Need Help Hooking to DXMD.exe

Homepage Forums Technical Support Need Help Hooking to DXMD.exe

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #200157

    I decided to reinstall Vorpx because I got a 3080, so I’m testing a lot of higher end games. I used to mainly use Vorpx for running the old games that have been converted to FullVR.

    I tried to lookup different information to solve the issue, but I can’t seem to get vorpx to properly hook to DXMD.exe

    To do some testing I downloaded Dark Messiah of Might and Magic, one of my favorite FullVR conversions. With minimal tinkering, DMOMM starts right up in vorpx just like it always did.

    I am on Pimax, and have my settings set according to the post here:

    Currently I am still tinkering and reading through pinned troubleshoot posts.
    Is there any specific reason it would hook to a game like DMOMM and not DXMD?
    Any help is appreciated.


    Also wanted to say I have all antivirus disabled and any non essential services shut off.


    One specific reason is that DMOMM is a directx 9 game whereas DXMD is directx 11.
    Which may or maybe not be related to the issue you’re having. Have you tried other dx11 titles?


    I’m not sure, I know I recently tried switching between DX12 and 11 to see if it could make a difference but it did not.

    I’ll try some dx11 games, do you have any easy recommendations?


    This is a list of dx11 games.

    Unreal Engine and Unity games usually work well with vorpx so you may want to try one of those. Bioshock Infinite, most if not all of the Batman games, Borderlands 3…most games published after 2014 are dx11.

    Again, the api used may or may not be relevant – at one point I couldn’t hook dx9 games but dx11 worked. Game overlays can cause similar problems, so I’d suggest just a quick test to see if it’s a general problem.


    Normally Deus Ex MD starts a launcher which then launches the actual game. It seems vorpX disables that and the game launches directly. If this isn’t the case for you try to start the game with -benchmark and/or -nolauncher.

    I have vorpX with the default settings (standard hooking method, no admin) and it hooks without issues. vorpX should also change game settings automatically, but make sure in the game’s display settings you have DX12 OFF, Fullscreen ON, Exclusive Fullscreen ON.

    While for me it hooks just fine, Z3D is only working in the menu, the benchmark and cinematics. During gameplay only interactive objects have depth. I see there are long standing issues with Z3D on this game. G3D works but for some reason just doesn’t look good in this game.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!