New 4k monitors –> bad VorpX performance now

Homepage Forums Technical Support New 4k monitors –> bad VorpX performance now

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #200880

    Hi there,

    I’ve been enjoying VorpX tremendously. With my old monitors, I ran World of Warcraft at 1920×1080 Full screen windowed, qraphics quality 10. VorpX just did whatever it did, and the game was wonderful on Oculus Quest 2 with Link.

    My video card was and still is NVidia GeForce GTX 1070.

    Now I got new 4k monitors. I upped my resolution to 3480 x 2160. Works great in Windows, works great in Wow outside of VR.

    But VorpX… no longer happy. I go in there, and it’s like 8 fps. Not usable. I thought VorpX automatically adjusts the game settings to make it work well in VR, but it looks like it’s not doing it.

    I tried changing the resolution in Wow back to what it was – still bad.

    I tried changing the resolution of the left monitor to what it was + the game down to the same 1920×1080 res, and it’s better, but not like it used to be! Plus it’s a huge hassle changing that, and having all my regular Windows stuff shift and resize and have to put it back after gaming.

    I tried reducing graphics quality in-game. Again, it’s better, but really not great how it was before!

    What’s the right way to have VorpX realize what it has to do with the monitor and game running at the higher resolution, at quality 10, but shift it so it works great in VR again like before?

    Thanks so much!


    The resolution you run a game with has a pretty huge impact on the performance. Going from 1920×1080 to 3840×2160 means that four times as many pixels have to be drawn as before.

    There should be no performance difference at all though when you change back the resolution to 1920×1080. If that’s really the case, something else has also changed. Can’t really suggest much more than resetting both the vorpX profile (in the config app) and the game’s graphics settings to default.

    Also try running the game windowed, just in case it does some internal upscaling to the native native monitor resolution when you set 1920×1080 fullscreen.

    With the same game resolution and graphics settings performance is the same regardless of your monitor’s native resolution.


    Ok so yes, I’m already running Windowed (and always was), so let’s rule that out for now.

    When I change the game resolution down to 1920×1080, the vorpX cursor is way off inside VR, like half a screen away. On-screen Wow cursor is fine.

    That’s why I tried changing the screen resolution for that monitor so that it matches the game resolution, but still very low fps.

    I will do the profile reset and see. Where do I reset the profile? There is so much information, I’m not sure what exactly to reset. Hopefully not the entire thing and all my settings, excluded programs, etc.

    I see a Restore Game Settings option. This tells me that VorpX does something with the settings. And I was assuming it would do what’s necessary to make the game work well in VR. Could you maybe point me to information of what exactly VorpX does to change a game to work in VR?

    Thanks much!


    You can reset each profile individually, either on the ‘Local Profiles’ or the ‘Trouble Shooting’ page of the config app.


    Ok, so in the end, it was a two-pronged solution.

    1. Reset the profile just like you said, under Local Profiles. Selected World of Warcraft and reset it.

    After that, I let VorpX launch Wow. It was better, however, still not great.

    2. I figured out the Wow in-game resolution settings
    > Switch to Windowed mode
    > Switch Resolution Scale down to the lower resolution (1920×1080)
    > Maximize the Wow Window so it stretches to fill the whole screen

    Now the game runs at full fps in VR again.


Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!