New runtime broke VorpX

Homepage Forums Technical Support New runtime broke VorpX

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #100620

    Okay so I managed to install VorpX however it seems completely broken , whenever I launch games through Vorpx they now always open the oculus home menu , the game displays on my monitor and a black screen (usually before intro cinematics) will display on the rift , Nothing else loads or displays on the rift after that.

    The game will be completely playable via monitor but not at all on the rift.

    Also I managed to get another game to open up but with a different conclusion

    I opened another game it displayed on my monitor perfectly but , I got like a oculus VR blank grid that displays which asks me to look at the center to accept and display my game , upon doing that it just loads forever and never displays the game

    am I missing something?

    I’ve had run untrusted oculus services checked and unchecked still to no avail

    It seems like anything related to oculus starts the oculus home viewer and from there on , VorpX does nothing except keep the blue light from my tracker on , games that ran before on unreal engine 4 just instantly crash , seems the only games I’m able to play are the ones just that come with the new 1.3 platform , nothing’s working on my end on the new update.


    The game shouldn’t display on the monitor if vorpX successfully hooked. If it hooks successfully, you see a black screen on the monitor and the game in the Rift with default settings. Pretty much like before with the last vorpX version.

    Oculus Home starting and the grey Oculus room showing before the game is normal though. That’s how they chose to handle things from now on.

    Side loading (“untrusted sources”) has to be enabled in Oculus Home.


    I’m getting the same thing. Sometimes the monitor goes blank and others the game displays there.

    Sound comes through my CV1 headphones no problem as if the game is running just not displaying. When I move my head I can hear sounds as if I am highlighting options on screen (Fallout 4)

    The Desktop viewer works but as soon as I try to load a game through that the CV1 goes blank.

    VR Games in Steam run no problem with Untrusted Sources enabled.


    Starting games through the desktop viewer isn’t really recommended anymore. Too many things that can go wrong with vorpX being enabled and then shortly again hooking a game now.

    This worked fine before, but since Oculus Home for obviously solely business related reasons now auto starts as soon as any Rift session ends, regardless whether it was started through Home or not, too many things that may interfere with each other are happening at the same time here.

    Long story short: use the desktop viewer for web browsing etc., but start games from your normal monitor.


    So how do I go about fixing this ? anything reccomended , I haven’t done anything odd or different from before Vorpx just seems to refuse to hook for me on 1.3

    Is there a way to go back to previous VorpX versions

    1. I don’t own a xbox 360 related controller I’ve always been a PC mouse/Keyboard rift kind of user
    so the new oculus home menu sucks to me
    2. I cant hook into ANY of my games anymore , I went through everything a solid 15-20 games and nothings working anymore.


    Please try the steps in the trouble shooting guide, especially regarding virus scanners. With new releases new issues with some virus scanners are to be expected unfortunately, so that should be the first thing to check.


    Like I said , Nothing is different , I don’t have any virus scanner programs that ever interfered with the VorpX injecting system or VorpX period for that matter

    all I did was uninstall 0.8 , and Install the 1.3 runtime and update vorpx

    EDIT: Desktop Viewer doesn’t even display for me either.

    Edit 2: For whatever reason the only thing that has hooked is CSGO , seems like everything refuses to hook for me aside from that , and I have no idea how …


    vorpX is different, hence some notoriously overzeleaous av programs will almost certainly cause issues until that is sorted out. Happens regularly after every new release.

    If you want to go back to an older version, please send a mail to support |at| vorpx com. Won’t get answered til tomorrow though.


    Any advice in updating to SDK 1.3 for DK2 ???

    The new oculus setup will not accept my DK2. It has a error box in the setup that says DK2 is no longer supported and will not connect to the device or personal tracker.

    I have tried the method of skipping the setup and switching to “allow unknown device” found here
    Anyone know how to get DK2 working on runtime 1.3? Please help.

    If I try VorpX I get this error because my DK2 is not setup and no longer supports runtime 0.8.
    Oculus runtime init failed

    Please tell me that CV1 is not required for new VorpX because I love my DK2 and have no intention of upgrading for a while.


    Fixed this issue. Had to update my USB 3.0 drivers to use oculus in USB 3.0 ports with run time 1.3.

    New vorpX works great for me now =)

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!