Not working for the games i wanted it the most (HTC Vive)

Homepage Forums Technical Support Not working for the games i wanted it the most (HTC Vive)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #102547

    So….as the title says.
    I managed to get it working for Alien: Isolation (Steam).
    Arma 3 (Steam) does not even start, and when i try it with Flight Simulator X (non-Steam), i only have a black screen on my Vive and the Monitor, but the game is running (i can hear the sound).

    I’m kinda pissed off. On the store page it sounded like it just plugs itself to all of those supported games, now it turns out that it works rather bad than good, at least for Vive owners from what i read here in this forum.

    So, does anyone have an idea about Arma 3 and FSX?
    I already disabled all possibly interfering hardware, HMD is in direct mode, and Steam VR and VorpX are running.


    For FSX please try to switch between DX9 and DX10. DX9 is preferred due to Geometry 3D support, but maybe Dx10 works better for you.

    Arma III only works in single player mode or on non BattleEye servers. The BattleEye dev some time ago decided that the way vorpX hooks into games is not the right way in his opinion. An attempt to discuss the matter with him to get back to the previous state, where vorpX worked fine with BattleEye, led nowhere.


    Thanks for the answer, but i did not help.

    I tried everything now for FSX:

    Started SteamVR first, second VorpX, third FSX.
    Started only VorpX, then FSX.
    Switched between DX9 and DX10.
    Changed resolution.
    Started FSX via the Steam library (i have the non-Steam version).
    Edit: OFC the Vive is in direct mode and i also tried starting VorpX as administrator.

    Nothing worked. Either i have a black screen on both devices, or i have the game screen on my monitor but on the Vive i still have the VR background that shows up when you turn SteamVR on.


    Small update:

    When i play FSX in DX10, i get the game shown on my monitor, the Vive stays in the virtual room mode.

    When i play in DX9, my monitor and the Vive show black screens PLUS the SteamVR overlay says “device not responding”. Restarted the HMD and SteamVR, but same error occured after i tried to start a flight in DX9.


    I have exact the same Problem, but I have the steam Version. FSX is the game I wanted the most with vorpX.

    In DX10 the game Starts at the monitor, but the Vive stays in the virtual room.

    With DX9 and vorpX running, the game crashes at once.


    I had the same problem. Unfortunately they dont reply to any request. I requested my money back as it is useless, of course, never replied to me never refund me. Total waste of money. Wont recommend it in all the forums Im.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!