OpenXR Error for Bioshock and other games

Homepage Forums Technical Support OpenXR Error for Bioshock and other games

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #214251


    After reinstalling windows to get the latest Vorpx working as i had issues…I now have issues when running the 21.3.2 version to play bioshock and other titles. Some games work fine like MK11/Amnesia and Dead Souls 3…..But the games i wanted to play(Bioshock 1 and 2) i get a starnge startup error.

    I have a Valve Index with Steam VR running and selected in Vorpx. I inject the profile and i get this error…..

    OpenXR instance creation failed
    This is a severe error.Make sure that OpenXR is working correctly on your PC or switch to a different VR API in the Vorpx config app

    The game seems to appear on desktop and i can see that vorpx has been injected but then that error appears shortly after game boots…and Steam VR doesnt boot the game at all.

    Ive tried different settings in config…but as i say some games boot,most dont.

    All drivers up to date and Steam VR games running fine.

    Anyone help? Kinda frustrated at this as ive been at it for about 5 hours trying to fix this. Again its strange that some games boot fine but the ones i downgraded for dont.


    Contrary to Valve’s announcement two years ago or so their OpenXR implementation isn’t spec complete in any way. It entirely lacks 32bit support (would be necessary for older games like Bioshock), and also has a spec breaking issue where they swap the behavior of two functions used to initialize a frame, which breaks the purpose of splitting the OpenXR frame init into two functions and makes their OpenXR implementation pretty much useless in more complex multithreaded scenarios.

    Long story short: stick to SteamVR. There is no point in using Valve’s OpenXR. It’s broken without hope of getting fixed (they have been made aware of both issues mentioned above by several people for years) and basically just a wrapper to SteamVR anyway.


    Ye ive not changed anything..Im sticking to Steam VR for everything.

    But as i say i still get the OpenXR error whe nrunning a majority of the games.

    I downgraded to the version that runs Bioshock 1 and 2 and i select them but that error appears. The game boots up on desktop and i can see that its injected Vorpx but then that error appears and it doesnt boot up in headset.


    Please double check whether SteamVR is selected in the vorpX config app, OpenXR messages (obviously) only are displayed in OpenXR mode.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!