Potential problem with IPD?

Home Forums Technical Support Potential problem with IPD?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #188595
    madcap
    Participant

    I tried playing Crysis Warhead but could barely stay in my HMD for more than a minute. It felt like the IPD was way off and I could feel the muscles in my eyes straining (it took a while to recover afterwards). I also noticed it in HL2 when I briefly tried it, but it wasn’t as intense. I don’t have this problem in any VR title or VR mod (doom3bfg vr mod for example).

    I’m using a Rift-S. My measured IPD is ~63 and I feel I fit perfectly in this HMD. I have tried adjusting the digital IPD in Oculus and even went to both extremes but it made no difference.

    In-game I played with 3d geometry scaling and even disabled it, but I could still feel the pain. I also noticed I couldn’t focus on a lot of text (when looking at a gun on the floor a 3d popup displays with text) without closing one eye. It was doubled.

    Could there be something wrong in the IPD translation? I looked online and it would seem that VorpX did have a manual IPD setting, but it was removed and now works directly with the value in Oculus (currently at its default 63.5). Is there an override or any way to add an offset, assuming this problem is IPD related?

    #188597
    Ralf
    Keymaster

    IPD is handled by the Oculus runtime, not by vorpX. vorpX works just like a native app that regard.

    If a game has a scalable HUD, you can change its depth on the ‘Image’ page of the vorpX menu, which may help with text rendering. vorpX does not provide a scalable HUD for every game though.

    #188598
    madcap
    Participant

    The digital IPD in Oculus does little or nothing for me. Apparently it helps with scaling for some people, but it couldn’t do what I have experienced because the displays are fixed. Assuming it has nothing to do with IPD what else could be causing this incorrect rendering? When moving the HMD off and on in this game it caused a lot of refocus which quickly created discomfort in VR (fairly intense eye strain – unplayable), where on VR titles it is an almost seamless transition.

    I just found your update regarding hud scaling. brb.

    #188599
    Ralf
    Keymaster

    I can’t really imagine anything causing that, and also don’t recall to have heard of anything like this. vorpX only handles the IPD in ‘Generic Headset (desktop mode)’. In Oculus/SteamVR mode, the camera center is the image center and everything IPD related is done by the runtime.

    Might be worth a try to reset the profile to default, just in case you fiddled with settings in a way that causes your issue.

    #188600
    Ralf
    Keymaster

    One more thing:

    If you have expert settings enabled and are playing in cinema mode, it’s probably possible to break the image alignment with the ‘Focal Offset’ (convergence) setting. If that’s the case, change it back to 0.0.

    #188601
    madcap
    Participant

    Lowering the Hud Depth to 0.70 stopped the double vision on pop-up text. I’m still get that instant discomfort the moment my eyes pick up the 3d world. Can I test it in Generic Mode with this headset?

    #188602
    Ralf
    Keymaster

    Generic mode only renders to the desktop. It’s largely a leftover from the very early days of VR when VR headsets were treated as a second monitor, not as a special device type.

    #188603
    madcap
    Participant

    OK, thanks. I reset the profile and lowered the hud scale, which resolved that issue. It still feels intense on the eyes but maybe this is just how 3d geometry is working on this game. Lowering/disabling the 3d strength seems to give a little relief, but the scaling goes off. I didn’t notice any eye strain in FEAR.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.