Problem with Black Mesa reflections/flashlight

Home Forums Technical Support Problem with Black Mesa reflections/flashlight

  • This topic has 13 replies, 2 voices, and was last updated 1 month ago by Ralf.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #188450
    keem85
    Participant

    Hey there

    I’ve tried to solve this weird bug for several hours now. tested all gfx settings, dx9, opengl etc etc. Not able to solve this…

    The issue is that shadows, reflections and flashlights only shows themselves on 1/4 of the screen. It’s super weird!! Here’s a pic: https://imgur.com/a/lZxyJRu

    Works fine on pankace.. Any ideas?

    #188476
    keem85
    Participant

    Any ideas guys? This is driving me nuts!!! It’s literally the ONLY issue I have with BMS..

    #188485
    Ralf
    Keymaster

    First please make sure to use the latest paid Black Mesa on Steam. The right graphics API would be DX9, but I don’t think that can be changed anyway. Older free versions are unlikely to work correctly.

    If you already use the latest paid Black Mesa, it would be great if you could send a savegame to support |at| vorpx com. The flashlight works fine here at the beginning of the game after getting the suit, but who knows.

    #188486
    keem85
    Participant

    Thanks Ralf. Yes I am using the latest. I will be sending you the savegame shortly

    #188490
    Ralf
    Keymaster

    One more thing: if by any chance you are currently using one of the game’s beta branches, please opt out on the ‘BETA’ page of the game’s properties dialog in Steam (right click the game name > Properties > BETAS).

    #188491
    keem85
    Participant

    I’m not in beta :).. I noticed that this issue is not present if I start the game in pancake mode. Only when I start it with VorpX. I also tried several profiles and resetting BMS profiles from within VorpX also.. Not sure what causes this.. I would be willing to bet that it has something to do with resolution. Maybe the game gets confused every time it enters vorpx

    #188493
    Ralf
    Keymaster

    Such things usually are related to special shader definitions not being applied, e.g. when they become invalid after a game update. Hence using the latest official (non-beta) version is important. If you havn’t done that already, please also try to reset everything to default. vorpX as well as the game options (aside from the 4:3 resolution).

    There is no need to apply any tweaking at all for this game aside from using a 4:3 resolution. The default profile with default settings is perfectly fine.

    If that still does not help, I’m happy to check your savegame(s) here.

    #188494
    keem85
    Participant

    I am at work now, but I will try to reset BMS when I come home. But it’s not possible to change resolution in VorpX for this particular game. I had to set resolution arguments on BMS.exe in order for it to load correct 1920×1080 resolution.. If I don’t do that, the game looks like 8bit nes

    #188495
    Ralf
    Keymaster

    16:9 resoltions do not work. You should see a hint in the top left corner of the game window that suggests to use a 4:3 resolution (e.g. 1600×1200, 1920×1440 etc.) whenever you start the game with a non 4:3 res. Please take this hint seriously, it’s shown for a reason.

    Using a 4:3 resolution is ABSOLUTELY MANDATORY for any Source 2 engine game, otherwise the DirectVR FOV does not get applied correctly.

    #188496
    keem85
    Participant

    Yeah. I have tried 4:3 resolutions also, but when changing resolution WHILE in VorpX, the game always hangs. It’s not possible to change the game’s resolution while VorpX is running.. Do you have any other suggestion for me? Are there any VorpX setting file where I can sett this manually? I tried setting it on videoconfig.cfg of BMS folder, but it had no effect at all.

    #188497
    Ralf
    Keymaster

    If the game crashes while you select a 4:3 res, you can do that before launching it with vorpX. Shouldn’t crash though, at least it doesn’t here, sorry.

    As said above, using a 4:3 resoution like 1600×1200 or 1920×1440 is mandatory, hence the according hint when you start the game.

    #188501
    keem85
    Participant

    No I tried now. It works changing resolution in pankace, but the settings I set in pancake will not be brought over to VorpX… VorpX always resets the setting to 1280 x 920 instead of 1280 * 1080.. I think Vorpx is the issue here, not BMS.. Are there any vorpx settings where I can manually set it to 1280 * 1024?

    #188502
    keem85
    Participant

    Correction: Max resolution for BMS is 1280 * 1024, but VorX sets it to 1280 * 960 no matter what I do.. Can I set it manually somewhere?

    #188504
    Ralf
    Keymaster

    The flashlight is working fine here with the savegames you sent, so there is no problem with the 3D-profile.

    Resolution is handled by DirectVR, you can change it on the DirectVR page of the vorpX menu after successfully adding the 4:3 custom resolutions to you PC or setting the game’s display mode to windowed.

    I can’t really do anything else than recommending what I recommended in the Reddit thread a few days ago already, sorry again.

    In a nutshell: reset everything to default, DO NOT tweak anything afterwards, setup 4:3 custom resolutions for your PC and let vorpX do its job. The Black Mesa profile automates everything, it works out of the box.

    If by any chance you had used some other 3D-software before with the game or maybe some image enhancement shaders or similar things, it might also be worth a shot to empty the Windows DirectX shader cache.

    I’m really out of ideas now.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.