Question about Quake and Vorpx 9

Homepage Forums Game Hints and Settings Question about Quake and Vorpx 9

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #90767

    Hi everyone,
    First I’d like to congratulate Ralph for this amazing software. Specially now that Vorpx 9 is out (and Extend mode is finally gone!)

    I’m just having problems with Quake, and I wonder if someone has any info on this (maybe someone in this forum already played Quake with Vorpx)

    I checked the “Game Compatibilaty Page”:
    And apparently Vorpx supports Quake, but it says “Quake with DX9 mod”

    But I’m not sure what mod is that… There’s a post where Ralph tells someone to use “DXQuake”,

    But I guess that was a mistake, because “DXQuake” is a DirectX 8 version of Quake, and Vorpx …

    Anyway, if there’s no Directx9 version: I do have the OpenGL version of Quake, but it doesn’t work properly (one of the Oculus lenses is always red, Vorpx even shows a message that says “recommended resolution: 1920×1080”, But I already changed the resolution to that (Vorpx even shows that I am using the 1920×1080 resolution already, but it stills recommend 1920×1080)

    Another alternative is buying Quake on Steam. But I don’t know if it works with Vorpx…

    So, I have 3 options:
    1-Find the correct DX9 versions of Quake
    2-Make the OpenGL version I already have work properly
    3-Buy the updated game on Steam

    I’m OK with any of them, I just want to know if anyone can help me make the game work properly (If not, then can someone confirm that the Steam version works with Vorpx 9?)

    Thank you!


    I think what they mean is you have to launch quake with dx9, sort of like Bioshock 1 I think.. what you do is inside properties(right click, go to properties) then in the field and -DX9.. now I don’t recall what field and the exact thing you have to type in… but it should be something like that.. you should be able to find more info I’m just trying to point you in the right direction… Its easy once you figure out what field to change.. I just don’t remember right now.


    Hi Karlor,
    Are you talking about creating a shortcut to the game EXE file, and add command line arguments to it?
    I had to do that, to change the game resolution like this:

    G:\glquake.exe -width 1920 -height 1080

    Adding -DX9 doesn’t seem to work here, I have the OpenGL version of the game. I either need to make this openGL version work properly (at the moment, one of the lenses is red) or find the correct DX9 mod… I don’t know if the Steam version is the correct version to play with the Rift

    Thank you!


    Yeah I’m pretty sure that’s what I was getting at. There might be an actual mod but I don’t know.


    Well, this thread is old, but I found an answer: You need the Quake engine called “DirectQ”. It is based on DirectX 9. The original creator of DirectQ apparently no longer has a homepage. But the “DirectQ 1.9.0” can be downloaded from here:

    Works nicely for me, i.e. both eyes are rendered correctly in 3D. The only problem: the VorpX menu does not work. I.e. hitting the “Del” key does not show the menu. So you are stuck with the default 3D settings.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!