RDR2 attaching / hook err / gfx state error

Homepage Forums Technical Support RDR2 attaching / hook err / gfx state error

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #192459

    Howdy !

    I can’t, for the hell of me, make RDR2 start with vorpx.
    I tried to re install newest nVidia gfx drv 442.19
    I reseted in game gfx options
    disabled afterburner
    disabled antivirus

    The only reward i’ve got for my endless efforts are errors like :



    Vorpx program’s hang error windows saying “this takes a while, choose what to do: close / wait / do nothing”.

    Whatever i did i never saw Vorpx hang on this game properly. My heart is broken. I wish i could head up to Valentine town today. Please help !


    Steam version I guess? Check the release notes for yesterday’s hotfix.

    If you want/need someone to blame, the correct addressee is located in ‎Bellevue‎, ‎WS, United States, which incidentally is the location of Valve’s HQ. ;)


    Oh i see… do you mean you have the exact same both issues on your side ? Yesterday hotfix didn’t help unfortunately. As for Valve, i’ve already blamed them a couple of time when they broke SteamVR. As many big companies they’ve became blind at user’s feedback. I’m affraid they have already put a flag on me ;)


    Did you read the post linked above? Yesterday’s hotfix does not help since it reverts a change from a few weeks ago that made the Steam version of RDR2 work in the first place. Was necessary since without doing that the latest Steam version could get caught in an infinite update loop.

    Help is on its way though. Much faster than expected I found a way to make the Steam version of the game work again without the earlier method to block the Steam overlay. A fix will be released either later today or tomorrow. Caveat: if you use an Oculus headset, you will have to switch vorpX to SteamVR mode for RDR2/Steam. Apart from that little inconvenience all will be back to normal in less than 24hrs.


    I did but my english may have some weak points, sorry ;) Help is on its way ?! Woow ! That’s great ! If i can see Valentine in VR today, you will be the real hero of the day !

    oh! and i’m using a Valve Index kit btw. :D


    vorpX is available now. The Steam version of Red Dead Redemption II is working again.

    Note that Oculus users will have to switch vorpX to SteamVR in the vorpX config app for it to work. This only affects the Steam version, the Rockstar version still works in native Oculus mode as always.


    Thank you Ralf for adressing this so quikly !

    Unfortunately, and i hate to have to say this, for some strange reasons that needs to be unfold, vorpX can’t hook to the game even with the update.

    Let me discribe: on desktop view, i can see the hook message pops in and out and the game’s image is flashing as if two different resolutions were fighting for one display. Also, i can hear the sounds in the hmd’s speakers but no image display in hmd. I also get the “this take a while” message from vorpX.

    What can i do ?


    Sounds as if the update didn’t get installed properly as that is pretty much what happened for the last two days due to the changes Valve made in the latest Steam release. Works here again with an Index, should also work for you.

    Try a factory reset in the vorpX config app (trouble shooting page) and if that also doesn’t help, do a full reinstall.

    Also still get rid of any unnecessary background processes, particularly things definitely also hooking into games like Afterburner that you mentioned above.

    On a general note: while it’s too late for you in this particular case, it’s usually better to get games that need another DRM client on top of Steam DRM directly from the game publisher if possible instead of Steam. Avoids potential issues like this one in the first place.


    well, here is what we can take note of:

    Reset vorpX to factory settings did allow the hook to occur properly.

    Import RDR2 profiles [official or Dellrifter22] from the cloud made the issue to strike again as before (as discribed previously).

    Reset the RDR2 profile to factoriy settings did solve the issue again.

    In every cases vorpX whatcher won’t trigger the hook if Bitdefender is active even if i make program exceptions properly.

    Afterburner isn’t a problem here.


    Do not download a cloud profile, that overwrites the updated profile that was just installed when you updated vorpX. There is no need to use a cloud profile, the vorpX update comes with a new one that works.

    Afterburner and similar programs should always be disabled since they hook into games in the same way as vorpX. That’s never good, even if you think it doesn’t cause any issues.

    Also get rid of BitDefender, one of the worst known offenders in regard to AV programs that cause hooking issues with vorpX. It has a feature, ironically named “Advanced Threat Protection” or something similar, that rather unadvanced flatout blocks Windows functions that vorpX uses to hook into games. Even if you “disable” BitDefender this feature will still be enabled. You have to disable it separetely.

    If you are on Windows 10, just uninstall it. Windows Defender will kick in instead, no real need to use any invasive third party AV on Windows 10.


    Hey Ralf, about Afterburner, i use it mostly for the custom gpu fan curve but i’m not sure if what you say would apply then too, i tought it was a global (OS) setting. Any link to read more about it would help a lot, thanks for the info tho


    All tools that like Afterbuner have the ability to display an overlay in games hook into the same Direct 3D functions that vorpX also hooks into. While that doesn’t necessarily have to cause problems, it’s a scenario that should best be avoided to be on the safe side.

    CPU/GPU tools of any kind and FPS counters are the obvious candidates, less obvious are various messenger apps like Skype etc. and generally anything that can show ingame notifications and/or grabs/records/streams games. Always better not to use such tools together with vorpX unless you really have to for some reason.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!