Rotation scan problem on Vive

Homepage Forums Technical Support Rotation scan problem on Vive

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #124631

    I didn’t have time to experiment during the week, but today I spent the whole day in testing the new vorpX with Skyrim. There were lots of crashes because of mod experiments and a lot of restarts. I’m using Vive.

    Everything works perfect, when it does work. I have a problem with the head rotation after a Direct VR scan. It fails to work about 80% of the time. Restarting the game and PC doesn’t fix this. It happens in vanilla Skyrim also.
    Half of the time the scan reports success, the other half reports failure. But the result is the same – there is no head rotation. At some point, after several game restarts and about 5-10 tries it works. I haven’t managed to find a pattern.

    I saw another similar post but I haven’t tweaked the controller settings. I did try to change them to see if there is a difference, but there is no.

    Any ideas how to fix this? Thanks!


    Haven’t heard of that regarding Skyrim yet, which is very reliable here and only very rarely fails. What seems to be a bit wonky is the Bioshock Infinite scanner profile, but I almost expected that.

    What can help in case of failures is changing the starting position/rotation or loading another savegame in a different location. Also make sure to absolutely not touch the mouse during the scan.

    In case you use any security/antivirus software that may monitor memory access, disable it. Such a program almost certainly would interfere. If you use anything else, I would recommend Windows Defender.

    Other than that unfortunately I can’t really say much else than the disclaimer on the scan progress screen says already: such a memory scan isn’t 100% reliable, may cause issues incl. crashing a game sometimes, and even might not work at all on some machines/configurations.


    I think I can guess in advance when it is going to work. There is a slight zoom-in just before the scan starts and it is always successful when this happens.

    When it fails I try rotating in different direction, even wait to move to another cell. But it doesn’t help.

    I’m pretty sure this is something related to my setup so I’ll continue to experiment.


    One more thing I forgot above: might make sense to disable gamepad input in Skyrim’s options menu. Shouldn’t be necessary, but can’t hurt.


    Do you try to do the DirectVR scan in Helgen during the intro mission? I’ve also encountered several failures of the DirectVR scan during that mission. Afterwards, however, it worked fine.


    I’m on a CV1, win10 intel-i7 and an Nvidia 1080 and I can reiterate having a similar issues.

    When I first booted up Skyrim SE and did the first scan it worked great, had to tweak some controller stuff (had disabled the gamepad emulation to get it to feel just right, always felt off when emulating) and invert the y-axis, but it worked flawlessly.

    My second play session I had to scan several times and had some issues but eventually got it going again.

    Today’s attempt at playing though never worked. Scanning became very problematic (many failures and crashes) and I just never got it working again.

    Are there any other tips to getting a good successful scan? I’ll try disabling the gamepad when doing the scan next time, then try re-enabling it, or goin in or out of locations to try scanning in different load zones (if this makes a difference?).

    I tried one of the other profiles from the cloud at some point and had problems, but I seem to remember that when I re-loaded the default VorpX profile the scan worked fine, then I just had to re-tweak my control stuff (disabling the HMD only allowing verticle tracking and disabling controller emulation and invert-y)

    Perhaps one of the settings I’m changing makes the scan much more likely to fail. I suspect that it might be the case that I have to load the default Vorpx profile before each play session then change settings after the scan is complete, but I’ll need to test this more to come to any definitive conclusion.

    As a side note however: The new gamma/saturation/sharpness sliders are working MIRACLES in making these games looks SOOO much better than they did before!


    I think I’ve found the problem. It seems the rotation after scanning always works now.

    tl;dr : If you have trouble scanning try disabling HT Positional Tracking from the Head Tracking page in the vorpX in-game menu.

    I was thinking that my problem is that the scan usually thinks it has succeeded but the rotation doesn’t work despite that. And then I noticed that the positional tracking has an interesting side effect in some situations (in free camera mode the position tracking can affect the player character model causing it to slide left or right as you move). Then I remembered your remarks about how the position can interfere with the rotation.
    So I made an experiment this morning and tried to not move at all before running the scan. Then tried clicking the position reset before running it. Both didn’t help much.
    Then I thought – my POV is always at the level of the PC’s chest and not the head for some reason (I haven’t changed the value for that, it is at 0, also I have played seated all the time yesterday). Maybe this is enough deviation to mess with the rotation. So I disabled the positional tracking from the menu and since then it always works (tried it 5 times).
    Another interesting thing is that even after disabling the positional tracking my POV is still at the chest level.

    Interesting experiment. Go to a forge or a similar object that triggers an animation. Start using it and start rotating your head in RL – not move left or right but only rotate your head. You will see your character rotate in sync with you.


    @ rtoast: not much that I can add to my post above, sorry. The crashes sound especially odd. There always is a certain chance of failure though and it may be higher on some machines than on others. That is the reason for the message in this regard on the scanner screen.

    In case of Skyrim I would recommend to alternatively try the original, with a bit of luck that solves your issue easily. From the vorpX perspective there’s not much reason to use the SE anyway. The original likely will run better with vorpX unless extremely many and/or memory hungry mods are used. So if you don’t absolutely crave for the new color scheme they are using in the SE, you can’t go wrong with the original Skyrim for vorpX.

    What is very important is that you don’t move the mouse during the scan. So just in case: take the hand off the mouse as soon as the scan starts. May even be worth a try to try another mouse, just in case the one you are using sends some input although it shouldn’t. That is a *very* long shot though and quite unlikely. If you use a virus scanner other than Windows Defender: get rid of it. Some of these programs may monitor memory in a way that interferes with the scan process.

    I can’t really think of any setting that may have an influence, but just in case I overlooked something, it may be worth a try to do a full factory reset in the config app and try again afterwards.

    BTW: the gamepad emulation is supposed to be disabled automatically in case of a successful Direct VR scan since it isn’t necessary afterwards.

    @ prinyo: that’s an interesting observation. It shouldn’t have any effect, so it may just have been a coincidence, but one never knows. I’ll certainly check that.

    Camera height: First recenter the head tracking (ALT-SPACE or in the vorpX menu), that makes sure that the camera is at the game’s default height. That is still not what you would see in real life though, these games are made for monitor gaming, their camera height is adjusted to look good on a monitor, not for real life camera height that would be used in VR. You can apply a modifier to the camera height in the vorpX menu, but that can (and likely will) have side effects.


    I tried it again the other day and this time I didn’t turn on my game pad at all (I’m using a wireless Xbox one controller) until after I was in game and performed the scan.
    First scan was successful and worked flawlessly, so afterward I just turned on my game pad and started playing. I didn’t test any further so I don’t know own if that sequence helped or if I just got lucky. The experience was so amazing I just got sucked into playing for like 3 hour, haha.

    I should go back and check out, original Skyrim as that is where my original character/save file is, but framer ate so far is fine in the SE. I do prefer the color palette of SE and the upgrades to all the vegetation etc. It’s like running the original with a bunch of mods but not having to deal with all the hassle.
    Hopefully the framer ate doesn’t tank when I go to other areas like whiter until etc, but so far it’s good


    I didn’t have time until now to play after the latest update. But now it is completely impossible for me to have the rotation tracking working with DirectVR. Before the update if I disabled the position tracking the scan was always successful. Now it never works. It does say Success but there is no rotation tracking.

    With or without DirectVR now there is an audio problem – when you face a NPC their voice sounds like coming from several rooms away. To be able to hear them I need to turn my head so my ear is pointing to them.

    Both those problems appeared after the last update, it was working nice before that.
    I restarted the game, the PC several times, even reinstalled VoprX and did the optimization again – nothing helps.

    Also it would recenter and show me the red message randomly without me moving at all. Any ideas what in the last update that can cause those problems?


    Found the problem. The First Person Plugin mod is now incompatible.
    Removing it fixes the problems.


    Ok, just wanted to chime in with an update.

    After trying a multitude of times now I feel fairly confident in saying that the problem for me is the game pad causing the issue.

    Without exception, every time I have tried to launch Skyrim with the game pad already turned on (wireless Xbox one gamepad) the direct vr scan will NOT work. It will either crash, fail, or succeed in the scan but still fail to work.
    If I launch the game with the gamepad off, navigate with the mouse until loaded into the actual game, do the scan, THEN turn on my gamepad after the scan, it will work just fine every time!

    Just to reiterate, this is the vanilla Skyrim SE, no mods, no plug-ins, no ini tweaks!
    Get into the game first, do the scan, and THEN turn on your gamepad (Xbox one wireless) and it works flawlessly for me every time.


    Please make sure that the gamepad override is set to “full” (the default), that will very likely help with your issue. That is all supposed to be handled automatically for the scan process, but isn’t fully due to a stupid glitch. For now (and in general) better leave the gamepad override setting at its default setting for a game. The default is usually chosen for good reason.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!