Shader control without g3d ?

Homepage Forums General vorpX Discussion Shader control without g3d ?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #207830

    Is it possible to have shader authoring without actually using g3d rendering ? There are many games where playing with a huge screen has the issue of ui being too far in the edges, but smaller screen mean you see the borders and lose the advantage of being in a vr view in the first place.

    Ive been in a few cases where it would have been great if i could have the huge (larger than the view) screen for immersion sake, but shrink the ui closer to the middle of the screen, which you can only currently do in g3d as the shader authoring tool seem disabled when g3d is not enabled, it would create a few more scenarios where playing with vorpx would be superior to playing with regular monitor.


    For D3D11 and 12 that will be incidentally be available with the next vorpX update.


    I’m pretty sure you can already do this (scale the HUD) for profiles that have UI layers assigned – even in Z3D or 2D mode. If the HUD sliders are visible on the vorpX menu Image Settings page, then something has been assigned. If there are no HUD sliders visible, that means nothing has been assigned yet.

    You can use the G3D shader authoring tool (Ctrl+End) to seek the UI shaders and assign them to HUD treatment. You might have to temporarily enable G3D rendering to do this, but once you have assigned the right layers to be treated as HUD, you can then disable G3D and now be able to scale the HUD from vorpX menu in any 3D mode. Or at least you can do this with dx11 games, but maybe not dx12.

    Edit: oh great Ralf. Thanks.

    Any way we can add “do not render” assignments that apply to Z3D as well? I’ve been using the “hide shader” scan tool to temporarily hide depth breaking transparent window glass shaders in Mafia Definitive and RDR2, but having a proper toggle for things like that and unwanted crosshair/hud elements might be better.


    ah, i didnt think to just try with a broken g3d profile to set the shader for the ui then turn g3d off. (the specific game i was thinking off is Icarus, but i couldnt find a profile that gave functioning g3d with it, they all had the right eye black sadly).

    I’m gonna give it a try tonight. if it doesnt work, ill just wait for the next vorpx update. thanks Ralf

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!