Skyrim gamepad Y-Axis broken after VorpX update

Homepage Forums Technical Support Skyrim gamepad Y-Axis broken after VorpX update

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #191748

    My settings were great before but a patch has broken them.

    I am running normal Skyrim, not Skyrim – SE and it’s been working fine. I haven’t played in many months and last night, VorpX updated to 20.1.0. The profile was updated for Skyrim. The gamepad emulator mode has never worked for me and I’ve always set Override X-Box Gamepad to Off. This time, I do this and everything works fine except the Y-axis on the right thumbstick. I cannot look or move the camera up or down. If I move the right thumstick slightly to the right or left so that it’s mostly Y-axis but just a little bit of X-axis then Y-axis does respond but it responds only very slightly. It’s by no means a workaround but I shows that there is some input happening somewhere. The closer I get to true up/down Y-axis, the up/down motion stops entirely.

    This is definitely a bug because if I exit VorpX, right thumbstick works fine.

    Somewhere, the Y-axis is being overridden by VorpX even with Override X-Box Gamepad set to Off. Head tracking is disabled and all other settings are from the cloud Skyrim profile (default) for 20.1.0.

    I’m not sure which new patch version broke my stuff since it’s been a few months.


    I think I found a workaround although I think it should still be considered broken because ultimately the Override X-Box Gamepad set to Off isn’t really set to off. It should use default X-box controls but even after setting to off I had to set other settings to off also.

    I did these steps:

    1. Performed a full factory reset.

    2. Opened Skyrim and made the following changes in the VorpX in-game menu:

    Override X-Box Gamepad=Off
    VorpX Gamepad Buttons=Off (Why is this necessary when override gamepad is off?)
    Changed FullVR Right Stick Y Sensitivity from 0.3 to 1.0 (Why is this necessary when override gamepad is off?)

    Before I did these steps, right stick Y sensitivity made no difference but now it does.

    I hope this helps someone. I will report if my workaround has further issues.



    The y-axis sensitivity for native gamepad handling has been introduced in the last version. It’s pretty useful in FullVR mode typically since it makes it harder to accidentally look up/down with the gamepad. If you don’t like it, just set it to 1.0.


    Bethesda games fall in the category of games that don’t allow mouse and gamepad to be used at the same time, hence the gamepad handling might look a bit unintuitive at first sight. Everything is setup as it should per default though. Before you run the DirectVR scan, the gamepad override should be on. Otherwise head tracking will fail since vorpX emulates a mouse for head tracking before running the scan. After the DirectVR scan that is not necessary anymore and the gamepad is automatically set to native (override off).

    Leave these settings at their default values. I can guarantee 100% that’s what you want to happen, i.e. override before scanning, no overrive after scanning.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!