Skyrim + Vive

Homepage Forums Game Hints and Settings Skyrim + Vive

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #101846

    Just want to dispense some observations that I have learned from tweaking vorpX to work for skyrim.

    What makes a game VR ready?
    How well you can keep the vertical in a 1:1 sync.
    Horizontal rotation can be slower, faster, doesn’t matter.

    When I finally stumbled upon the right sensitivity settings for me that kept the vertical rotation as close to 1:1 as possible. The comfort level literally skyrocketed. And mind you I don’t even get sick in the first place and I could tell an immediate difference.

    Now here’s the problem. The sensitivity settings + vorpX GUI settings, to achieve such fluid comfort, makes horizontal rotation much slower than I’d like. Is there a way to specifically tweak just horizontal Head Tracking? The option disappears when you do a full override of the xbox controller. And the only other screen that allows you to mess with the rotation sync rates just does a general for all axis.

    Also. What’s the likely hood of games being able to know when y rotation is at 0 degrees for the camera in the game? I’m wondering if it’s possible to inject something that can watch for that and make it so the program will speed up or slow down rotation on the vertical axis to always make it so looking straight ahead syncs it up with looking straight ahead in the game. It can be slightly out of sync when not looking straight ahead.

    For example.

    Looking Straight down in game + Looking at a 45 degree angle down in RL = OK
    Looking Straight ahead in game + Looking up or down 10+ degrees in RL = BAD

    It needs to be:
    Straight ahead in game = Straight ahead in RL. If you can make this program accomplish that you will solve 90% of the motion sickness issues attributed to vorpX.

    Almost forgot to add.
    The way that I determined I was getting as close to 1:1 vertical sync as possible?
    I made is so I could see my chaperone wall. And used that as a reference to help sync it up and I just kept messing with sensitivities in game, and in vorpx until looking up and down, always ended up with looking straight ahead within a 5-10 degree margin of error. I’d like to get it below 5 degree margin of error. But I don’t think it’ll happen.


    When using headtracking as thumbstick, you allow us to modify x, y sensitives seperately.

    But when doing a full override. You cannot do the same for the mouse x, y sensitivities.
    Your only option is that general HT sensitivity on one of the other setup tabs.

    Almost forgot to add something else that I noticed about the vertical sync and what happens as it get to be more 1:1.
    It helps your brain to develop a sense of scale for everything from ramps, stairs, columns etc. When you’re constantly having to correct your vertical alignment with an alternate control method, you lose a bit of that.


    Don’t use the term vertical sync for head tracking scale, it means something entirely different. Had me confused there for a second ;)

    Have you enabled the expert mode in the vorpx settings?
    I am not at home right now, but I am pretty sure you can change vertical and horizontal sensitivity separately. An even better solution would be to directly configure skyrim for 1:1 horizontal to vertical sensitivity:
    Under [controls] in Skyrim.ini (Found in “My Documents\My Games\Skyrim”) there are two entries.
    Change the YScale to match the XScale. If you do not have entries for fMouseHeadingXScale then just add them. Also set “bMouseAcceleration” to “0”

    If you want to make sure you’re RL head orientation lines up with your ingame orientation, look straight ahead and use alt+space.


    Ty for the tips. I did turn off acceleration in the vorpX gui. I wonder if the game still applies its own anyway?

    I have not dug into expert mode yet. I’ve mostly been loading the default profiles for each game and going from there.


    I have noticed some strange y-axis HT sensitivity in Skyrim before. I found it had to do with the FOV. Sometimes the y-axis sensitivity would go severely down compared with the x-axis and feel odd/warped when I looked up/down. This problem would correct itself if I opened the in game map and closed it (which resets the FOV, which I changed to 120 deg in the skyrim ini).
    I found using the VorpX set fov (ie the skyrim console FOV=120) would not solve the problem and only opening and closing the map worked for me.
    I use mouse for HT and not x-box controller.


    I ended up having to bump fov to 125, thinking about going a little higher, with all my other settings to get that vertical rotation almost 1:1 now with minimal distortion.

    Some other things I have tried. When I force the ini to 960×1080 resolution, I get an almost perfect game, if you disregard the horrible pixelation. So then I bumped it to 1080×1200, to match the vive. And I started getting issues with water in the distance appearing all weirded out. IF anyone knows a sure fire way of dealing with the wall of water issue I’d appreciate it.


    I am not sure about the water. Do you use any water mods?
    I find in geo3D setting the focal distance up (0.3 – 0.10) did make a more real full size feeling game but can mess with the reflection and sky convergence.

    1080×1200 is not 8/9 resolution like 960×1080. If you can make a custom resolution to keep 8/9 try 1080×1215.

    One thing I have definitely noticed in skyrim is the water will flashy glitch-out and npc and creatures will bob and jump around if you force a non-compatible resolution on your display.

    For example I play with 1440X1280 (z-3D to keep the frame-rate up). And it works great in the DK2. But if I play just on my monitor with these settings the water flashes in and out and mammoths bob around like rocking horses. I get sound glitches and actors pop up and down. If I go to 1920×1080 and play on my monitor everything returns to normal. All resolutions seem to work properly in the rift, However stereo 3D seems to only work for me at proper 3/4 8/9 resolutions.


    In regard to possible rendering glitches it might be best to stick to aspect ratios that are natively supported by the game. If you have glitches with uncommon resolutions that aren’t there otherwise, try something that the game supports directly, e.g. 1600×1200.

    I’m not sure how this affects Skyrim, but Fallout 4 for example has various glitches with resolutions that are not really supported by the game. Considering that Skyrim is based on an older iteration of the same engine that might also be the case here.


    An even better solution would be to directly configure skyrim for 1:1 horizontal to vertical sensitivity:
    Under [controls] in Skyrim.ini (Found in “My Documents\My Games\Skyrim”) there are two entries.
    Change the YScale to match the XScale. If you do not have entries for fMouseHeadingXScale then just add them. Also set “bMouseAcceleration” to “0”

    I just want to say Thank you again, for these references. It’s exactly what I needed. I think I’ve finally perfected my settings last night. Because now, I can look straight down/straight up, and get right back to 1:1 when looking straight ahead, and…. left and right rotations seems to be right on 1:1 as well.

    Thank you.

    Now I just need to follow a few tips on out how to squeeze as much graphic fidelity out of it as possible without causing distortions.


    I just tried Skyrim with VorpX last night on my Vive. I used the VorpX game optimizer and set fov to 120. The game is pretty pixelated at 1280×1024. Is this normal? Also, are you guys playing the game with cinema mode on or off?


    Just curious, people who are experiencing the issues with the water flashing, what frame rate are you running at? This is actually an issue that can occur in the vanilla game with your frame rate above 60fps


    I tried Skyrim in VorpX today and I may be the only one with this problem, but how do you turn around?

    I feel sick if I use my mouse AND VR headtracking so I tried to play without touching my mouse (remapped mouse clicks to left and right arrow keys), but then I find myself stretching my neck in weird positions while pressing various combinations of wasd just to get my character to turn around.

    Is there a better way to do this?

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!