Star Trek Online

Home Forums Game Hints and Settings User Profiles Star Trek Online

This topic contains 9 replies, has 2 voices, and was last updated by  dellrifter22 1 month, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #186825

    dellrifter22
    Member

    Here’s some STO in G3D that a few people have been asking for lately. Got lucky with a Unity5 base, and after a couple nights of tuning I think the profile turned out pretty well. I hope it helps you guys enjoy the game even more. Now on the vorpX cloud:

    Star Trek Online (G3D)

    Zoomed-in immersive screen is default (most natural way to play), but fullVR is still plausible thanks to the games customizable HUD. It takes a bit more effort to play in full, but adds truer 3D scale and optional headtracking for the first person mode. Try them both to see which you prefer.

    – in vorpX config app, exclude launcher “Star Trek Onilne.exe” from game’s directory (we will hook GameClient.exe instead)
    – use a 16:9 resolution (2560×1440) in Fullscreen mode
    – Shadows to OFF is recommended
    – in game FOV setup: copy/paste command into chat window

    /gfxsetdefaultfov 90

    (Should only need to be done once ever)

    *Optional first person mode setup – reassign the Captain’s Log “L” key to another key in game, then copy/paste commands into chat window:

    /bind L “cam_distance_interp_speed 0”
    /bind Lbutton “CamMouseLook 0”

    (Needs to be done every game launch. To enter first person, back camera into a wall until avatar is invisible. Pressing L will now lock this camera distance. for headtracking, assign a mouse look toggle key to enable freelook, or press B to enable shooter controls. Press Home key to restore 3rd person.)

    *F12 for game HUD adjustment
    *vorpX HUD sliders also available, adjust the depth to your comfort. Near looks better for RPG controls, but Far looks better for reticle aiming with shooter controls.
    *NPC/target selection outlines look wrong in G3D, so are assigned to Shadow Treatment OFF. Turn them on by setting Shadow Treatment to Auto in vorpX delete menu.
    *Pimax8K should use cinema mode fullzoom and reduce strength to 1.04

    Now you should be set to boldly go in VR. Engage!

    #187613

    P1Elijah
    Member

    Howdy,

    Have you been having issues recently? I’m desperately trying to get this to work but, it crashes or the game barely responds.

    I’m with Priority One Podcast and I’d really like to report on this experience. Any help would be greatly appreciated!

    Cheers!
    -Elijah

    #187625

    dellrifter22
    Member

    What hardware specs and headset are you using?

    I’m on Rift CV1 using vorpX in steamVR mode with an rtx2080ti.

    I tested the new Awakening update tonight on the newest vorpX, and things are still working on my end. Except for the first person mod code, that now returns an unknown command error sadly. Zoom in all the way with shooter camera and you get pretty close to a first person view.

    I do sometimes get a crash report on first launch and have to try a second time. I’m also using mostly low settings in game to help performance. I have both GPU and CPU sliders set just below medium. If I crank them up to high I go from about 50fps to 25fps at the academy.

    The game doesn’t like if I minimize in fullscreen mode (can’t renter game), so setting to Windowed Maximized helps.

    While I was testing, I made some more adjustments to the profile’s scale for fullVR. You can redownload from the cloud if you wish. You may still encounter a random lighting or texture glitch here and there.

    I set scale and HUD depth settings the way I like them, but you can adjust them to your liking in the delete key menu. I think fullVR mode is the best looking, and worth the extra effort to move your desired HUD elements into view with F12. Use edgepeek key for glancing at out-of-sight HUD.

    I hope lowering some graphic settings can get you playing well enough. Game looks pretty neat in large scale 3D. Don’t expect native VR, but not too far from.

    Let us know how it goes and if it ends up on your podcast. Would be fun to hear about.

    #187628

    P1Elijah
    Member

    Ah! Thanks for the additional information!

    I hadn’t lowered any of the graphics settings in STO other than disabling Shadows like you mentioned in your original post.

    I’m running two GTX 970 FTW (SLI) w/ an Oculus.

    Also, I haven’t tried running it through SteamVR. The Oculus software automatically kicks on when I run VorpX. I wonder if the Oculus software is holding back performance?

    I’ll give it a shot again tonight!

    #187630

    dellrifter22
    Member

    It may work fine in Oculus mode, I just default to steamVR now since I use multiple headsets. Oculus mode has given me trouble with a couple games before.

    Note that the Oculus app will still remain open even while using steamVR. This is normal. I typically boot Rift and Oculus app, start steamVR, then launch vorpX in steamVR mode.

    Takes a lot of CPU/GPU horsepower to run 3D, hopefully the 970 can pull off lower settings. Target minimum of 35fps is generally good.

    Not sure if this is your first game in vorpX, but if you have more questions just ask.

    #187634

    P1Elijah
    Member

    Awesome! Thanks for all your help!

    This is my first time using vorpX — so it’s all new to me.

    #187650

    P1Elijah
    Member

    Well, I got closer tonight by lowering the graphics but, I don’t think my SLI 970’s are powerful enough to render the game. /sad face/

    #187652

    dellrifter22
    Member

    Darn. I’m not sure that vorpX or vr in general are able to take any advantage of sli, sorry. In fact running a single card with vr might be a better idea.

    If we could find some z-normal performance 3d for this engine, you could at least experience some world depth at very little performance cost. I play many other games this way.

    Maybe Ralf can help us get some Z3D working.

    #187656

    P1Elijah
    Member

    UPDATE

    I got it working!! I kept playing w/ STO’s graphics settings and lowered my texture and distance detail to 100 ((I had it set to 200-max)).

    After that, framerates stabilized… I’m actually able to play on “Medium” settings. Ran a new patrol and still stayed smooth.

    Are you playing in “Full VR”? I changed the vorpX settings to Cinematic. I didn’t like how the whole display moved when I moved my head. Am I missing something?

    Thanks again!

    #187657

    dellrifter22
    Member

    That’s because headtracking is mouse based and you have to hold or toggle the rotate camera button in STO. Or change to shooter camera mode.

    All three vorpX modes are essentially a big screen in your face, the main difference is how you want head tracking handled. Immersive screen/Cinema mode may well be the more comfortable way to play a HUD heavy game like STO. If having the most accurate scale and distortion free 3D is important to you (closest appearance of real vr), Full VR mode will look best – while also provide camera based head rotation.

    Play which ever way is best for you. I use all modes across various games. Glad it’s running well enough now. Hope you get some fun out of it.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.