Stuttering in game after 20.1 update Monster hunter world

Homepage Forums Technical Support Stuttering in game after 20.1 update Monster hunter world

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #191150
    rombodawg
    Participant

    Just upadated to 20.1 after having 19.3. 19.3 worked great with monster hunter world. Although my fps would be anywhere from 25-40, which isnt very great. I would get no stutter and it would be visually smooth. Now that i updated to 20.1 there is a clear stutter making the game very difficult to play and view. Even when switching to Z3D and getting about 50 fps, the game still has the same aweful stutter. Im assuming the issue is with the update since my game was working fine before updating. A solution or at least a way to go back to 19.3 would be nice. I have a Intel Core™ i7 9750H CPU and a NVIDIA┬« GeForce RTX 2060 GPU. running on the Oculus rift S

    #191151
    Ralf
    Keymaster

    For me the game seems to work as good as before even with the GPU clocked down to run the game at ~30fps, at least in a (very) brief test. Maybe even better since with 20.1.0 the Oculus runtime is less likely to throttle down to half the headset refresh rate.

    There is a confirmed isssue with the latest Oculus software though that seems to cause frame drops for some. Maybe your issue is related to that. They have a hotfix in their public test channel (PTC). You can subscribe to the Oculus PTC in the Oculus Home desktop app.

    Also try to enable ‘FluidSync’ on the ‘Display’ page of the vorpX menu. If you had that on before the vorpX update, it probably got switched off. FluidSync caps the FPS, but can make things feel more, well, fluid since the frame rate is more constant.

    Let me know if you still encounter this issue with the Oculus hotfix.

    More info on the Oculus issue here:
    https://forums.oculusvr.com/community/discussion/83277/newest-update-12-0-0-191-268-introduced-unplayable-frame-drops-in-hmd

    #191152
    rombodawg
    Participant

    I did what you said and subscribed to PTC on oculus and it did boost my fps to 30 on average vs 25 before. But the stutter still persisted. Its most notable when i move my head around but even with head tracking on the stutter is still there. I dont believe its the oculus software thats causing it. It could be a setting in monster hunter world itself, I just tried running portal in vr with vorpx just now and there was no stutter. So let me tweak with the setting in MHW and do some testing. In case you were wondering I am running MHW with AA off.

    #191153
    rombodawg
    Participant

    Sorry in the third line i meant to say “even with head tracking OFF”

    #191154
    Ralf
    Keymaster

    OK, did some more testing. vorpX uses a new frame sync mechanism for DX11 on Oculus, which enhances FPS a little (~10%), but with very low frame rates below 30fps like in your case the old method seems to feel smoother in Monster Hunter World.

    I would suggest to adjust the game settings to reach 40fps and then maybe enable FluidSync. Overall that will yield a better experience than playing with a super low frame rate.

    If instead you rather want to go back to the old sync method, you can do so with an .ini tweak:

    1. Navigate to C:\ProgramData\Animation Labs\vorpX\Devices\Display
    2. Open Oculus.ini with a text editor
    3. Change iDmBufferGrabberSyncDX11 (near the bottom of the file) from 1 to 0

    Only change the DX11 value, DO NOT change the value for DX12, DX12 is untested with the old method and may fail entirely with it.

    If you can’t see the C:\ProgramData folder, you have to enable ‘Show hidden files’ in Windows Explorer.

    #191156
    rombodawg
    Participant

    Yea i dont mind the lower fps for a better resolution. the only way to make the fps go up that enought to get rid of the stutter is to make the game look like a ps2 monster hunter game. Anyway, i did the manual text change trick you told me about. It worked and there’s no more stutter. However, now that I have your attention, my gamepad (PS4 controller) seems to have stopped working in the vorpx (DEL) key menu. I like using edgepeek with my controller while in vr but that stopped working along with the menu control with controller. The menu works fine with mouse but it does not recognize inputs from the controller. Any solutions there?

    #191157
    Ralf
    Keymaster

    Not really. For vorpX any gamepad is just an X-Box gamepad and with that it works as it always did. Not sure what to recommend to you, sorry. Can’t really imagine any change that could possibly make your PS4 gamepad fail suddenly, there is not a single line of code that treats it differently than an X-Box gamepad.

    #191158
    rombodawg
    Participant

    Good point, you actually gave me a solution and didnt know it lol. I forgot that vorpx considers the dualshock 4 as an xbox controller. I turned on DS4 program, which makes my pc think my ps4 controller is a xbox one and it works now. Thanks alot for the help, im back to hunting monsters in beautifull VR :D

    #191191
    Ralf
    Keymaster

    Happy hunting!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!