Stuttering in witcher 3

Homepage Forums Game Hints and Settings Stuttering in witcher 3

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #127756

    I have used the vorpx settings, that play the witcher 3 in virtual desktop mode, this is right?
    But I find the game unplayable this way, too much stuttering. Game is not smooth.
    Did I do something wrong? Are there settings I should check?

    My computer is an i5 6600K with 16 Gb of RAM and a GTX 970 video card with 4 Gb of VRAM.

    Also could you please confirm this is the way to play the witcher 3?

    1. I launch VR from steam
    2. I launch vorpx
    3. I launch the witcher 3. I then got the warning this is not a VR game and that the game will be displayed on my desktop and performances may suffer. Is it normal?
    4. Then in vorpx menu I select a menu that shows something like “start virtual desktop” (unsure the exact sentence)




    if you are still interested, I had witcher 3 running without steam vr. The game is very performance intense with vorpx. I have a similiar PC. Try lowering the resolution to 1600×900 and lower settings in witcher to see if it is better. Higher resolutions were choppy for me, too.

    1. launch vorpx
    2. launch witcher 3
    3. set vorpx cinema mode without the head controlling the mouse movement



    you need a better GPU honestly

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!