'Supported Games' that don't actually work at all

Homepage Forums Technical Support 'Supported Games' that don't actually work at all

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #95842

    I finally built a powerful computer and am getting back into Rift experimentation. I installed VorpX 0.9.1 in conjunction with Rift SDK 0.8.0.

    I then reviewed the official VorpX ‘supported games’ list and tried the first three games in my Steam library that are listed on the VorpX site. The results were disappointing.

    – Gone Home: Rift will not come on at all.
    – Metro 2033 Redux: Rift will not come on at all.
    – HL2: Rift comes on and VorpX is enabled (but presumably worse experience than the native VR now included).

    My question is, do the first two games listed above simply not work with VorpX? If not, why are they featured on the Supported Games list?

    If 2/3 of the listed games I tried do not work on VorpX, how many others on that list should I avoid?

    Otherwise, any suggestions on how to get the first two listed to work with VorpX?

    Specs: Windows 10 64-bit, GTX 980 TI, 32GB RAM, Intel 4970k, SSD.


    Gone Home: hooks correctly here (Win 10, Steam version), but then freezes when going into the actual game from the main menu. Might be related to Win 10, which seems to require to run the game windowed to work at all here with or without vorpX. Will be looked into.

    Metro 2033 Redux: works fine here (also Steam version). May have to be run in safe mode on some machines if I remember earlier reports correctly. If you also have the Non-Redux version of the game, using that is generally perferable BTW as it offers Geometry 3D when run in DX9 mode.

    HL2: When support for HL2 was done, there was no VR mode. Besides that it still makes a lot of sense for stand alone mods like Black Mesa. Personally I like the way vorpX does it better BTW, but that’s almost certainly a minority vote.

    In general: if you have problems with multiple games not hooking at all, please check the trouble shooting guide in the help. The most likely cause of this is some other program on your machine that creates a conflict with vorpX.

    You can also try to create a special vorpX desktop shortcut to a game’s main .exe (right click the tray icon, choose “Create Destop Shortcut”), which sometimes works more reliable than the normal hooking. Doesn’t help with most Steam games unfortunately, but would be an option for the Metro 2033 GOG version for example.


    I tried running Life Is Strange and it hooks properly without issue (looks fine in VR Cinema mode). All of my games are purchased and installed through Steam. This is a fresh install of Windows 10 64-bit with all the latest updates including NVidia drivers. I have disabled my antivirus software as well. I tried creating manual shortcuts for them like Gone Home but still my Rift does not come on. I read through the whole troubleshooter and nothing there resolved the issue. Hmm.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!