Thief 4 (2014) Problem

Homepage Forums Technical Support Thief 4 (2014) Problem

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #202112

    Hello Ralf, I wanted to play Thief 4 with the new update, but I couldn’t.

    The Thief 4 profile does not work, there are several problems:
    – The mouse cursor does not appear on the screen (but the buttons work)
    – The game doesn’t play any sound in my headset (the sound from my Rift S is on the headset audio channel)
    – The game camera moves in all directions if I move my head, and I have the impression that the FOV is not good (it’s hard to determine) which makes the game completely unplayable in FullVR (Putting the option in VorpX “Input Settings > Try Pitch Lock > On” alleviated the problem)
    – There is no DirectVR Scan button?

    Other than that the VorpX hooking up is good and the G3D seems to work well.

    I’m also using this post to give some settings I found (and that work) that could improve the VorpX profile of the game:

    Disable motion blur (Thief\Engine\Config\BaseEngine.ini):

    Disable the black/white vignette effect around the screen (ThiefGame\Config\ThiefGame.ini):

    Mouse setting (to be tested):

    Disable mouse smoothing (ThiefGame\Config\ThiefInput.ini):

    Reduce mouse input lag (Engine\Config\BaseEngine.ini):

    Reduce mouse lag (ThiefGame\Config\ThiefEngine.ini):

    Settings and optimisation guide:

    (I use the new update, The game is running on Oculus Rift S, I have a RTX 2060 on Windows 10, I don’t have Antivirus, only Defender and no software running in the background. Excuse my bad english)


    If you can’t see the cursor while it is supposed to be visible, try ALT+C. This shouldn’t really happen though, I’ll take a closer look at it. In the meantime ALT+C should do the trick.

    If you experience anything unwanted sound wise, untick the ‘Use built-in audio device’ checkbox in the vorpX config app. vorpX auto switches to the headset audio device. If that’s not what you want, unticking that checkbox disables the function.

    There is no DirectVR memory scanner for the game, that’s correct. Another part of DirectVR however adjusts various settings automatically to configure the game for FullVR mode. Most importantly the camera field of view. Note that initially two restarts may be required until the FOV is right. Works for me. vorpX displays a prompt requesting a restart whenever it considers that necessary.

    If you happen to have disabled automatic settings, please re-enable that, otherwise DirectVR can’t configure the game correctly. Also please reset the profile to default in the config app if you tweaked any vorpX settings.


    I have completely reinstalled the game without making any changes and I have the same problems.

    I’ve done some more testing:
    – The VorpX cursor (Alt+C) makes navigation in the game menus much better.
    – The only parameters modified by VorpX are in the registry (no modified ini file).
    – My game is installed in “D:\Program Files (x86)\Steam\steamapps\common\Thief\Binaries2\Win32\…” (default Steam path)
    – My screen and game resolution is set to 4:3

    But I have a new problem, I can’t reset the profile of Thief 4, when I reset it in the vorpx configuration software (Restore Game Settings) it disappears as it should, but when I restart the game my old modifications are still there (lumasharpen, contrast…) it’s been 4 times that I reset it without success.


    EDIT: I managed to reset the profile correctly, I was in the wrong configuration menu (ignore the last paragraph of my previous post).
    After this reset the problems are still there.


    Can’t really say much more than above, sorry. Checked the game for you right away after I read your post to be sure nothing has been broken. If you let vorpX do its thing, it adjusts everything so that the game’s FOV matches your headset FOV. That has been working for years and it is still working today. The registry edit is precisely what you need for the FOV to be right. Just a guess, but maybe some of your manual .ini tweaks affect how the registry value works. Worth a shot to delete your manually tweaked ini files. The game should create new ones on launch, if not verifying the game files in Steam will.

    Note that if all worked, the game will run windowed. If you run it fullscreen on a 16:9 monitor with a 4:3 res, it may looked stretched. vorpX takes care of that under normal circumstances.

    The only other thing I could possibly imagine is that maybe there is some game of the year edition or something similar with different config paths than the original game, that happens occasionally. If you suspect, it could be that, let me know. Judging from your Steam path that doesn’t seem to be the case here though.

    Not sure if there are mods for the game, but if so and you have installed some, please also try without.

    Apart from that the only other suggestion I have is maybe trying a full vorpX factory reset in the config app (trouble shooting page).

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!