Trying to get IL-2: BoS working

Homepage Forums Technical Support Trying to get IL-2: BoS working

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #105326

    Has anyone gotten Battle of Stalingrad working with VorpX on the CV1?

    I am just getting “Please wait” and “IL-2.exe is taking a long time to load”, while the game runs on my desktop.

    I know the game is unsupported, but I did see some videos of Rise of Flight (same engine though an older iteration) running with VorpX.


    New info: The game hooks when I get to a loading screen, and the loading shows in the Rift. Only problem is that the HMD stays at the loading screen, while the game plays on the monitor.

    Head tracking and sound works perfect though.


    Update: I got it to work by loading the Arma II profile. However, the FOV is too low.

    Only way to make playable is to use the or_enable = 1 in the config.
    This however leads to the image being split in two for both eyes, due to the fact that this option is meant for Extended mode on the Vive.

    Does anyone know if VorpX is able to split a single render down the middle, so it can be displayed on each eye? Maybe there even is an existing game profile that does this?


    Bumping this to see if anyone has had any luck getting IL-2: Battle of Stalingrad working with Vorpx? Fiddled with it for hours last night but kept getting the same results as kissklas above:

    – the game does not launch in the headset (Vive, in my case). But after clicking Quick Mission, then selecting a mission and clicking Play, the headset comes alive and shows the loading screen (with red font warning me of low FPS). It then freezes on this loading screen, and the monitor loads up the mission briefing. After clicking Play on the mission briefing, the game loads on my monitor but the image in the headset remains the frozen loading screen.

    Kissklas, I tried loading it by associating the the IL-2 BoS “launcher.exe” with the Arma II profile, but got the same results as before. Was there no way to make adjustments in Vorpx to alleviate the small FOV? Am I associating the wrong file?

    To the Dev(s) of Vorpx – I’m sure you’d get MANY purchases from the flight sim community if you were able to get this to run, even with limited functionality. BoS is currently on sale and in the midst of a massive reimagining, and they most likely won’t have true, native VR support for many months (I’ve used the extended mode support with my Vive and it’s really really choppy, since the FPS jumps around).

    I used Vorpx with Rise of Flight last night and got it working fairly well. It’s supposedly the same engine as IL-2:BoS – hoping you may be able to take a look at it ad see if there’s an easy fix? I don’t even care about any sense of “True 3D,” just being able to move my head to control the camera would be outstanding. The flight sim community tends to have money to burn, and a shortage of VR supported games.

    Thanks for the help!


    I gave up on it. I guess we need proper support to get it working.

    On a sidenote: I ended up running Virtual Desktop through steamVR in SBS mode, and running BoS through virtual desktops Games tab, with or_enabled in the BoS config. This gave me proper 3D and working headtracking in the Rift.

    But turning the head in game results in horrible lag, even at lowest setting, and the eye placement seemed a bit off no matter what I did. Success, sort of:-p

    Try it in the Vive if you can. Maybe it works better. Running the game in extended mode, through a program that is again run through SteamVR, via the Rift did not go well with my system:p


    Time to give it another shot, as I got it working! Like most things Vorpx related, it’s worth keeping expectations in check, but I played for hours last night and went to bed a very happy guy.

    Here’s what I did to get it working on my Vive:
    – “or_enabled” in setup can be either 0 or 1, it didn’t make a difference
    – start Vorpx so it’s in your taskbar
    – right click on Vorpx
    – click “Create Desktop Shortcut” (as per recommendation in Basic Trouble Shooting)
    – point to the .exe of IL-2: BoS (not the launcher)
    – I’m using the standalone BoS client, not steam, so I’m unsure if it will work with the steam version.

    This will create a shortcut on your desktop, mine was called “IL-2 vorpx”

    – Start SteamVR
    – double click on the newly created shortcut on your desktop
    – enjoy!!

    I’d love to hear if you can get the same results on your Rift. A couple of tips from my experience:

    – I prefer using Cinema Mode for this game, as First Person mode had pretty heavy blurring when moving my head quickly. Cinema mode is still awesome, and after 20 minutes of playing my brain kinda forgot it wasn’t native support; I was concentrating more on the content of the game, rather than the outside borders of the cinema screen
    – in Cinema Mode, bring the screen as close to you as possible (-1.00, I believe), and change the background to ambient or off. Then fiddle with the head tracking speed slider to your preference. It’s very similar to First Person mode when doing this, with much better image clarity and menu readability.

    I used my Vive in extended mode via the built in support (editing oc_enable…). I also used Vorpx via First Person and Cinema mode. Although Cinema mode doesn’t have nearly the depth/3D of the extended mode support, at least it’s clear, and the menus are beautifully crisp, making the game much more enjoyable for me compared to First Person mode or the extended mode support. Also, I was able to turn on AA, and I also Supersampled to 1.5 without performance issues (GTX 1080, 6700k @ 4.5, 32 gb RAM @ 3500). In addition, I’m not sure how much of a difference this makes, but after setting up the in-game options (AA) via the settings menu, I exited the game and edited the startup file to have FPS limit be 90 (also have tried 100). The in-game options menu doesn’t allow 90 as an option, only 80.

    Give it a shot, I’d love to hear feedback on in-game Vorpx settings, hope it works with your Rift!


    Forgot to mention –

    To improve FOV, try using the keys “Pilot Head Control>>>Move Pilot Head Forward/Back/R/L/Up/Down” to improve your FOV and seat position. Besides moving the head position back as far as it will go, you can also use the scroll-wheel on the mouse to pull the view back even further.


    I have gotten this to work before as well, but geometrical 3D for me renders the environment outside the cockpit black on one eye. have not yet tried to do or_enabled in config. The cinema mode works well, but it does lag quite a bit on my gtx 970. would say it is almost playable though.

    Edit: In normal/adaptive mode it’s all good, but no real 3d feeling:-/ wish the geo mode worked.


    Sorry for delay, was out of town –

    Totally agree, would be great of geometrical 3D mode worked, I get the same rendering issues as you do. Definitely wish there was more 3D with normal/adaptive mode. At least head tracking works, and after pulling the screen up close it’s much better than using a monitor (in my opinion, or course), and quite immersive when the stuff hits the fan.

    Don’t suppose you’ve figured out a way of getting it working with CloD? :-)


    Can anyone help me please!?!? Activating this thing is a fucking nightmare.
    First off I accidentally entered in my request code as my username and now i can’t get the key to work at all. What do I do?????


    Don’t suppose you’ve figured out a way of getting it working with CloD?

    Hehe no, I gave up on CloD. It just feels too “on rail” after BoS. But hey, TF are porting to DX11 and adding VR support soon! (that goes for BoS/BoM/BoK too actually!)

    Can anyone help me please!?!? Activating this thing is a fucking nightmare.
    First off I accidentally entered in my request code as my username and now i can’t get the key to work at all. What do I do?????

    You have to contact support on that one, I think. This thread is probably not the right place for account issues.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!