Using the Steam Overlay

Homepage Forums Technical Support Using the Steam Overlay

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #102295

    Here’s a bit of an odd issue: I’d really like to turn _on_ the Steam overlay while playing games with vorpX

    I’m trying to play Fallout: New Vegas with vorpX using a Steam Controller, but to use the controller, Steam’s overlay needs to be running. Also, I’d like to be able to see its overlay (part of the Steam Big Picture Mode overlay) in-game, since the controller has its own menus for hotkeys and profile switching and whatnot.

    For whatever reason, this actually works! … but only on the first run after a cold boot of my PC. I’ve been able to play the game with vorpX, Steam’s overlay, and the controller all working beautifully, at least long enough to start making a nice controller profile (even using touch menus within the headset). But, when I quit out of the game and start it again, the Steam overlay never loads and the controller doesn’t function properly. (vorpX injects fine in this case, however)

    When the overlay fails to inject, I’ve noticed that I can — with the vorpX in-game menu — turn on “Direct Mode Show Original”. As soon as the game draws on my display, Steam’s overlay injects like it should have at the beginning. This gets controls working, but then Steam only draws its overlay on my actual monitor, and not in the headset.

    I’m guessing that in the “cold boot” scenario Steam’s overlay injects itself before vorpX does, but in subsequent runs vorpX manages to inject itself first. Assuming that’s the case, is there some consistent way to make sure Steam injects its overlay before vorpX does (without having to reboot)?

    My procedure for starting the game is roughly: 1) Boot 2) Start vorpX 3) Start Steam’s Big Picture Mode 4) Turn on Steam Controller 5) Start game with controller.

    (If it helps, I’m using a Rift CV1 on Windows 10.)

    Edit: I’ve also tried pausing the watcher before starting the game, letting it start up normally, and then resuming the watcher. Unfortunately this just seems to crash the game.


    vorpX needs to hook early into the game. Starting the game first and then enabling the watcher will not work.

    Unfortunately there is no way to determine whether the Steam Overlay or vorpX hooks first, but there is something completely different that may help you:

    vorpX has a built in gamepad emulation. If you configure your Steam Controller as standard X-Box gamepad, you can enable the gamepad emulation in the vorpX ingame menu and apply custom button mappings etc. there.


    Thanks for the reply!

    Unfortunately, if the Steam overlay fails to load entirely, then the controller won’t use _any_ profile, be it mouse/keyboard, x-box, or otherwise. It’ll get stuck in its default “desktop” mode which isn’t usable for games, so gamepad emulation won’t help in this situation. However, turning on “show original” will get all types of profiles working, albeit without its Steam’s overlay being drawn in-game.

    That said, your gamepad emulation suggestion did get me thinking about another vorpX feature I forgot about: the VR hotkeys should perfectly replace the Steam controller’s overlay. So the problem was solved anyway! :)

    For anyone that runs into similar Steam controller problems: turning on “Show Overlay” can get controller profiles working. Steam’s in-game overlay won’t work (at least, consistently), but vorpX’s own hotkeys work great. (at least for Fallout: New Vegas, YMMV for other games)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!