Various games crashing after about 30-60 minutes

Homepage Forums Technical Support Various games crashing after about 30-60 minutes

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #126175


    Each game I’ve tried so far crashes after about 30-60 minutes playtime (e.g. Diablo 3). Shortly before those crashes the VR world begins to … “flashing” (My steam VR background fades in and out quickly). This starts very gentle and gets worse within next 1-2 minutes. In the end the VR world crashes (black screen), but the games still runs fine (on my monitor).

    Regular Steam VR games and Steam’s cinema mode running just fine. I already tried to lower game settings while using vorpx and set vorpx’s ingame settings to “low” (no 3D emulation, black background, etc.). It didn’t even increase the playtime before it crashes.

    Before asking: Yes, I went through the FAQ already (I’ve disabled antivirus, checked further programs, avoided game mods/injections and no nvidia 3D-ish configs activated).

    So, does someone have a hint on how I can solve this annoying behaviour?

    Thank you in advance.


    I’ve just found out that turning off “direct mode asynchron renders” seems to avoid the crash (or increased the time till the same). However, if I disable that setting, the whole VR environment is quaking slightly while moving my head. The game runs great though (no lags and “enough” FPS).

    By the way: I shouldn’t have saying that the “game” is crashing in my previous post. Only the VR environment crashes. The game runs just fine on my screen after that crash.

    Still looking forward to a solution.


    I don’t really have a solution to your issue besides very general hints like updating graphics drivers, headset runtime etc., sorry.

    One important heads-up though: disabling the asnyc rendering option severely reduces performance and – if at all – should only be considered for quite old games where that doesn’t matter since they run fast enough anyway. Without async rendering there is a lot more “time warping” happening inside your headset’s runtime (meaning inserted artificial frames in between real frames), which probably is the cause for what you experienced.


    Disabling the async rendering reduces performance? Ok, that might be the reason why the view starts quaking once I turn that function off.

    However, if I play a game that is expensive in resources it does fade out and fade in just as the problem I do have with vorpX, but they don’t crash at the end.

    Drivers and Vive firmware are up to date.

    Is there any log or debugging ability that I could use for further investigation? Or does someone else have another idea?


    Had same issue. Turn off crystal imaging fixed this. You turn it off on the vorpx settings but can only see setting if you have advanced settings set. Hope this helps.


    I didn’t test this solutoin with the vorpX version I had while opening this topic. However, I had another/similar behavior with the newer version 17.2.0: After a while of playing one screen/lense starts flickering. This lasts a view seconds before both screens turn to black, even though the game seems to be running just fine on my regular display.

    Anyway, the solution suggested by forlaunchcast helped me to avoid this issue from occuring again. Thanks for that!

    Though I would be glad if that would get improved even more with a upcomming version.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!