VorpX and Vive and Source Games Technical Issue

Homepage Forums Technical Support VorpX and Vive and Source Games Technical Issue

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #172729


    I recently got an HTC Vive headset and I’ve been trying it out, and comparing it to my Rift CV1 headset that I have had for a while. I play a few games using VorpX, and while I’ve used the Rift and VorpX, everything works flawlessly, albeit some jittering here and there. Now, since I’ve gotten the Vive and I’ve been attempting to run some Source games using it (and SteamVR), I’m unable to, and I’ve been trying to figure out a solution.

    Things specific to my issue:

    – VorpX hooks into the program successfully and the headset’s movements and such display correctly in the game window.

    – I have two GTX 760 GPUs. On GPU1 I have my Vive plugged into the HDMI, and my center, primary monitor plugged into DVI. GPU2 has my other three monitors plugged into them. Whenever I launch any game while VorpX is running, SteamVR pops up a warning saying “Headset plugged into wrong video card”, when clearly my center monitor and the HMD use the same GPU.

    – Vive input and VorpX hooking works fine, but rendering to the Vive using SteamVR does not work.

    Error lines I see in VorpX logs are:

    WRN: OpenVRDirectModeManager Submit Error: 101 101 0
    WRN: OpenVRDirectModeManager Submit Error: 104 104 0
    (with that second line repeating many hundreds of times)

    Error 101: Corrupt initialization
    Error 104: Factory not found
    Error 0: No error

    Error lines I see in SteamVR logs are:

    Sun May 06 2018 20:21:05.036 – Refusing connect from hl2 (19032) because app start error VRInitError_Init_Retry
    Sun May 06 2018 20:21:05.036 – Processing message VRMsg_Connect from hl2 (19032) took 0.0316 seconds
    Sun May 06 2018 20:21:05.537 – New Connect message from C:\Steam\steamapps\common\GarrysMod\hl2.exe (VRApplication_Scene) (Args: -steam -game garrysmod -windowed -noborder -cl_cmdrate 99 -mem_max_heapsize 8192 -width 2036 -height 1527) 19032
    Sun May 06 2018 20:21:05.537 – Unable to create property container PC_700004a58 because it already existed
    Sun May 06 2018 20:21:05.537 – Unable to create property container for hl2 (19032). Maybe it’s a reconnect?

    (These messages repeat 5-6 times, or until I exit the program)

    I’ve been scouring this forum and various other locations for an answer, but I’ve been unable to solve this problem.

    Extra info:
    – VorpX desktop viewer runs just fine, and as expected. It is currently the only VR app other than SteamVR Home that runs fine.
    – SteamVR Home and the SteamVR Tutorial also run just fine, as well as any VR-designed apps or games.

    I’m willing to gather any app logs necessary to provide any extra info on this issue.

    Any help would be appreciated!


    I have the same issue, even with a normal GPU setup – one 1050ti with the headset and only one monitor.

    I found this happens with HL2 and Black Mesa so far, the head tracking works but I only get the SteamVR loading screen in the headset.

    I tried a couple other games in VorpX and those work fine


    So I tested my Vive on a laptop I have with a GTX 1060, and I get the same issue, like with you. One GPU, though it still says the monitor and the HMD are connected to different GPU’s.

    I’ve tried, on both my desktop and my laptop, to set StewmVR’s and the game’s GPU to whatever one the monitor is plugged into, but to no avail.

    I also wanted to mention something else odd: VorpX desktop viewer works on my Vive, but it has never worked for my Rift.


    The Source engine issue might be related to some recent SteamVR update. Some still work fine (e.g. Stanley Parable, Left 4 Dead 2), others don’t (e.g. HL2, Black Mesa Source). I can’t say anything more specific yet, but the issue will be looked into before the next update.

    The SteamVR/Source issue has been addressed with a profile update. Importing the updated “Half-Life 2 / Portal [vorpX]” profile from the cloud should fix it. Same for Black Mesa.

    @ Sauermon: BTW: Gerry’s Mod currently is not supported and 2D only since it uses an older Source engine build that the current vorpX version can’t handle. Geometry 3D for Gerry’s Mod will be available in vorpX 18.2.0.


    The updated profile works flawlessly, thank you very much for the info!

    Also, about Garry’s Mod and Geometry 3D: I’ve been able to use Direct 3D and Geometry rendering in Garry’s Mod for many months now, and it seems to work okay, aside from some rendering issues on some maps and so forth.


    I am experiencing the message WRN: OpenVRDirectModeManager Submit Error: 101 101 0, a couple of hundret lines, game displaying with vorpX logo but not displaying in HMD after i changed to the Vive Pro. SteamVR version is the older one from 2017 (i havent updateed because of those SteamVR “bugs”) . Not supported game though (Starpoint Gemini with Whale 2 propietary engine), other games work well, just want to drop that info here for statistical porposes in case other pro users run into similar things.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!