VorpX appears to hook, but then crashs right away

Homepage Forums Technical Support VorpX appears to hook, but then crashs right away

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #91038

    Hi all,

    I have two games that are compatible with VorpX. Serious Sam:BFE launches, then freezes on a black screen. The Stanley Parable tries to launch, flickers between a black screen and a couple different resolutions, then crashes sending me back to the desktop. Both games run fine on my laptop display when VorpX is disabled.

    My specs are:
    Lenovo W540
    Intel i7-4700MQ @ 2.40GHz
    Windows 8.1 64bit
    16GB RAM
    nVidia Quadro K1100M (choose to run game with this GPU)
    Intel HD Graphics 4600
    vorpX 0.9
    Oculus Driver 0.7 (tried 0.8 as well)
    nVidia Driver 354.42 (latest since 11/4)

    I originally tried with Oculus Driver 0.8. When that didn’t work, I tried uninstalling and installing OD 0.7. I also tried reinstalling the vorpX driver. Nothing changed the mode of failure.

    I also tried disabling my virus scanner (AVG) and Windows firewall. Neither helped.

    The desktop viewer does work.

    Thanks for any help!


    Hi, I have been checking your laptop specs and it uses optimus technology, that is not compatible with oculus runtime (I have an optumus laptop and worked till oculus runtime 0.5). Have you tryed other oculus apps?


    Hi dandealer,

    Thanks for responding. I did google what you are talking about and see the potential issue. However, right now, with Oculus runtime 0.7, I am able to use the Oculus demo scene. Also, I tried VR Karts which I had not used for a while. That worked as well. Performance is not the best for the demo or VR Karts. Maybe 30 frames a second? Other than that, it seems to work fine. FYI, when oculus runtime 0.5 initially came out, VR Karts did not work, but it has since been updated which is why it must work now.

    This was with vorpX disabled.

    Any other ideas?


    Glad 0,8 works in your laptop!

    2 ideas just in case:
    Did you try to run vorpx and games as admin?
    Some times my games only hook with vorpx if the oculus config tool is open
    Give it a try just in case :)


    Despite the Oculus demo scene working this might still be an Optimus issue. It’s not unlikely that vorpX can’t hook correctly when a game switches from the integrated graphics to the dedicated GPU.

    One thing you could try is disabling the integrated graphics entirely in the BIOS of your laptop, provided it has an option to do so.

    On a side note: Quadro cards, regardless whether desktop or mobile, are known to cause issues in general with the Oculus Rift. They might or might not work. (source: https://forums.oculus.com/viewtopic.php?f=26&t=26692&p=300557#p300557)


    Okay, will try what both of you said. The laptop is my work computer, so I will try and give feedback on Monday.


    So I tried running the vorpx and the game as admin with and without the vorpx configuration up. That did not work. Still have the same issue.

    I checked my BIOS to see if I could disable the integrated graphics, but there was no such setting.

    Investigating a little further, I discovered that if I assign the Oculus server to run on the nVidia card, it crashes. If I assign it to run on the integrated graphics, it runs, but the frame rate is slow as before.

    Reading what this guy did (http://riftdev.com/oculus-general-discussion-re-laptops-w-switchable-graphics-not-compatible-with-dk2-82/ ), it looks like I might have to not use any displays connected to the intel GPU (basically the internal laptop display). I am going to try and get a multiport hub off my mini display port so I can just use an external display and the oculus. That seems like it might work.

    I will post here hopefully once I am able to try that.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!