VorpX cannot find DK2

Homepage Forums Technical Support VorpX cannot find DK2

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #16587


    I’ve installed the latest vorpX, but i cannot use it for some reason.
    I’m trying it with F1 2013.

    When I start vorpX in Direct HMD mode, it can see the DK2, but says that i’d better use the extended desktop mode and i cannot start the game.

    If I start vorpX with extended desktop mode, it cannot recognize the DK2, it says i have to select a new device from the list.

    If I start vorpX with Direct HMD mode, and THEN switch to extended desktop, the game starts, but it immediately tells me, that: “Rift init timed out. vorpX will not work correctly. Please check the USB and HDMI connection of your Rift”

    What could be the problem?


    The DK2 has to be turned on when you start vorpX otherwise it won’t be found, maybe that’s the issue.

    Also please try to use the Rift as primary display and set the vorpX config app to “Use system settings”. That’s the most compatible option. The documentation has a step-by-by guide with pictures. Direct to Rift will only work with very few games currently.

    And just in case: Did you try the usual things like rebooting and changing the USB port?


    It’s turned on, the LED is blue when i use extended display mode. I’ve rebooted already a couple of times, i’ve changed USB ports, “Use system settings” is selected, but no luck so far.


    Sounds like neither the control app nor the injected DLL can initialize the Rift. One other thing I can think of is that you might not have the latest Oculus runtime (0.41) installed. It can be downloaded from oculusvr.com . The vorpX setup should install it automatically, but maybe that failed for some reason.

    If that doesn’t help, please send your vorpx.log to support |at| vorpx com. The log can be found in your temp folder (Usually C:\Users\[User]\AppData\local\temp).


    I have the latest Oculus Runtime (0.4.1, Rev 1).
    Vorpx.log only contains this if i start it with extended display mode:

    INF: VorpControl: Starting.
    ERR: vorpControl: No Rift found.

    By the way, with extended mode, neither the Oculus Configuration Utility can find the HMD.

    I’ve already reinstalled the whole Runtime after uninstalling and cleaning it from the system, but no luck.


    I have no idea what might cause this. All that vorpX does when checking the device is initializing the HMD and checking its name.

    If the problem persists, and you can’t find a solution, please send a mail to support |at| vorpx com. Sorry for not being able to be of more help.


    I have the problem myself, if a solution then please post here thanks


    Good news! I’ve managed to fix the thing!

    I used this tutorial: http://www.reddit.com/r/oculus/comments/2cu0qq/how_i_got_my_dk2_working_with_positional_tracking/

    The problem was my Teamviewer installing its own driver for the rift display while extended mode.

    I’ve also notified OculusVR of this bug, maybe Ralf could make a sticky post or something with this information.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!