VorpX Disabling VR VSync doesn’t work (Async Render/Fluidsync)

Homepage Forums Technical Support VorpX Disabling VR VSync doesn’t work (Async Render/Fluidsync)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #192511

    Previous post not showing – try #2


    Hi Ralf,

    Since VorpX limits gaming to 45fps (90fps on old games with powerful hardware), turning off VR VSync via the ASW/ASync Render/FluidSync settings is always my first move to enable me to play games at much higher fps that fully utilise my GPU.

    VR FPS is checked via Alt-F hotkey in VorpX within games for testing purposes.

    Unfortunately, I have a consistent and repeatable problem with VorpX in games tested under Win7 and Win10 where the Async Render / Fluidsync options don’t work properly or at all.

    Sometimes they work, other times they don’t, always resorting back down to 45fps for the game/ CV1 headset.

    I’ll try to describe the behaviour:

    Case 1: Old game + Powerful GPU @ ~60% GPU utilisation = VorpX Game/headset @ 90FPS – Great, working as intended

    Case 2: Modern game + Powerful GPU @ ~60% GPU utilisation: VorpX @ 45fps – not so great FPS, but working as intended.

    Not working:
    Case 2 + VR VSync OFF (VorpX in-game options for ASync and FluidSync to on/off/auto etc)

    Expected result: VR FPS varying freely, (not limited to 45fps or 90fps) e.g. FPS at 80fps depending on scene with GPU usage @ ~90%+, i.e. being fully utilised.

    Actual buggy result: Game / Headset FPS still locked to 45fps with GPU usage @ ~ 60% (GPU not being fully utilised). Randomly goes to higher fps e.g. 80, with GPU utilisation @ 90%+, but then randomly goes down to 45fps again at specific scenes and stays at 45fps for a long time even when going back to previous scenes where higher FPS worked fine before. Higher FPS will eventually kick back in randomly.

    It seems there is a bug in VorpX which keeps forcing some kind of syncing back down to 45fps randomly, even when the fluidsync/async options are disabled/adjusted.

    Tested various games under various resolutions, GTX 1080 / RTX 2080 Ti, Win7 / Win 10, Oculus tray tool setting ASW to OFF / Auto, Tracking prediction on / off. All these settings don’t seem to affect problem behaviour.

    The goal is to have VorpX fps completely (or as close to completely) detached from any kind of limit e.g. no 45fps limits, and VorpX / game always utilising 90%+ of GPU to deliver the max FPS possible.

    Perhaps there is some really simple setting that I am overlooking.

    Help would be appreciated getting to the bottom of this issue – when VorpX does work at higher than 45fps (usually around a target of 80 on my setup), it is truly a pleasure to experience.



    Headset runtimes may decide to throttle to half your headset’s refresh rate at their own discretion although vorpX would be perfectly able to maintain the full framerate on its headset thread. The Oculus runtime does this notoriously early for example since about a year or so after the CV1 start.

    I’d rather have full control back either, but on the other hand it’s not really a huge problem since at that point the headset runtime’s interpolation/timewarp/whatever-they-call-it takes over. The only real drawback is that instead of for example 70 interpolated to 90 like vorpX would do without FluidSync if left alone you always get 45/90 when the heasdset runtime decides to throttle to 45 and does the interpolation.

    If you are severly bothered by this behavior, getting an Index would be a viable solution, which for the most part let’s vorpX do its own timewarp/interpolation without getting in the way.


    Ta for the info Ralf.

    1. Is disabling Asynchronous Warp using the Oculus Tray Tool not supposed to disable this behaviour? (it doesn’t seem to have any effect)

    2. Anyway, to confirm: non-Oculus headsets using SteamVR don’t have this issue?

    b. What if we try to use the CV1 via SteamVR – would this help? i.e. In SteamVr games, when I disable SteamVR “Allow Asynchronous Reprojection” setting, I get great performance utilising all GPU power without any cut-downs to 45fps. Can I somehow get the same effect with VorpX?

    I have been considering getting the Pimax 8KX + Index controllers bundle when it finally gets released. It would be great to get a thumbs up from you if you’re saying it will have significantly less of this issue…



    Not sure about the tray tool, IIRC it applies some registry hack. Who knows whether that still does anything. My Pimax experience is rather limited to some short pre-release tests whenever a new vorpX version comes out TBH. So I can’t really make any qualified statement here.

    The best I came across in the above regard lately is Index. In demanding games you will still occasionally see vorpX’s headset thread dip below 90, resulting in a mixture of vorpX/SteamVR interpolation, but that doesn’t really matter. What it never does is cutting its frame rate in half despite plenty of performance headroom for vorpX’s own timewarp like Oculus.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!