VorpX Help: BF4 Experiencing extreme graphical glitching

Homepage Forums Technical Support VorpX Help: BF4 Experiencing extreme graphical glitching

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #204875

    VorpX for Battlefield 4 does not work.

    Recently I tried to play Battlefield 4 in VorpX; use my Oculus Rift S as a sort of head-tracking device so that I could pilot jets better. However, VorpX completely destroys my game’s graphics as seen in >>>>> THIS YOUTUBE LINK<<<<<

    I’m completely unsure as to how I could fix this. I have my suspicions that it could be the geometry build that VorpX has that could be interfering with the game directly, but I have yet to find out a way to change settings without crashing the game.

    Yes, trying to change most of the geometry settings in VorpX causes BF4 to crash like clockwork. I’m unsure how to change these Geometry Settings outside of the game.

    Would appreciate any help! Really wanna try BF4 out in VR. Its weird since I’ve seen VorpX gameplay of BF4 just a few months prior, but now and my partner’s PC is experiencing the same Graphical error!

    I would appreciate any help. This isn’t time-sensitive or anything but I really would love to try out BF4 in VR, and it seems unfair that it is preventing me from doing that and blasting me with something that could give someone a seizure XD

    Once again here is the link: https://www.youtube.com/watch?v=ZhFGaF8ToBc


    That looks odd for sure. Please try to reset both the vorpX profile and all game settings to default, not really sure what else to recommend. Also please make sure that you don’t have ny GPU Utilities, overlays or other programs running that hook into Direct3D.

    If the issue still occurs afterwards, try switching to Z3D instead of G3D in the vorpX menu.


    Yup. Same thing happens for me in BF4 G3D (as well as Battlefront 2).

    Tried everything. It’s a shame… because I can tell they both would look amazing in G3D. Z3D is ok… but not comparable. In fact, Z3D kinda messes with my brain a bit.


    You have to restart BF2 after switching from Z3D to G3D. There should be a hint suggesting that directly below the 3D option in the vorpX menu. Also please try to reset all graphics settings to default, just in case some settings affects G3D.


    Thanks Ralf…
    It’s been a while, so I’ll give BF2 another go.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!