VorpX install error "Failed to expand shell folder constant \"userdocs\"

Home Forums Installation and Registration Support VorpX install error "Failed to expand shell folder constant \"userdocs\"

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #186785
    LancerVI
    Participant

    Just purchased VorpX, downloaded it and started the install. Can’t even install it. I receive an error message at the “Ready to Install” portion of the setup.

    An error box pops up and says, “Internal Error: Failed to expand shell folder constant “userdocs””

    AMD R9 3900x
    Asus ROG X570 Crosshair VIII Hero (wifi)
    Sound Blaster AE-9 Logitech Z906 5.1 speakers.
    G.Skill Trident Z F4-3600C17-8GTZR 32GB (4×8)
    MSI GTX 1080 TI Gaming X 11G
    Samsung 970 EV0 plus 1TB nVME x2 RAID 0
    Watercooled, custom loop.
    Oculus Rift S
    Windows 10 Pro 1903

    #186786
    Ralf
    Keymaster

    This error indicates that an internal Windows function fails that should never fail on a normally configured Windows.

    Please check whether you maybe have some “security” feature in your AV software activated that blocks access to your ‘Documents’ folder by obfuscating it. Might be called ‘Protected Folders’ or similar depending on your AV software. If so either disable this feature or allow the installer to access your ‘Documents’ folder.

    If that is not the issue, please check whether your Windows user’s ‘Documents’ folder is set up correctly, i.e. not set to an unavailable network drive or something similarly invalid.

    #186789
    LancerVI
    Participant

    Ah. I have it set to my NAS. I like my library folders setup to my NAS. Is there a work around?

    EDIT: I’m going to try and change the permissions and see if that will allow me to continue.

    EDIT: Didn’t work. Completely disabled my Norton and checked the permissions for the documents folder. Everything looks good, but still get the same error message.

    #186791
    Ralf
    Keymaster

    The installer is a common third party installer used by literally thousands of applications. If it fails to expand your ‘Documents’ folder location correctly, something has to be messed up. All I can recommend is trying to temporarily set the folder path to the default location for the installation. The only file currently installed there by vorpX is an optional background image for cinema mode.

    Might be worth it to find a permanent solution though for the messed up environment variable expansion as this issue probably will affect other applications too. Also once installed vorpX accesses the ‘Documents’ folder sometimes to optimize game settings. I have no idea whether vorpX itself will suffer from the same problem as the installer, but if it also fails due to your broken setup, some of vorpX’s auto game configuration features would not work for you.

    BTW: Might be unrelated, but get rid of Norton AV. One of those AV programs that may prevent vorpX from hooking games correctly. Windows built-in Defender is less invasive and at least as good these days.

    #186795
    LancerVI
    Participant

    I understand. All of my other applications use my documents folder with no problem, including games, productivity, etc. I must be missing something here. It’s the first time I’ve run into this issue.

    Thanks for your help. I will try to set it to default location and see if that works.

    Update: Changing to default documents folder worked. Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.