vorpx overwriting steam controller configuration?

Homepage Forums General vorpX Discussion vorpx overwriting steam controller configuration?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #173397


    I recently purchased vorpx and I have been experimenting with Guild Wars 2. It’s been a good experience so far even though there’s no support for stereoscopic 3D (it’s an option in the game, but it’s grayed out). I do have one issue that’s bugging me. It’s a bit complicated, so I’ll explain as best I can.

    Before I got my Rift and vorpx I was playing with a controller using Steam’s controller configuration tool. There is an option in Steam that allows you to create separate button mappings for when a cursor is both present and absent. I’ve included a link/image below explaining what I mean.


    For my purposes in Guild Wars 2, when I’m in combat and exploring the world I’m running with Action Camera (no cursor present) but as soon as interact with an NPC, look at my map, open my inventory, or use any menus, the action camera goes away and the cursor appears.

    In Steam, I created a button mapping layer called Mouse Controls so that when the cursor appears I have new buttons that aren’t combat related, like my right trigger becomes my left mouse button.

    When vorpx is running, and the cursor appears, my buttons don’t get those secondary functions (“Mouse Controls”). Rather, my combat buttons persist.

    I think vorpx is detecting the cursor and trying to superimpose its will over my Steam controller configuration somehow. That’s just a guess. I played around with settings in vorpx and I can’t figure out how to disable whatever vorpx is trying to do.

    Does anyone know the solution to my admittedly confusing dilemma?


    vorpX has its own gamepad to mouse/keyboard mapper, which would conflict with any external mapping program if both are used together. You can check whether it is enabled in the vorpX ingame menu.



    Thank you for the response. The vorpx gamepad options are set to Off.

    I’ve noticed that the cursor in game when vorpx is running is different than the normal Guild Wars 2 cursor. Perhaps that is a clue.

    I also tried adding/removing Steam .exe files to/from the exclusion list, and that didn’t change anything.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!