Vorpx Refuses to Work

Homepage Forums Technical Support Vorpx Refuses to Work

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #206820

    Hi everyone,

    I’m at a bit of a loss right now so I’m asking for help. I’m trying to get Vorpx to work on my laptop with an oculus quest 2.
    Acer Nitro 5
    GTX 2060

    Basically, I end up with 2 results with whatever I try. Either oculus will show a constant loading screen for vorpx or the left lens will be black and the right will show half a black display with a painting to the right. I’ve tried disabling the integrated graphics card, disabling anti-virus, running in steamvr in vorpx config. Tried using virtual desktop and oculus link, no difference. The constant loading screen only happens when I launch vorpx from the oculus link home, everywhere else gives me the screen described above. Also, I’ve reinstalled the oculus software and still no change.

    Like I said I’m kind of at a loss and willing to try any more suggestions you might have.



    If nothing works at all there usually is some conflict with another software that also hooks into games. If you see a dialog popping up after a minute or so with some trouble shooting options, please first try to install a hook helper to the game folder (first option in the dialog).

    If the dialog doesn’t pop up, or installing a hook helper doesn’t help, you have to dig deeper. First please check wether vorpX works in ‘Generic Headset’ mode (which will display its output on the monitor) to see wether there is a general hooking issue or a problem with sending the image to the headset. If the generic headset mode doesn’t work either please double and triple check for potentially conflicting tools. Ideally disable/remove everything that may get in the way. The trouble shooting guide above has more details.

    If generic mode works, but your actual headset doesn’t, please try all three VR APIs you can select in the vorpX config app. Your Quest will work best in native Oculus mode or with OpenXR (if enabled in the Oculus app), but SteamVR should also work. Ideally try with Link first, additional tools like VD just make things more complicated.


    Ralf, could you please also try to help me with the issue “How to get SoundSpectrum’s Aeon 3D Music Visualizer to successfully hook?” I posted this on the forum on Oct the 15th, but I have got no response to it yet. See below. This is very important to me and I would greatly appreciate your help. I just want to know whether or not it is even possible to get it working. Thanks in advance!


    I don’t have any experience with the application, sorrry. Judging from a brief look at their website I’d suspect it might be an OpenGL application. A bit older, available on both Mac and PC, makes OpenGL a reasonable assumption.

    Try to make a copy of an OpenGL profile in the vorpX config and then assign the application’s .exe to that copy. No guarantee that will do anything, but worth a shot. Good candidates to try are the Quake/Quake II/Quake III/Quake IV profiles.

    If you can’t make it work, you can use the vorpX desktop viewer as fallback option. 2D only, but that way you can display the app in the headset without vorpX hooking into it.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!