VorpX update performance problem

Homepage Forums Technical Support VorpX update performance problem

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #101808

    I have done a lot of testing and I have noticed a sever decrease in performance for Skyrim in the new VorpX update for me.

    In I got 35-55 fps in exteriors and 65-75 fps in interiors for GEO 3D
    I got a solid 55 – 75 fps in exteriors and 70-75 fps in interiors for Z3D

    Now I get only 30-35 fps everywhere for everything even in Z3D
    and I only get 25 – 35 fps in Geo3D

    I have not changed any of my Skyrim settings from before (except to decrease the quality which did not help at all)

    Does anyone else notice this problem?

    System: AMD Athlon x4 860k, 8Gb ddr3 ram, GTX980


    I would like to tell you something else, but a little test stroll here showed pretty much the same performance as always.

    40-50fps in the grazelands around Whiterun, 30-60fps in Whiterun, 60-90 in the first tavern in Whiterun and 60-90 in the usual test dungeon (Bleak Falls Inner Sanctum). Everything with Geometry 3D on a CV1 at the new recommended resolution (1280×1024).


    I was using 1440×1280 with DK2

    Are the 8/9 resolutions no longer recommended ?

    Also It seems my frame-rate (30-35) is close to the 1/2 refresh rate.

    There no longer is the Async option for “full” or “half” refresh rate.

    Can I return it to full by disabling the fluid sync ?


    Yes, please disable fluid sync on Oculus. As mentioned in your other post, please do not tweak too much, as tempting as that may be. Most options especially in the input and direct mode department are the right ones for your headset per default. They should only be touched under special circumstances.

    If you already tweaked a lot, it might be best to do a factory reset in the config app.

    Custom resolutions of any kind still work, but using the the recommended 4:3/5:4 resolutions is easier and also has some benefits in regard to async timewarp.


    I also tried with Skyrim default “low” graphics settings which has low shadows LOD and 1024×768. The frame-rate and frame skipping were the same as with ultra settings (no noticeable difference)
    I will say that it is not exactly the same as “judder” as with no async at all. There is some smoothness but the screen skips and jumps around uncomfortably around 2-3 times a second occasionally.

    When I go home I will try disabling fluid sync and see if this helps.


    Please do a factory reset. There haven’t been any changes to the D3D9 renderer at all recently. With the default settings everything works as it did with the last vorpX version.


    Short update: disabling async rendering (which you should never do except games run positively with 90+ fps) and enabling Fluid Sync at the same time pretty much leads to the frame rates that you describe, so that’s probably your issue.

    FluidSync alone can make things smoother in some situations, but please leave everything else in regard to direct mode where it is per default.


    I would never disable async for Skyrim.
    However, I will try this default reset tomorrow and hopefully that will help. (Although it was at factory settings when I updated to 1.6.2)

    Also I noticed occulus runtime updated and it seems to run the home studio thing with sound effects and everything and pops up instantly when I quit Skyrim. Hopefully that is not taking resources because I don’t think it can be disabled. Also the new Nvidia drivers may have changed some other settings in directX.


    I have found that this performance and stuttering problem seems to persist even at high frame-rates.

    For example when I turn fluidsync off I can get to 60-75 fps in interiors with z3D.

    But even at 60 fps I get this jitter/skip once every second or two so it does not seem to be a frame-rate issue but it does feel very uncomfortable. I did not get this in version It feels like I am going crazy but I am sure there is a problem that was not here before. I am not sure if it is VorpX or new oculus home or even new Nvidia drivers

    I have tried resetting VorpX todefaults and 1280×1024 resolution and nothing seems to help.

    I would like to try and go back to VorpX1.6.1.2 if possible because I know this worked well for me. I will send support request. I have a DK2 so I am fine staying with an older version and not getting updates.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!