Vorpx, VR and low fps

Homepage Forums Technical Support Vorpx, VR and low fps

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #211078

    Recently decided to get into VR stuff, loved Fallout 4 and other games but didnt want a full vr wand experience, and Vorpx is highly recommended so i decided to buy a headset, the program and give it a bash.
    Im having some major issues, and wanted some advice or help – nothing so far has worked.

    Intel Core i7 7700k (4400mhz)
    AsusTek Z170-P motherboard
    16g DDR4 memory
    Nvidia Geforce RTX 2060, 6gb
    Vive Cosmos Elite (headset only, 1 base station)

    Setup the headset ok, ive got a Vive console window that pops up with “motion compensation” and options to select Vive openxr, Steam Xr etc. Can select VR or WMR “experience”. No idea what those are.

    Steam VR installed and works fine – i can see the base unit, i have a pretty smooth and high fps feeling here, and i used a program called virtual desktop which is sharp, smooth and fast.

    If i run games on the Steamvr using the desktop theatre, i get IMMENSE fps drop and stutter. Nothing seems to effect this, but if i enable the motion compensation option on the vive i get this weird black liquidy bleeding artifact on the headset that makes me feel violently sick. WHen this ISNT happening however, the fps is pretty decent.

    If i use Vorpx to run games, Skyrim and Fallout for example, the Steam VR loads up aswell, and then Vorpx hooks into the game and it loads. I have a screen on my pc that is 200+fps. The headset meanwhile is 30fps or lower from the looks of it, and is very stuttery and laggy. I tried the different screen options for the vorpx program and they all seem to work and im having fun looking at geometry and z3d options, but the auto resolution picker seems to want me running at 2500+ x 1800+ resolutions and these are almost 1-2 fps at best. Ive set the quality option on the auto to the lowest, and fps is awful. I disabled the “change game resolution” option and added custom resolutions to the Nvidia card, and ive had the most success with a forced 1600 x 1440 res, with z3d and a massively reduced graphics options (very low).

    My question is, why is the fps so low? A few days ago i was alt tabbing while using the program to close background apps, and noticed that while i was tabbed out of the game window, the fps was MUCH higher – nearly 70+ in the headset – but obviously i couldnt play because my mouse pointer was elsewhere – what could cause this?

    Overall im enjoying the product and im very glad i bought it, but im confused as to how to play it without it being the primary window XD

    Oh my desktop resolution is 1980×1020 btw, as the monitor doesnt go higher than this. I was able to run DSR factors on Fallout 4, scaling it up to 2560×1440 and that ran at about 70fps and looked lovely – but that doesnt work in Vorpx for me – black screen and exit to desktop. Vorpx needing a window and all that to run i suppose?

    It seems any app that starts to use DX graphics, drops in FPS for some reason if it is the main window?


    Low end GPU. Vorpx is incredibly demanding.


    Seems there’s something wrong with your configuration, you also don’t mention what you’re using either, G3D will always be a lot more demanding than Z3D and might be the reason you’re getting 30 fps only. If you’re getting the same fps then there’s definitely something wrong with your configuration.

    Ignore fubar, he’s honoring his name.


    Well ive been tweaking and testing for a little while now, and scouring these forums and a few other sites ive hit some interesting issues.

    My Vive + Vorpx configuration seems to work the best when the custom window size is TALLER rather than wider – odd but the pixel density is tightest like this.

    For some odd reason, the picture quality is AMAZING in geometry when i run FO4 with a custom resolution of 1080×1440. (window, set in Nvidia custom res.)
    If i lower the height of the window, i get bad pixelation – but with that exact height, i get really good quality, and the fps is 45-65 with geometry on, full vr.
    Im happy to run it like this, it looks amazing and plays well, minor stutter in heavy built up places.

    Im interested in finding out why the geometry stutters so badly at higher resolutions, and depending on where you are looking – the Nuka world dlc map in Fallout has very little structures in it, so the fps is decent enough to run Geometry in 1920×1440 res at 45 fps – but as soon as i enter an area with houses or lots of trees it tanks. Is it the cpu or gpu thats struggling here? Should i be lowering texture resolution or finding LOD / draw distance tweaks?

    Im basically trying to figure out the best way to tweak my config files for each mode.
    Z3d is ALOT faster, as i read many times here, but i cant make the 3d look “right”, and the config files from the cloud ive tried dont seem to make the picture look natural – there is a lot of distortion.
    I downloaded a cloud profile for “Ark Survival Evolved” called “The Isle” and this put Ark on a curved screen, a slight distance from the VR “centre” and has geometry and Z3d support and looks amazing, but i cant seem to simulate that with Fo4 – different games and all that i know.
    If i can run Z3d with a decent enough looking depth that would be awesome, but i cant get Fo4 or Skyrim to look like 3d – i either end up with depth but strange mirror like halos around everything, or i get a cardboard cut out like depth XD
    Is there some sort of generic guide here that i havent found about the basics of the Z3d mode and what sort of settings im looking at? A sort of, set this to this, and slide that to that and then adjust this bar to get the depth type guide?


    I am not that much of a 3D-Fan and mostly bought vorpX to play on huge theater screens (free software doing the same causes too many troubles with several games) rather than having 3D effects, even if those effects can be really nice and add alot to the experience.

    So far i am gettin more into that 3D thing over the time and seem to use this feature more often now. Just today i started RESIDENT EVIL 2 (the remake of course) again, but this time in 3D and wow….LOL…when i first saw it all with geometry i almost fell off my chair. SADLY my rig can´t handle it so it´s stuttering pretty bad, lowering graphic configurations made it a little better but i still wasn´t “great”.

    But when i switched to Z3D it suddenly ran completely smooth and i was also able to use my standard graphic configuration rather than lowering most of it down to the minimum.

    So my first realization: Yes! Geometry seems to suck alot of power, so it seems i should get a better rig asap!


    The geometry is the selling point for me – ive played Fallout4 modded for nearly 3 years solid now, its without a doubt my favourite game. I think mostly due to the fact that i can change and tweak things and alter bits to suit how i want to play.

    Vorpx is the icing on the cake for this game – i can play it and be IN it – the geometry is without a doubt the golden lining for me. Im running my 2060 RTX now on 1368×1440 windowed game res, and thats nice and sharp and REASONABLY playable in most areas – ive been used to 25-35 fps machines so its not bad for me.


    Not sure if the preferred etiquette is to create a new thread or respond to an already existing one that’s old– But I am having the same issue that people don’t seem to be understanding properly.

    The game is running fine, if I look at my monitor I’m getting certainly more than 75fps [refresh rate of my DK2] (hundreds if I run HL1 or a similarly old and easy to run game) while the HEADSET output is very laggy and low fps.

    This is not a performance issue, the games are running fine but the headset output is very laggy for some reason.


    I’ve found out that for *me, increasing the 3D depth can actually cause glitches and effect overall performance, so that’s the first thing I’d check. Try to set the depth at the minimum required setting to get the 3D effect.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!