Watch Dogs hangs when attempting to hook

Homepage Forums Technical Support Watch Dogs hangs when attempting to hook

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #193597

    Hi Ralph,

    I installed Watchdogs, played to the first save. Fresh install of watchdogs on Windows 10.

    Then I fired up Vorpx – it was using the default profile.

    The game never completes loading – just the splash screen and then VorpX eventually reports that it is taking too long to hook and gives the options to close, skip or do nothing. Doing nothing just causes it to hang indefinitely.

    I am using HP Reverb which works fine with VorpX otherwise.

    The game complains if the Ubisoft overlay is disabled from uPlay (in any case I have run with Vorpx option to disable overlays both enabled and disabled)

    I have tried using alternative hooking method and running Vorpx as administrator (though Watch Dogs does’t run as admin so I never really expected that to work.

    I even tried some troubleshooting by deleting potentially corrupted save files and then launching (even though Ubisoft released their own fix for that issue anyway).

    I’m out of ideas now – is it a regression in


    This interests me as well, as i plan to play Watch_Dogs this year (it’s one of my very favorite games).

    VRified Games

    Same problem here,

    Did you ever get a fix?


    Unfortunately I was never able to replicate this issue. Did you try the ‘alternative hooking’ method in the config app? That can sometimes help without getting to the bottom of a hooking conflict. Don’t forget to switch back though later even if it helps, some games require default hooking.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!