Witcher 3 – Black Screen in Rift – vorpX doesn't attach

Homepage Forums Technical Support Witcher 3 – Black Screen in Rift – vorpX doesn't attach

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #178199

    Hi there,

    I must say, I’m pretty frustrated and disappointed. First of all, the hard facts: Win10, i5-6500, GTX 980, 16 GB RAM, Oculus Rift, Witcher 3 (GOG Version) installed (not on OS HD). vorpX does not attach to Witcher 3 after starting it. vorpX config is set, I created a desktop shortcut attached to witcher3.exe, I disabled (shut down) my Comodo Security Software completely, no other tasks concerning graphics is running (apart from Oculus App), but still: Witcher 3 starts in “normal” 2D mode, the Rift stays black when starting witcher3.exe, nothing happens when starting Witcher 3 via the desktop shortcut.

    What am I doing wrong? Do I need to install anything else? Mods, Patches, Updates for Witcher3? Do I need to deactivate the Oculus App that starts automatically when putting on the Rift? I see vorpX control work in the background with 15% CPU load without starting any app or game, but I can’t really figure out what’s doing.

    Please, I paid for this software and I don’t want to spend money for frustration… Thanks a lot in advance!


    Alright, so, it starts in “normal” — I’m guessing that means it doesn’t actually start in VorpX, but launches “normally” on the desktop monitor.
    First, under General in the vorpX Config, make sure you have the right HMD selected. As a fallback, you could always try SteamVR if you can’t get your Oculus to work properly with VorpX. Before you may ask, it doesn’t matter that it’s a GoG game.
    If that doesn’t work, and you may want to do this first, uninstall Comodo (you can always reinstall it after if this doesn’t work). You’d be surprised how often Antivirus protections are still “running” after being “shutdown”.
    Another possibility is that you need to make sure that the HDMI on your HMD is plugged in to your primary graphics card.
    Also, if you are running anything like FRAPS, or some overlay software (like Overwolf, Discord’s overlay, etc.), you will want to disable them.
    VorpX is not the issue here, there is an environmental factor on your system. Many people have played on Oculus and have played Witcher 3 successfully. Just take a breath, and try some troubleshooting steps.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!