Witcher 3 Next Generation Patch

Homepage Forums General vorpX Discussion Witcher 3 Next Generation Patch

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #215042
    efrain86
    Participant

    Does anyone have an idea why i cant get it running? When i Start it in dx12, nothing happens and i get Stück on oculus home or steamvr (tried both). At dx11 it starts in VR and i can See it on the cinema, but i have no 3D effect, even when all the sliders are to the Max. I want to Play it in third Person in 3d on cinema Mode, because first Person triggers nausea.

    Any ideas? Im using rift S and Standard vorpx Profile.

    #215047
    MarcDwonn
    Participant

    I agree, it’s annoying to get Stück. :)

    But seriously, i tried v4 DX11 in Z-Normal and had the same experience – no 3D. I catched a quick glimpse of a vorpX message, similar to “this version is incompatible”. I guess that there’s no profile for v4 yet.

    #215048
    Ralf
    Keymaster

    The 23.1.0 beta comes with something special for the latest Witcher 3 version. TW3 is now one of the profiles that have been heavily enhanced with a game specific mod programmed in the game’s scripting language. Provides alternate frame 3d, automatic FOV adjustment and auto EdgePeek in cutscenes etc. Reportedly compatible with a first person mod that is available for the game, but I haven’t tried that myself.

    You can download the 23.1.0 beta from the first post of the according thread in this sub forum.

    #215053
    MarcDwonn
    Participant

    Thx, Ralf. Does v4 work only with AF3D, or can it run in Z3D as well? Is it for DX11 or DX12?

    #215054
    Ralf
    Keymaster

    Z3D still works. The profiles launches the game with DX11 automatically. The game doesn’t really have a DX12 renderer. It uses a DX11 > DX12 wrapper that clashes with vorpX when it runs in “DX12”-mode.

    #215057
    Smoils
    Participant

    On beta tried newest witcher 3 and while full 3d worked, I wanted higher res and better frames so I tried z3d and it wasnt working. Tried using generic z3d profile did have depth in withcer 3, but strangely official profile doesnt work for me. Considering generic had depth I assume none of w3 settings interfered and I launched both in dx11, so pretty sure z3d on official profile just didnt work for whatever reason.

    #215061
    SavannaIbarra
    Participant

    Because it was a really terrible patch that just broke the game

    #215099
    MarcDwonn
    Participant

    redundant, pls delete

    #218608
    sameagol
    Participant

    [Edit]
    I fixed this issue by deleting r4Player.ws from your mod.

    [Original]
    Hi, I’m getting this error with the 23.1.0 BETA (pasted below). I’ve tried DX 11 and DX 12. Before I updated to the beta it was playable, just wouldn’t work in G3D. I have 3 additional mods, none of which are heavy or visual-related.

    Error [content0]game\gameplay\damage\damagemanagerprocessor.ws(557): Could not find function ‘ShouldAutoApplyOilImmediately’
    Error [content0]game\gameplay\damage\damagemanagerprocessor.ws(562): Could not find function ‘ShouldAutoApplyOilImmediately’
    Error [content0]game\gameplay\effects\effects\other\oil.ws(177): Could not find function ‘ShouldAutoApplyOil’
    Error [content0]game\gui\main_menu\ingamemenu.ws(1516): Could not find function ‘SetAutoApplyOils’
    Error [content0]game\gui\main_menu\ingamemenu.ws(1518): Could not find function ‘SetAutoApplyOils’
    Error [content0]game\player\states\vehicles\horseriding.ws(141): Could not find function ‘ShouldAutoApplyOil’

    Warning [content0]engine\environment.ws(30): Global native function ‘EnableDebugOverlayFilter’ was not exported from C++ code.
    Warning [content0]engine\environment.ws(32): Global native function ‘EnableDebugPostProcess’ was not exported from C++ code.
    Warning [content0]engine\showflags.ws(11): Global native function ‘DebugSetEShowFlag’ was not exported from C++ code.

    #219100
    mateuszw1995
    Participant

    I tried to run Witcher 3 nextgen (version 4.03) with latest Vorpx 23.1.0 beta in DX11 mode, but after installling additional components, script compilation fails as posted above. After removing r4Player.ws file the game launches, but there is no 3D effect in any 3D mode. I think something was changed in the game that brokes compatibility with code in this file (errors with SetAutoApplyOils are common in discussions about many mods that was broken).

    Ralf, can you tell which game version should work? Can you look why it is broken and check if it can be fixed?

    #219110
    Nigebik
    Participant

    Unfortunately, the latest version of witcher does not work with vorpx yet, I hope that it will be fixed someday. I recently completed witcher 3 with vorpx, I used vorpx no beta, witcher 3 version 1.31 (no next gen), Ranimate profile.

    #219780
    Florian-83
    Participant

    Fresh Steam The Witcher 3 Version 4.04 Installation here. Not working with VorpX 24.1.0 official Profile.

    Script Compilation Errors:

    Error [content0]game\gameplay\damage\damagemanagerprocessor.ws(557): Could not find function ‘ShouldAutoApplyOilImmediately’
    Error [content0]game\gameplay\damage\damagemanagerprocessor.ws(562): Could not find function ‘ShouldAutoApplyOilImmediately’
    Error [content0]game\gameplay\effects\effects\other\oil.ws(177): Could not find function ‘ShouldAutoApplyOil’
    Error [content0]game\gui\main_menu\ingamemenu.ws(1513): Could not find function ‘SetAutoApplyOils’
    Error [content0]game\gui\main_menu\ingamemenu.ws(1515): Could not find function ‘SetAutoApplyOils’
    Error [content0]game\player\states\vehicles\horseriding.ws(141): Could not find function ‘ShouldAutoApplyOil’

    Warning [content0]engine\environment.ws(30): Global native function ‘EnableDebugOverlayFilter’ was not exported from C++ code.
    Warning [content0]engine\environment.ws(32): Global native function ‘EnableDebugPostProcess’ was not exported from C++ code.
    Warning [content0]engine\showflags.ws(11): Global native function ‘DebugSetEShowFlag’ was not exported from C++ code.

    #219986
    Florian-83
    Participant

    Hello Ralf. Do we get a profile Update for the Witcher 3 “Next Generation Patch”?
    The official profile is not working anymore.

    #220018
    Laser
    Participant

    Would be cool to get this working on next gen patch, or if you (Ralf) don´t have any plans to make a working profile it would be nice to know so I can look for alternative method (superdepth3d) for running in vr or just play flat.

    #220019
    Ralf
    Keymaster

    Both Steam and GOG allow you to easily switch back to the last classic version of the game. Almost as if CDPR had a hunch that not everyone would be overly fond of their ‘next gen’ version. In Steam simply subcribe to the ‘classic’ beta in the game properties.

    That’s a better choice for vorpX. DX11 (required for G3D) graphics have been severly downgraded in the ‘next gen’ version, probably to make DX12/RTX stand out more. Shadows are less visible/defined, the best possible ambient occlusion method has been removed etc. All mysteriously things that then look better again when switching to RTX…

    So classic DX11 looks a lot better than ‘next gen’ DX11, actually almost as good as the much more demanding DX12/RTX. One could almost get the impression that some nVidia marketing money might have been at work behind the scenes. Purely potentially, of course. ;)

Viewing 15 posts - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!