Wolfenstein TNO + Gamepad issues (head tracking)

Homepage Forums Technical Support Wolfenstein TNO + Gamepad issues (head tracking)

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #207691

    So I’ve been playing The New Order with a gamepad (due to the sheer amount of the in-game actions, input can’t be properly/comfortably mapped to VR controllers, even with the “shift button” option). Everything worked, both gamepad and kb+m were active, though I always had minor issues when starting the game–it would prompt me to press “ENTER,” I would press “A” on the gamepad instead and the headset would go black / the window would lose focus on the desktop. I usually had to restart the game a few times to get it to work–but after the *massive* problems with Far Cry 4, that was peanuts.

    Yesterday, overnight, it stopped working. No updates downloaded or installed, no settings changed. But now, if I press “ENTER” at the start of the game, kb+m is active and head tracks–but the gamepad doesn’t work, regardless of whether I enable or disable it in the settings. If I press “A” on the gamepad, kb+m gets disabled, and since Vorpx doesn’t support DirectVR scanning in Wolfenstein and maps head movements to mouselook, head tracking stops.

    Now, Vorpx gamepad override works (great job there!), but the native mapping feels superior, so I would really love to go back to the way it was. Any ideas on how to do it / what’s happened? I may’ve accidentally pressed the “mode” button on the gamepad before it all happened, but I’m not sure anymore.

    I’ve tried deleted the profile and downloading again, restarting the game, Vorpx, Steam, and Windows, etc.


    If I understand the post correctly, switching the ‘X-Box Gamepad Override’ option to ‘Off’ is what you have in mind. May require a game restart, depending on how and when the game evaluates connected gamepads.

    CAVEAT: Some games don’t support mouse and gamepad input at the same time. In such games the gamepad > mouse/kb mapper is the only way to have both mouse based head tracking and gamepad input. That’s why the mapper exists in the first place.


    > If I understand the post correctly
    Not quite. I have the X-Box gamepad override working, it’s just that Vorpx’s mapping feels inferior to the native gamepad mapping (especially wrt. walking/sprinting).

    Wolfenstein apparently does support mouse and gamepad input at the same time–I’d played through 3 chapters without issue. Yesterday it stopped working overnight, so I was wondering what I could try to restore it.


    Natively gamepad input usually handles walk/run in an analog way, i.e. there is no hard switch between walking and running, instead you become gradually faster when moving the stick forward. With the override walk/run (obviously) works like keyboard walk/run with two distinct velocities.

    Not necessarily a bad thing in VR btw, at least if you are sensitive to VR sickness. Gradual velocity changes (acceleration) can be fairly sickness inducing when your body isn’t actually accelerating since your brain receives mismatching input from your eyes and your vestibular system.


    Thank you for the info, Ralf! Any ideas re my original question, i.e., what I could try to get both inputs back? It used to work, stopped working between two game starts yesterday. Like I said, I tried restarting everything, deleting and reloading the game profile from the cloud, etc.

    > Natively gamepad input usually handles walk/run in an analog way,
    > i.e. there is no hard switch between walking and running

    I don’t think that’s true at all. Most modern 1st-person games (Cyberpunk 2077, the Far Cry series, Rage, Wolfenstein TNO + TNC, etc.) have standardized gamepad controls: RT for shooting, RSTICK for looking, LSTICK for walking, A for jumping, B for crouching, X for using / picking up stuff / reloading. Beyond that, there may be differences, but these seem to be set in stone. Sprinting / running is *always* done via pressing and moving the LSTICK, i.e., there *is* a hard switch.

    Check out the following links:

    Cyberpunk 2077: Complete Controls Guide for PS4, PS5, Xbox One, Xbox Series X


    > With the override walk/run (obviously) works like keyboard walk/run with two distinct velocities.
    It’s not about having a gradual buildup in speed (Wolfenstein has none, and neither does Cyberpunk), it’s about how you switch between the two velocities. The native mapping makes me press the LSTICK for that; Vorpx’s override messes it up and starts analyzing how far I’ve moved the LSTICK. It doesn’t seem to allow me to get the switch back. I have to be very careful when touching the LSTICK lest the guy start sprinting like crazy.


    I’m sorry. But either I don’t really understand your original question or you don’t understand my replies. Honestly not sure which of the two it is. :)

    vorpX doesn’t change any game files or anything when you enable the override. So getting back to how you had thing before enabling it, is easy: you just disable the override.

    However, there are only two options as far as mouse based head tracking and gamepads are concerned:

    1. A game works fine with both gamepad and mouse input at the same time: if that is the case, you can leave the X-Box Gamepad Overide disabled since mouse based head tracking doesn’t cause a conflict.

    2. A game can’t handle simultaneous mouse and gamepad input: in that case mouse based head tracking will cause a conflict and you need the X-Box Gamepad Overide to use a gamepad together with head tracking.

    There is no way to get native gamepad input and mouse based head tracking when a game can’t handle simultaneous mouse and gamepad input. The whole point of the gamepad override is dealing with such a conflict.


    Okay, let me rephrase–I think the original post was way too convoluted.

    1. Wolfenstein: TNO worked fine with both gamepad and mouse input until yesterday.
    2. Yesterday, it stopped working with both inputs, forcing me to enable X-Box Gamepad Override. I don’t particularly like the way the Override handles controls (especially wrt. walking/sprinting), so I want to get back to the way it was in 1).
    3. What could be the reason(s) for 2) and what could I try to get back to 1)?


    Unless I misunderstand that either, 2. was answered above, I think. You disable the override by switching the ‚X-Box Gamepad Override’ setting off. Like said above vorpX either overrides gamepads or not. The only thing that affects this behavior is turning the override on/off in the menu.

    As far as the origin of your original issue is concerned, I can’t really say much unfortunately. If “suddenly” something changed without you changing this setting, there must have been something unrelated to vorpX that changed. E.g. gamepad input being disabled in the game options.

    The only thing I can really recommend is resetting both the game options to default as well as the vorpX profile (respectively deleting and re-downloading it in this case, since it’s not an official one).

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!