Wont attach to The Surge

Homepage Forums Technical Support Wont attach to The Surge

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #185366

    Can’t get vorpx to attach to The Surge here. Downloaded the profile for it. Vorpx hooks into other games I have, like Kingdoms of Amalur, STALKER: Call of Pripyat, or Titan Quest.

    I am sure the profile is working, when I attempt to make a new profile and attach it to TheSurge.exe I get the error message that there is already a profile attached to that.

    It doesn’ even attempt to attach when I’m booting the game. I have a Lenovo Explorer (WMR), which I use with a USB Headset and an XBOX 360 controller (wired).

    I run Windows Mixed Reality Portal, Steam VR on top (which also starts up Revive), then I run VorpX. VorpX is set to link into Steam VR. Game is on Steam, so Steam is running in background.

    I have Steam Overlay disabled, Nvidia Experience overlay disabled, Windows gaming whatever-its-called xbox bs overlay disabled, BitDefender Shield is my AV, which I disabled for 1 hr before attempting to run. Also GPU Tweak and GII Monitor, I have task killed before trying to run the game.

    All I’ve got left on my task bar are Rainmeter, Bluetooth Devices, GTX 1050 Ti Display (that thing for switching what GPU games run on), Steam, Steam VR, Revive, VorpX control, SpaceDesk (disabled), and the lovely windows security icon to tell me my computer will explode since my AV is off.

    When I run the game the “attaching to” dialog never even shows up. Any idea what could be stopping VorpX from attaching?


    Hi, You didnt wrote if you tried the admin checkbox or the alternative hooking, but youre right, I own a Lenovo Explorer too, you have to start 5 programms before you get into play sometimes :) I have also experienced starting problems often, for these cases I have Batman Arkam Asylum it will start everytime then I get out the game but let Windows mixed reality client and SteamVr active, then I start the game I want to run. I have the impression in most cases the game starts quicker then WMR Background and SteamVr get up and then VorpX helplessly stays in the background trying to inject. Anyway try a running programm and do it like I did.


    Thank you for answering and giving some ideas of something to try :)

    I tried running KoA:R, as it works for me, waiting until it was attached, and minimizing it, to start The Surge. Still didn’t attack, never saw the pop up. I tried it both with and without “Use Alternative Hooking Method” checked. I have “Run vorpX Control as administrator” checked as well, or did you mean something else by admin checkbox?

    If you didn’t mean leaving one game that works running while starting the other, then previously when I was troubleshooting I tried running games I knew worked first to confirm vorpX was working properly before trying The Surge again.


    yo have no further ideas, maybe there is a game launcher were you can switch Dx versions ? Since it is a local profile it should work out of the box must be some different thing, you on your own :( good luck anyway


    If by chance the game has a dx12 mode, make sure to switch to dx11. Vorpx won’t hook 12. Sorry if this doesn’t apply.


    I haven’t been able to find an option for changing DirectX version, but when I run the game windowed it says DX11 on the application bar…


    … GTX 1050 Ti Display (that thing for switching what GPU games run on)…

    Sounds like you are using a gaming laptop. If possible try to disable the integrated GPU entirely. Not all laptops provide such an option, but maybe yours does (e.g. in the BIOS).

    I also wouldn’t rule out BitDefender, which is a known troublemaker in regard to vorpX and diffcult to disable since you have to disable several of its modules separately. IIRC a BitDefender function called ‘Advanced Threat Protection’ or similar could cause hooking issues.


    Thanks Ralf, you nailed it. It was advanced threat defense in BitDefender. Interesting that it only prevents attaching to some games and not others.

    For anyone who searches up this thread, in BitDefender, choose Protection tab from the left, then Turn off Advanced Threat Defense with the slider above it, and also under antivirus click settings, then use the slider to turn off BitDefender Shield.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!