World of Warcraft / Vorpx Desktop Viewer Troubleshooting

Homepage Forums Technical Support World of Warcraft / Vorpx Desktop Viewer Troubleshooting

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #194813

    Hey everybody. I’m new to Vorpx. It seems like an amazing program. I can’t wait to use it.

    Has anybody had any luck with World of Warcraft recently? I can’t seem to get it to “hook” it just says attaching to “WoWclassic.exe” and then it seems to time out, and I get the option to exclude from vorpx list, do nothing or close application. I’ve seen and heard of a ton of people being successful using vorpx with World of Warcraft, I wanted to know if it wasn’t a patch that broke it and that it is still working. I would love to use vorpx to play on private servers on some older versions of the game, however I also read that only the official game through the launcher will work (or will it?).

    I’m using an Occulus Quest with a cable to connect to pc via occulus link. I also cant seem to launch the Vorpx Virtual Desktop Viewer. It gets stuck loading and never appears in my VR.

    I have been troubleshooting for days and have followed everything on the troubleshooting guide. I have turned off windows defender, uninstalled all of my antivirus software, added the Vorpx folder as an exception to my antivirus, tried alternative hooking method, changing WoW to dx11legacy, tried creating a vorpx shortcut… all with no luck.

    I’ve made sure there are no other processes running in the background. Occulus link automatically runs whenever I connect my headset to USB to my computer. Other than that, just Vorpx, and World of Warcraft. The only thing I can think of maybe is this pesky “antimalware service executable” that I’ve tried everything to get rid of. Even so, I’ve tried adding vorpx to the windows defender and alternative antivirus exception lists as well as completely disabling all antivirus software.

    The only other game I’ve tried in Vorpx is Star Wars KotoR II which I was able to launch successfully, which makes me think its not an AV problem.

    Please, if anybody has any input or can confirm for me if WoW is working for you let me know! I am dying to experience Azeroth in 3D and that’s the only reason I purchased a vorpx license!

    Ralf, I see you are on here always working hard. I appreciate you and anything you can do to help me get my money’s worth! Thanks yall


    WoW is working fine here, the profile got updated for the latest version not too long ago. Since it’s a fairly popular game I’m also sure there would be more posts like yours if there was a general issue.

    I assume you also checked the rest of the trouble shooting guide above, not just AV software. Just in case you didn’t, please go through it entirely. If for example you happen to use a gaming laptop, the issue might also be related to games starting on the integrated GPU. The desktop viewer not working sounds suspiciously like such a case.

    The ‘antimalware service executable’ belongs to Windows Defender. While occasionally Defender may also cause problems briefly after a vorpX update, currently that is not the case. You don’t need any other AV software BTW, that’s overkill. Defender is very good these days. Third party AV may cause as many problems as it pretends to solve.

    If after thoroughly going through the entire trouble shooting guide you still can’t make it work, please create a trouble shoot data archive in the config app *after trying to launch the game* and send that to support at vorpx com.

    Private WoW servers/clients: some things in G3D profiles may break between game versions, so the chance of getting a custom version of the game working in 3D and with HUD definitions etc. is fairly slim. Not impossible, just not very likely.


    Hey, I’m having a WoW-related issue for some time yet. It is about mapping some textures differently for each eye, making mess (only in G3D). Like in an image below, the whole blurry dirt is mapped almost similar but with little shift, easy to spot at the central part around the vertice angle.
    different textures
    Latest NVidia drivers, same for Oculus and VorpX.


    P.S. this issue is related only to ground textures like tiles in Stormwind or dirt or piece of ground with flowers drawn on it etc.
    Right after loading (or after swtiching from DX11 to Legacy DX11 ingame) everything is fine until ingame camera is rotated, then goes some kind of texture fighting and then it stabilizes in shifted textures state.


    i play a lot in 3rd person Vr..originally i was using the oculus rift..which was PERFECT!! then i recently got a vive because the earphones to my rift is damaged.. there are a few profile you can use from the cloud server and import them to your
    vorpX game local list.. Good luck and see ya in Azeroth !! :)

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!