WoW refuses to hook

Homepage Forums Technical Support WoW refuses to hook

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #212831

    Is anyone currently able to get VorpX to work as of patch 9.2.7? To clarify, I’m only stating the patch for timewise. Last time I played WoW was back in late 2020 and, although I wasn’t able to get full 3D to work, VorpX would at the very least hook. I resubscribed yesterday and cannot get VorpX to hook under any conditions. I’ve googled a bit and have tried a bunch of solutions that worked for others including:

    Using dx11 and dx11 (Legacy) instead of dx12, running windowed mode with each of the three dx levels, trying each of the options VorpX provides (Installing hook helper, alt hooker, administrator mode), restoring the WoW profile to factory settings, trying multiple cloud profiles, and making a VorpX shortcut to the Wow.exe. I have tested with other games and VorpX hooks like normal. I’ve read some of the common issues such as any overlays running or running on a notebook. Although I am using a notebook with a discrete GPU, VorpX was able to hook just fine last time I played in 2020 with the programs I always run. I even went into WoW and told it to only use the dedicated GPU.

    Anyone have other ideas on something I might be missing? Even a confirmation that someone else can run retail WoW currently would help show it’s likely something on my end.


    Still working fine here with the latest version, neither a hook helper nor alternative hooking are required. Just in case: The ‘DX11 Legacy’ renderer is mandatory, that’s the only one that works with vorpX.

    If the trouble shooting options don’t help, there probably is some more severe conflict with another program on your PC. The trouble shooting guide on top of this sub forum has more details on the matter.


    Wanted to update and say that I found the (somewhat unexpected) issue! Unsure if it’s an issue with my personal laptop or a more general issue, but it seems that Fortnite will keep a background process of Easy Anti-Cheat running even after the game is closed. I have to manually end the background process through task manager regardless of how the game is closed. Was able to get it running and incredibly happy with the results. Thank you for your help!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!