xbox 360 controller issues with Resident Evil 7

Homepage Forums Technical Support xbox 360 controller issues with Resident Evil 7

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #179291

    The xbox controller(wired) seems to work fine except for the left trigger. The left trigger (right click mouse) is to draw your weapon. It does draw the weapon but goes back and forth as if I’m letting go and repressing the button even though I’m holding the trigger. Outside of vorpx the controller works without issue in this game.

    I then tried changing the controller from ‘full’ to ‘partial’ and ‘none’. Both partial and none solve the problem, but both introduce a new problem. If I am walking forward and look in any direction, the axis become flipped. So up is down, down is up. As soon as I stop walking, looking around behaves as normal.

    I tried binding draw weapon to a new button in game, mapping right click button to a different key and changed it accordingly in vorpx, but the repressing issue remained.

    I also tried the button press threshold (default 30) tried 0 to 100 but didn’t solve the issue.

    A separate issue I have is I use adaptive 3d instead of geometry for performance issues. With adaptive 3d, tilting my head left or right tilts the whole world along with me, when it should stay level. Not sure if other games have this issue. This issue doesn’t happen in geometry mode.


    Please do not change the ‘Controller Override’ setting, it has to stay at ‘Full’. Profiles only override native gamepad handling if it interferes with mouse based head tracking, which is the case here.

    Rule of thumb: in almost all cases with ‘Controller Override’ set per default changing it breaks head tracking.

    More generally speaking: tweak default settings carefully and always first try to reset a profile to default in case of issues after tweaking any settings.

    I’ll look into the Z3D issue, for now please stick to G3D and maybe reduce graphics fidelity in the game options instead.


    Yes as soon as that up is down stuff happened, I went back to ‘full’.

    Ok, I re-imported the official vorpx profile for re7 and went back to geometry.

    Sorry I might have not been clear before, the button issue exists in geometry as well. Also, after retrying, it’s not that it’s pressing/depressing/pressing again while holding, it’s simplying registering as one press, but not the hold.

    I tested this by holding the right mouse button, the gun stayed out and the target reticle goes to a dot. But if I just press and release the right mouse button, the gun comes out and you get a cross hair instead of a dot and the gun goes away after a few seconds, same as vorpx.

    So it seems to be registering presses, but not holds. This may be happening to every button in the game, just that others dont (afaik just started playing) need a hold, but it may be more apparent with the triggers being having a larger threshold that normal buttons. As I mentioned, tried the button threshold setting in vorpx to no effect.

    I was only changing buttons to see if I could resolve this issue myself. But right now, in game and via vorpx both have the buttons at their defaults.


    Not really sure whther I understand the issue, but I’ll look into it. Might be an issue with vorpX, but it’s just as liekly that the gamepad emulation simply can’t fully replicate how the game treats triggers natively. The vorpX gamepad emulation can emulate mouse movement and basic button presses but not more complex scenarios game developers might have implemented for their individual native gamepad handling.

    If you want more sophisticated gamepad emulation that allows deeper and more complex configuration/programming, dedicated gamepad emulation software like Xpadder or Pinnacle Profiler is worth considering.


    After resetting to defaults, I bound mouse left click to the xbox’s left button (I left it the left trigger binding alone).

    The gun draw behaviour works fine with left button.

    Sorry, I might ramble and complicate things. Basically, left trigger (I assume both triggers) are not currently registering a press and hold, maybe something due to their analog nature?

    I may try outside mappers, but I think this is vorpx issue where xbox triggers don’t register holds. Maybe it affects more games as well.

    I’m happy I can play for now using left button instead of trigger, but it would be good if this can be fixed.

    thx again.


    Now I got it. You might be right, at least that was an issue at one point. Should have been fixed long ago, but I recently rolled back some gamepad code to an earlier state, so maybe it’s back. Will definitely check that.


    Awesome thx. The z3d tilt thing was a separate issue outside of the controller issue. Maybe that has to do with loss of positional tracking… But playing with g3d for now. Again, modest system so I’ll use z3d for the fps boost even if losing positional tracking and true 3d.

    But just wanted to say I mainly bought vorpx last year for RE7 (other games were a bonus) as I was ticked off capcom wasn’t bringing it to PC. The shimmering weapon thing was a deal breaker for me so I held off on playing.

    Anyway, really glad you got that fixed and am happy to say RE7 is great in vorpx now. And with a fps mod for RE2, I might have to try that next. thx.

    Vorpx can be intimidating to use at first, but lots of options are there to make a lot of games work in vr. A great contribution.


    you have to set your controller settings according to the game, maybe it is not configured properly that’s why you are facing difficulty ..

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!