3d Blu Rays and VorpX Tutorial

Homepage Forums Game Hints and Settings 3d Blu Rays and VorpX Tutorial

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #192626
    moadepth
    Participant

    Hello everybody, here is a little tutorial on how to run your 3d Blu Ray rips in Vorpx’s Desktop Viewer.

    1. Make a backup of your 3d Blu Ray.
    Download MakeMKV : https://www.makemkv.com
    on the website below you can find a key to unlock all features of MakeMkv
    https://www.makemkv.com/forum/viewtopic.php?f=5&t=1053
    Only valid till march 2020 so hurry !!!
    Put in your disc and let MakeMKV do its work (takes a while) after that select
    the biggest file in the resulting list unfold it via the small arrow on the
    left and make sure to check the 3d option and your favorite audio language
    uncheck all the unwanted stuff and save the file to your hard drive or ssd.
    (lot of youtube videos on this matter)

    #201453
    svarni
    Participant

    Hi and thank you for your tutorial! I have just made a copy of my newest 3D BluRay Disk. However, your tutorial has no second step – how to properly view the video file in 3D? I’ve tried VLC player, but the video coming from MakeMKV is not side-by-side, so I have no idea how to watch in 3D.

    #201456
    moadepth
    Participant

    Sorry I wouldt like to help but my post gets constantly deleted.

    #201457
    moadepth
    Participant

    seems the forum is still buggy …

    #201458
    moadepth
    Participant

    new try
    2. Download the MPC HC video player https://mpc-hc.org/downloads/
    Download MadVr http://madvr.com
    install
    Download K lite standart codec pack https://www.codecguide.com/download_kl.htm
    Download LAV-Filters https://www.videohelp.com/software/LAV-Filters
    install
    3. Go into the options/settings of MPC HC video player and select the output
    settings and change the video renderer into madVR
    go to the external filter settings and add madVR and the 4 Lav filters to it
    4. Now everything is ready to start
    start the Vorpx desktop viewer
    right click on your previously made video file and open it with the MPC HC
    player (steamVr and other Vr clients should start immediately)
    press the del key for the VorpX menu, go to image settings and select side by
    side output then go to display settings and turn Direct Mode Async Render off
    (makes the the video replay much smoother) save your settings !
    sidenote : sometimes MPC HC resets the video output back to the standart
    renderer make sure madVr is always in charge.

    Hope it works for you enjoy !

    Btw this methode maybe outdated and there a now perhaps some easier ways ?, its still working here but I have only 4 3d Bluerays :(

    #201473
    svarni
    Participant

    Hi and thank you for that quick reply!

    I have indeed used MPC-BE, wich seems to be still active.

    Also used madVR and now I “just” need to tinker around with the specific display settings for the movies.

    Thank’s again! :)

    #201738
    Laser
    Participant

    I can´t get this one working properly.
    If I run desktop viewer and just start the video MPC always defaults to output “Enhanced video renderer” instead of Madvr. Then if I switch to madvr and reload the video, my desktop switches resolution to 1920×1080 and vorpx unhooks from the player.

    #201740
    Laser
    Participant

    I think I got it working starting things in a different order.
    1. Start Mpc-hc
    2. Change video output to madvr
    3. Load 3d.mkv file (this changes my desktop resolution and colour settings(?)
    4. launch vorpx desktop viewer

    I have to do some more testing tomorrow.
    Im using Reverb G2 btw, maybe this has something to do with the problems I am having, maybe the upcoming vorpx update makes things simpler.

    #201741
    Ralf
    Keymaster

    If you want to use MPC-HC with the desktop viewer instead of with vorpX hooked into MPC, you can simply pause the watcher from the vorpX tray icon‘s right click menu after starting the desktop viewer.

    Be aware though that watching videos with the desktop viewer involves two framerate conversions: movie framerate > desktop framerate > headset framerate. Hooked into the player vorpX upsamples directly from the movie framrate to the headset framerate, which typically is a lot better.

    #201744
    adzter
    Participant

    I didn’t know you could hook directly into MPC-HC, Ralf.
    I don’t see a profile.
    Is it as simple as starting Vorpx and then MPC-HC and it should automatically hook?

    #201751
    Laser
    Participant

    I didn’t know you could hook directly into MPC-HC, Ralf.
    I don’t see a profile.
    Is it as simple as starting Vorpx and then MPC-HC and it should automatically hook?

    There is a profile “Mediaplayer Classic Home Cinema” and it just works. ;)
    Normally when watching side by side 3d videos its easier but framepacked blurays seem to be more trickier.

    #201753
    Laser
    Participant

    Be aware though that watching videos with the desktop viewer involves two framerate conversions: movie framerate > desktop framerate > headset framerate. Hooked into the player vorpX upsamples directly from the movie framrate to the headset framerate, which typically is a lot better.

    After watching some clips today, yes there is a problem with conversions. With madvr the desktop resolution changes to the video resolution and framerate, so 1920×1080 @23hz for 3D-blurays. And while the movie plays very smooth on the desktop, it is somewhat juddery in the headset. Most noticable in panning shots.

    Apart from the framerate issues this is the first time for me to consider watching a full 3D movie with my hmd instead of tv. Previously I had just watched compressed movies and the resolution and screen door effect of my previous hmd (rift cv1) was not good enough compared to my 4k tv. And as a bonus there is zero ghosting when watching in vr compared to 3dtv and obviously far more immersive.

    As a side note, I like the ambience mode but it doesn´t work so so great with 2.35:1 content since the ambience starts after the black bars on top and bottom. I don´t know hard it would be to change this?

    #201758
    moadepth
    Participant

    @laser yeah looks nice imo better than 3d cinema or tv. I have also a g2 HMD and I also have a 4k monitor but I dont have those problems (reschange, juddery ect.)
    Last year i had a 1080gtx+lenovo explorer and had also to struggle in fast cam heli shots also its usefull to store your mkvs on ssd>hdd it will help alot.
    BTW. VLC will also give you sbs but only on monitor but with Vorpx will not work total mess.
    @Ralf if I start your recommended way -start VorpX – start mpc – start video
    its ok but as soon as I want enter Vorpxmenu via DEL key it prompts mpc to stop and asks to delete the file (Nooo) the Vorpx menu freakin flickers and there is no other way out to quit all and not start this way again…

    #201762
    Ralf
    Keymaster

    Didn’t have that annoying MPC key issue on the radar when I replied above… Will be fixed in the next vorpX version. VLC should work though normally. Make sure that its video output is set to DirectX 11. vorpX should take care of that automatically under normal circumstances, but maybe that failed for you (e.g. if you have disabled auto settings).

    #201768
    Laser
    Participant

    Ok, almost got it working with out desktop viewer and its judder problems.
    You actually need to vorpx to hook up to madHcCtrl.exe and not mpc-hc64.exe

    So I temporarily changed my mpc-hc64.exe to something else so vorpx doesn´t try to hook up to that since its also running parallel with madhctrl.exe.

    I made a copy of media player classics profile since I can not add or remove processes of that built in profile. Now it hooks up fine to madvr but now the options page for changing video format is gone?`

    Ralf any ideas, can I fix it myself or do you need to make changes to vorpx itself?

Viewing 15 posts - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!