7 Days To Die

Homepage Forums Game Hints and Settings 7 Days To Die

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #124171

    Up to now, I’ve been playing this in 3D with TriDef and Virtual Desktop. The devs are going to make it VR, but said it will be a long way off yet, after all the content is in.

    Yesterday I came to check on the info with the new update and spotted a post where someone said they had a profile for the game, but today, try as I might, I just can’t find the post. So, if that was you, or you have a profile for this game, please share the info with me. I have read all of the VorpX info, and though I have had it for about 6 months, I haven’t got it working yet (bought it for Far Cry 3, really), so I am not exactly experienced at getting it to work, so some tips with 7 Days To Die would be awesome.

    I have over 1,700 hours up in the game so far and not getting even slightly fed up yet!


    EDIT: I found it – so thanks, but still would be grateful for any relevant tips :-)


    I’m also interested to playing 7D2D with VorpX. Can you share your experiences with it and how you configure it?


    I haven’t tried VorpX yet – was asking for any tips. I will be trying it as soon as I have some time for playing around with testing and troubleshooting etc.

    If I get it sorted, I’ll post whatever I have.


    Working on writing up the instructions now. I will publish the profile to the cloud and instructions here later today


    Please note: There is a profile published in the Vorpx Cloud already by Rkese, but I am basing none of my notes nor profile on that one. It may work great, but I have become accustomed to making my own profiles first before trying ones made by others. Feel free to try that one as well, but I will use this forum soon to publish some notes you’ll need regardless


    Notes about playing 7 Days to Die with Vorpx:

    – Download my “7daystodie” Vorpx profile (or make one of your own)

    – You can’t play with EAC enabled. Play the non-EAC version of 7DTD

    – Run 7DTD at least once beforehand. Go to the display menu and turn off Depth and Blur and Vertical Sync

    – I also turn off my nVidia card’s global vertical sync as well, but up to you

    – Make sure you can support the 1600 x 1200 resolution. Create the custom resolution in the nvidia control panel (or AMD equivalent) if needed

    – Sorry, but you’ve got to change some registry keys.

    * Open REGEDIT
    * Browse to HKEY_CURRENT_USER\SOFTWARE\The Fun Pimps\7 Days to Die
    * Change “OptionsFieldOfView_h1003984851” to decimal 110
    * Change “Screenmanager Resolution Height_h2627697771” to decimal 1200
    * Change “Screenmanager Resolution Width_h182942802” to decimal 1600

    (I used REGEDIT for the resolution because 7DTD menu doesn’t always present all resolution choices in the display options menu)

    – Before playing 7DTD, change your desktop resolution to 1600 x 1200 (it will look weird I’m sure). This tricks 7DTD to use the resolution properly

    – When you play the game, NEVER open the display options menu … it will reset the FOV

    – Play the game! Works so awesome, especially with Vive controllers!

    – It will – of course – look bit pixelated, but that’s due to the stock graphics, which are not HD. Fun Pimps will supposedly release HD textures in Alpha 16

    – Optional: I chose 1600 x 1200 resolution because it looks awesome and I can’t seem to get it any higher. Feel free to use a different resolution. Make sure you change the registry values to match. Just don’t open the display options menu ingame after you’ve changed the FOV or it will reset


    Thanks very much for this.
    Yes, I just signed up to the VorpX Cloud and saw the profile by Rkese, which I have downloaded.

    I’ll try according to your notes, too, and see what I can get.

    Thanks again – I will post how it turns out.


    The great news is that it works :-)

    The not so great news is that the FOV is messed up. I changed it to 110 but it’s very narrow in the game.

    I’m using 1600×1200 as described. The toolbelt isn’t visible – it’s off the bottom of the screen – and it’s amost like I’m zoomed right in – can just see the left edge of the stone axe blade and the items on the left of the GUI are well out of sight.

    I will try increasing the FOV, but I don’t think I can take it that much further?

    I’ll try a smaller resolution, too, as although it looks fine – pixelation excepted – I wouldn’t be able to play at this FOV.


    Increasing the FOV to 120 didn’t seem to make any difference.

    I changed the res to 1920×1080, which is the native res of my monitor, but this made no difference either – except I felt slightly more comfortable with it.

    I take it there should be no headtracking in game – there is a little movement, but not much, and most times it just skews. That’s okay – I’m happy to use the mouse.

    It’s doing a good enough job to be able to shoot zeds and animals with the bow & arrow, but with so much of the GUI out of view, it is still unplayable. Also, the fact it is so zoomed-in by default (it actually looks really good when I use the in-game zoom) means judging distances is very difficult.

    I’ll continue to try adjusting things, but with this being the first time I’ve managed to get anything working with VorpX, I’m not sure what I will be able to achieve.


    I think I have found the problem, but I can’t fix it.

    It’s that the FOV is not being implemented. I set it as per your notes, at 110 and didn’t open the options in game before playing.

    I have just changed the FOV to 65 and there is no difference whatsoever in game using VorpX. I can still see the same amount as I could with the 110 setting in the registry – when I opened the options on the desktop, it was at 90, so this would show that it had changed, at least in the options.

    I don’t know what else I can do to try and force the game to use the extended FOV. If I could do that, I think it would be fine.


    Couple questions …

    1) Do you verify afterward that the registry entry for FOV is what you set it at and didn’t get replaced with another value? that would show 7DTD is overwriting it for some reason, like when the display menu is opened

    2) Do you use Edge Peek? The UI should not be an issue, as with all Vorpx games, Edge Peek needs to become second nature for accessing inventory, maps, etc. I don’t even think about it anymore, especially with the Vive grips as a mapping

    I can tell you this … when you get the FOV to work, it will DEFINITELY make a difference every time you change it 5 or more

    Make sure Vorpx actually says “Running in 1600 x 1200 resolution” when it starts up. Many times, games will force a different resolution, and Vorpx will tell you this

    1920 x 1080 is a widescreen resolution and should be avoided. Always use a 4:3 res, as it is hardly scaled at all to fit the lens resolution. Widescreen gets “squished” and things look ugly

    Also, I get full head tracking and play standing up using the controllers to get near-room scale effect.

    Keep at it. Glad to help, as I love the game and Vorpx too. Once the FOV, resolution, and tracking line up, then you just have to reteach yourself the Vive controller and you’ll be amazed at how fun it is


    By the way, I should clarify …. using Z-adaptive mode, the near-room scale effect I mean is with environment and locomotion. Positional tracking is NOT supported. You can’t lean and peek, you’re really just becoming the mouse. But you definitely should be able to turn and look up at the sky, face the floor, etc. As with many Vorpx games, use the mouse or controller to “correct” your head if you end up off the horizon


    FOV setting of 115 is the last one for me that works before becoming too “warpy” when you turn

    Anything under 100 seems to go back to the fish-eye effect

    110 works best for me


    Okay, thanks a lot for the tips. I now have a setting that is good for me – but with no head tracking.

    I did check that the FOV in the registry was still 110 by the way. Also, 1600×1200 is supported by my monitor, so didn’t need a custom res.

    For some reason, I am unable to use edge peek at all. I opened up the VorpX menu and I had to reduce the zoom all the way to 50 to be able to see enough to play – and then it was very fish-eyed. Funnily enough, changing the FOV to 90 fixed that.I am using a Rift, btw, but I think the res is the same as Vive.

    Anyway, I can play okay now, but there are black bands at the top and bottom, which I can deal with, as long as the edge peek isn’t working. The head tracking was definitely not implemented, and as trying to move my view with my head was just giving a lot of vertical judder, I disabled it for testing purposes.

    I’ll keep plugging away, but at least I know I can use these settings for playing well enough in 3D for now.

    Thanks for your help!

    oh PS – I tried that other profile from Cloud, but it didn’t work at all. Maybe it’s an old one.


    Sounds like – if you have no edge peek – that you have not selected a 3D mode and have zoomed into the Virtual Cinema instead? Not sure, but make sure you are in Z-Adaptive mode with Virtual Cinema off. The oddities you are describing sound like you have not turned on 3D. I have not used an Oculus though either, so could be an HMD difference

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!