Bioshock original CRASHES only with vorpx

Homepage Forums Technical Support Bioshock original CRASHES only with vorpx

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #219659
    rogerty
    Participant

    Good morning.

    I need help with bioshock original version: in Windows 11 works ok, but with vorpx (v23 or the actual v24.1.0) the game crashes (closes itself, or the screen freezes with an image or blank screen):

    – When loading the saved game the screen freezes until I press ctrl alt supr: this, sometimes fixes the issue, but many others closes the game.

    – when loading a game most of the time closes the game, sometimes not.

    – after saving a game it crashes sometimes.

    All this does not happen without vorpx.

    I have tried different modes (full vr, cinema, etc.), with controller, with keyboard, using virtual desktop and vdxr, using oculus link, using steamvr, with or without head tracking… same result in all the cases.

    Does vorpx gives official support ? I can offer any log and ini data as requested, thanks.

    By the way, I am using an AMD Radeon Rx6700XT 12 GB and the Quest 2

    Please… HELP ! (Like the Beatles album)
    Regards !

    #219677
    Boblekobold
    Participant

    I just tried it and I have no problem with Bioshock 1.
    Win11 RTX4090 VorpX V24.1

    I use “Don’t Optimize game settings” and textures on ultra in VorpX.

    I play with 3840×2880 resolution. G3D (Shadow no S3D) with clarityFX to full, sharpness to 2.0 on reverb G2.
    I use the setFov option on keymap in ini files in order to have a FOV of 105 (so scaling is perfect in Full VR, unzoomed to the border of my view).

    If you don’t know how to do it, configure in User.ini :
    Up=MoveForward | SetFOV 105
    Down=MoveBackward | SetFOV 105
    (Of course you can choose another key or FOV value)

    The game is stunning this way.

    No crash, but I just tried the beginning. I tried quicksave a few times (save and load).

    I use OpenXR runtime, but I suppose you can’t with your Quest 2.

    Did you try Oculus Runtime ?

    Are you sure it’s the original version ?

    #219726
    rogerty
    Participant

    Hello, thanks for your answer.

    You said “Don’t Optimize game settings”… Do you mean to turn off “change game settings” in vorpx ?

    You said “I play with 3840×2880″… I suppose it depends on your monitor right ?, mine is up to 1920×1200

    You said “G3D (Shadow no S3D)”… Do you mean “Geometry” in 3d reconstruction options ? What is s3d? I cannot see it.

    And yes, I have tried oculus runtime. And virtual desktop’s vxd, and SteamVR.

    Thanks again

    #219734
    rogerty
    Participant

    Hello,

    I think I’ve got it !

    After applying your settings, the crashes were still happening, but after changing vorpx to SteamVR there is no error at all, apart from the minor issue about having to press ctrl+alt+del and esc after the initial load for the latest savegame.

    So, my settings are the ones mentioned from @Boblekobold except my own resolution, AND use this sequential steps:

    – IN VORPX, USE STEAMVR. Launch Vorpx

    -Connect the quest 2 to the pc with Virtual Desktop (the one in the oculus store, not the one from Steam) using VDXR.

    Launch the game: Vorpx will attach to it and will launch SteamVR.

    -After the load for your previous saved game, the screen will freeze: press ctrl alt del, and next, ESC. DONE!

    * Don’t forget to run alt-l to auto adjust visual settings.

    THANKS for all your help, I hope it will be useful to other people too…

    #219737
    rogerty
    Participant

    update 17/5/24:

    Finally it seems that it does not crash in Windows 10 with this configuration:

    -Without installing my AMD RTX specific software
    – Preliminary steps:
    – Start the game without vorpx and adjust all settings as you require
    – close the game and secure bioshock.ini and user.ini to prevempt changes: even if you set vorpx to not change the game settings, it CHANGES the user.ini every time the game crashes… To fix it I had to set both files to read only AND change permissions to disable inheritance AND allow ONLY my user to have permissions, and not SYSTEM or any other user.

    – In VORPX using steam vr
    – In the Oculus software start OculusLink wirelessly and connect but do not show the windows desktop.
    – My Virtual desktop streamer software in windows is shut down.
    – Start Steam and SteamVR: In the Quest 2 should appear the SteamVR environment.
    – From SteamVR show the Windows Desktop and start the game: once the last save is loaded press Alt+L as usual.

    … And for the time being, it is not crashing anymore… for the time being, I repeat. This is bloodily complex, but I think this is the way X-D.

    Before doing this, It still crashed from time to time, and also in some events like when you try to use the machine in the game called “https://www.youtube.com/watch?v=4Epue9X8bpc” ups not that one, sorry… just “power to the people”.

    I hope it helps…
    Regards !

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!