Call of Duty: Modern Warfare 3

Home Forums Game Hints and Settings Call of Duty: Modern Warfare 3

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #23194
    emilioNL
    Participant

    Hi!

    I have been putting together an Oculus Rift demo set with Call of Duty: Modern Warfare 3. Reason I chose this game is that the VorpX driver fully supports it and that it should have stereoscopic 3D. Also read a very enthusiastic forum post at VorpX about it.
    I set everything up, but it does not work as expected.

    Main problem:
    As soon as I start up the game, I can see VorpX kicking in, it shows a black screen with VorpX logo in the bottom center, version number in left corner and the standard warning message (telling about support and that I should shut off the shadowing feature in the game) is shown. Warning message disappears when I press enter or point the cursor on the OK button and click.
    After that, the only thing I see is the same black screen with the VorpX logo and version number. I can hear MW3’s intro starting up (theme song). Pressing Enter on the keyboard actually does something in the background (I progress through the menu, so it seems because the sound responds to it), but I cannot see the game. It almost seems like VorpX’ black screen is ‘blocking’ the game view.

    This is my setup:
    Windows 7 (fully up to date)
    Oculus Rift DK1 runtime (demo scene runs fine)
    Call of Duty: Modern Warfare 3 (this is a Steam game, bought and downloaded via Steam) – game itself works fine
    Xbox 360 controller (wired)
    VorpX driver – just downloaded / installed
    Followed exact VorpX instructions for Oculus display settings (cloned screen, etc)
    All overlay messages and notifications by Steam have been disabled
    Standard Tuscany demo works like a charm
    I have tried a lot of different display settings, but nothing seems to fix the issue.

    Can anyone help me out?

    Thanks in advance.

    Kind regards,
    Emile van den Ende

    #23669
    lipplog
    Participant

    Does the latest VorpX driver still support the DK1?

    #23804
    emilioNL
    Participant

    VorpX support, can you please get back to this?

    #23823
    Ralf
    Keymaster

    There seems to be an issue when using Z-Buffer 3D (although it doesn’t look like your description), but the game runs fine in Geometry 3D here using the Steam version of the game.

    We also didn’t receive any other reports about something like this as far as I’m aware of. At this point I can only assume that this is specific to your system or setup, so all I can give you are a few general hints unfortunately:

    1. Check whether the game runs in 1920×1080, other resolutions might not work correctly
    2. Reset the game profile in the vorpX config app
    3. Do a factory reset or reinstall vorpX (this resets everything)

    #26595
    emilioNL
    Participant

    Hi Ralf,

    Thanks for getting back.

    I have changed the games resolution to 1920×1080, and switched to the DK2, but unfortunately still no luck. However, I am seeing something else now:

    Game starts normally on my computer, I can see the game (with VorpX logo in bottom) starting and the view is split in 2 and responds to me moving around the DK2.

    The only thing not working now is getting the game to show up on my DK2. On the DK2, I only see my extended desktop…orientation of the desktop through the DK2 seems to be good (hard to see, but most probably not flipped or rotated).

    I have tried several display settings and VorpX settings (different combos as well), but so far, I have not been able to see the game in my DK2.
    I get closest to getting it to work when I follow the exact DK2 instructions in your readme file (other settings really screw things up).

    Can you give me a hint in the right direction towards correcting the display in the DK2?

    Thanks!
    Emile

    I have made some screenshots and pictures:
    Main display settings
    DK2 display settings (secondary display)
    VorpX general settings
    What I see on my desktop
    View in DK2 (extended empty desktop wallpaper)

    #26596
    emilioNL
    Participant
    #26599
    lipplog
    Participant

    You’re breaking several rules of the rift. Read this list, apply each change, and reboot for good measure. After that, everything should work.

    1. Never clone your displays. Always leave your display settings in extended mode.

    2. Always keep your Rift as Primary Display (a few exceptions like Virtual Desktop).

    3. In VorpX settings, never use an Oculus Profile. Make sure No Oculus Profile is selected.

    4. Always have Aero disabled. If not from your control panel, at least check Disable Aero at Start in your VorpX settings.

    5. Go to Control Panel – Display Settings – Screen Resolutions. Select your regular monitor and click Advanced Settings. Confirm that the refresh rate is 75. If 75 isn’t available, change the resolution until 75 is available. When it is, select it and save that resolution as your monitor’s permanent setting. And make sure your Rift’s refresh rate is also 75, just in case.

    6. Not a rule, but if you can, upgrading from Windows 7 to Windows 8.1 resolved a boat load of problems for me.

    #26671
    emilioNL
    Participant

    Hi Lipplog,

    Great, got it working now!!

    Only thing that looks weird, is that the Oculus only seems to display the middle of the game. In other words, I can hardly see the outside 20% (on left and right) of the game, making it hard to work through menus and such. It feels the same as sitting too close to the monitor…

    Does anyone know how to fix this?

    It’s quite easy to see what I mean when I set my desktop monitor as the main monitor temporarily:

    Thanks in advance!

    #27139
    lipplog
    Participant

    Sounds like you need to optimize your games. Open VorpX configuration Utility, click on optimize games, select each game you own and optimize it. The Field of View should now be better. You can also mess with the VorpX settings in your game by checking the box “Enable Expert Settings” in the VorpX configuration Utility.

    #27162
    OculusRiftRocks
    Participant

    may I ask what call of duty games run in geometry 3D? and does the FOV enhancement work on them?

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.