Config not starting – no window

Home Forums Technical Support Config not starting – no window

This topic contains 10 replies, has 3 voices, and was last updated by  Fred 3 days, 1 hour ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #177391

    Fred
    Member

    vorpConfig fails to open, process visible to attempt start but then closes within seconds in task manager.
    vorpControl starts and runs as expected (with the icon visible in the toolbar) two processes (“vorpX VR Driver Control” and “vorpX VR Driver Control (32 bit)” start.
    vorpDesktop starts a process under apps “vorpX VR Driver (32 bit)” but no windows opens on desktop (don’t know if it should?) Error message on Oculus runtime failure. The attaching message pops up and the closes.

    my system:
    re-Installed Vorpx today, registration and activation worked fine.
    windows 10 64-bit (updated today to October 2018 release, this includes .Net 4.7.03190)
    No AV or firewall except Windows Defender. Vorpx folder setup as excluded om antivirus scans
    gtx 1080
    HTC Vive

    Any help would be greatly appreciated.

    #177406

    zahncisten
    Member

    K, so, normally when you first start VorpX, a window does not show up, but a system tray icon does, like you’re describing. You can then right click the tray icon, and press “configure VorpX”. If you are doing that and it isn’t starting I would first close it and then try starting VorpX in administrator mode (just as a test) by right clicking and pressing “Run as Administrator”.
    Concerning Oculus, I’ve heard some some folks having problems and needing to use Oculus in SteamVR mode (via VorpX Config in General Settings, which you could get to if you can get it to run! 😆).
    It sounds like VorpX is actually running, so I’m going to guess that the first solution (right clicking the system tray icon, or trying to run vorpx as administrator as a test) may help, and the second suggestion (about SteamVR) may be a fix for your problem.

    #177410

    Fred
    Member

    Thanks for the response zahncisten! I did mean vorpConfig does not start, both as direct execution of the .exe file itself and right-clicking the VorpX icon in the tray. I have tried to both install and run VorpX as administrator as you suggested, but to no avail. I agree, VorpX seems to be running and it attaches itself to stuff when run. The problem is the config… Do you know what, if anything, needs to run in the background or if there are things that needs to be specifically setup regarding sound or display?

    #177415

    Ralf
    Keymaster

    Please check whether maybe your DotNet installation is corrupt. On Windows 10 no additional DotNet install should be required, but who knows. The config app requires DotNet 4.6.2.

    Also try to uninstall/reinstall vorpX if you haven’t done so already. Just to make sure the installation isn’t corrupt somehow.Keep the license information when the uninstaller asks about that.

    DotNet Repair tool
    https://www.microsoft.com/en-us/download/details.aspx?id=30135

    DotNet 4.6.2 installer:
    https://www.microsoft.com/en-us/download/details.aspx?id=53344

    #177419

    Fred
    Member

    Did run the the tool – no errors reported.
    I have uninstalled and re-installed vorpX several times.

    QDoes the app require “at least 4.6.2” or specifically? Perhaps there is an issue with a later DotNet version? My installed DotNet version is 4.7.2 (registry Relaease DWORD 461814).

    Is there any other apps/programs that need to run in the background or are there settings regarding sound or display one should be aware of?

    #177438

    zahncisten
    Member

    Have you tried the 4.6.2 installer? Some dotnet applications require specific versions.

    #177455

    Fred
    Member

    It’s not possible to install an earlier version.
    https://docs.microsoft.com/en-us/dotnet/framework/install/troubleshoot-blocked-installations-and-uninstallations

    “Because the 4.x versions of the .NET Framework are in-place updates, you cannot install an earlier version of the .NET Framework 4.x on a system that already has a later version installed. For example, on a system with Windows 10 Fall Creators Update, you cannot install the .NET Framework 4.6.2, since the .NET Framework 4.7.1 is preinstalled with the operating system.”

    #177457

    zahncisten
    Member

    You might want to try these steps:
    https://www.howtogeek.com/118869/how-to-easily-install-previous-versions-of-the-.net-framework-in-windows-8/
    The instructions work fine, just apply to 4.7.
    I understand the definitive words of Microsoft, but Steam installs old versions of dotnet all the time.

    #177461

    Fred
    Member

    older versions e.g. 3.5 can be, and is already in my case, installed. 4.6.2 can’t be installed when 4.7.2. is installed thouh….

    #177462

    zahncisten
    Member

    Alright, so, I did some more poking around for you, and found more people with similar issues, and installing the developer package worked for them. I just tried it and it installed without question and I could still run VorpX (I didn’t have a problem before, but I wanted to check and make sure I didn’t break anything by installing it, which I didn’t so: yay!)

    You can get it here: https://download.microsoft.com/download/E/F/D/EFD52638-B804-4865-BB57-47F4B9C80269/NDP462-DevPack-KB3151934-ENU.exe

    If you’d rather see the Microsoft site and download it by clicking the “download” button for yourself, you can go here: https://www.microsoft.com/en-us/download/confirmation.aspx?id=53321

    I hope that helps @fred!

    #177465

    Fred
    Member

    zahncisten: thx for the poking, but unfortunately, it didn’t work… which DotNet version do you have yourself? And where did you find the info regarding others having the same issue as me? I think MS is correct, it doesn’t install if you have a version higher… if if the installer you linked did run without error messages.

    The behavior seems to have changed a bit, after the SDK install script, when I now right-click on the vorpX Control icon and select “Configure vorpX” I get two consecutive error messages windows “vorpConfig.exe – The applicastion could not be started. Do you want to view infor…..” Clicking yes links to a site with this message: “This site can’t be reached dotnetsocial.cloudapp.net’s server IP address could not be found.”

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.