Games only displayed in 1 eye and upside down

Homepage Forums Technical Support Games only displayed in 1 eye and upside down

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
  • #102484

    First, I’d like to commend you on the awesome support that you provide essentially as a 1-man-army.

    I work Tech Support for the Delta Six GameGun and recommend that our users purchase and use your software to play their FPS in VR.

    Our games are running upside down and with only the left eye showing display when we try to play anything in VR. I’m thinking that it must be user error on my end, but I am unable to come up with any solutions on my own. I think “I’m just doing it wrong”.
    I have my oculus DK2 connected to the PC.

    I then open the VorpX software which in turn starts oculus home.

    I make sure that I am logged out of oculus home and I remain in the white-tiled-floor-disclaimer-screen

    -> At this point, do I look at the box for the 2 seconds to make the message go away, or should I start the game that I’m trying to play?

    Could you type up a step-by-step setup process?

    Part of my job is creating instructional videos to set things up. Our customers are frustrated and I am unable to find any solid information on how to get things running after the CV1 was released and vorpX updated. I’m unable to help anyone out when I can’t even get things to run myself. A whole lot of what I do to help people is a matter of figuring out what it is that they’re doing wrong so I can correct them. ..Well, now the tables have turned. I’ve hit a wall and I’m reaching out to YOU for help. I’m sure its just something I need to do differently or in a different order

    Thanks for your time :)


    The procedure you are using is more complicated than it has to be. While Oculus Home may be a bit annoying, you normally do not have to log out. Everything should work just as it did before with the exception that Oculus Home comes up after playing a game.

    In regard to the actual issue I can only guess that maybe the software you use for your controller also hooks into games which might cause a conflict with vorpX. Not sure what to recommend in this regard. If you only hook into Present methods it might suffice to delay your own hook a few seconds. If you do something more complex, such a conflict might not be resolvable.


    Thank you sir – the controller does not hook into the game, it is seen as either a mouse and keyboard or an Xinput device by the PC. – So that leads me to believe its how I’m trying to get everything opened and running.

    Everything used to work flawless, with the .8 runtime, and after the oculus updated and added their frontend, I’ve been unable to play. – again, because I’m sure “im just doing it wrong” haha.

    So if I’m understanding correctly, I should follow these steps to get my games to open properly:

    (make sure im not running software such as MSI afterburner, and that I am NOT using an SLI config. Also be sure that I am using a single monitor with my PC to avoid any other issues with hooking)

    Start VorpX

    Oculus Home will Open -> Sign into Oculus Home

    DV2 will display the white-tiled-floor environment asking to accept ToS (focus on button for 2 seconds) and will now be in the oculus “lounge” type environment.

    Opening my game should now allow VorpX to hook and my DK2 will go from displaying the lounge to playing the game.

    – Are the above steps correct?

    – I’m also willing to make a tutorial video for your customers to follow :)

    Thanks for your time


    That is all that has to be done. Please try without your controller software and any other background processes running and see whether that makes a difference.

    This seems to be a rather unique issue, I can’t remember a single report of something even remotely similar so far. Hence my guess that it may be linked to your software.


    There isn’t any extra software being run – I’m only trying to use my mouse and keyboard for now. :)

    And you’re correct, – I was trying to search the issue before bothering you for support, but I’m really stumped on this one. I’ll do some more tinkering tomorrow and see if I can make any progress.

    Thanks again


    Still unable to get Oculus DK2 to work correctly. Recording a quick video to show you whats going on in hopes to further troubleshoot.

    Again, everything worked up until the Oculus home update. I’ve been fighting with the headset off and on since then while I wait for my CV1 to arrive.

    – The desktop viewer app still works fine. – Which is what REALLY throws me off. Hope this helps understand what I’m doing wrong.
    Thanks for your time,


    Here is a video showing exactly what im doing and what’s going on with my headset. Hope it helps show what I’m doing wrong. I really can’t figure it out.


    Any suggestions?

    You can see that I AM doing everything EXACTLY how you say and it is still not working. IT was working before, now its doing what you see there and when it DOES decide to display the game, its inverted and only displayed in the left eye.

    I’ve completely uninstalled my antivirus (even though it caused no problems in the past)
    I am NOT using any other software that hooks into the game.
    I am NOT running a multi monitor setup
    I am NOT running an SLI profile.
    I have completely UNinstanned and REinstalled VorpX AND the Oculus runtime.

    Perhaps you could Teamviewer and help me get this running again?



    ALL games will run in virtual cinema mode and Desktop viewer works fine as well. Even DOOM runs. Not sure why it isn’t hooking properly.


    I hope this can help trouble shoot. IT works… but it’s not working in 3D for whatever reason.

    – I’d be editing my posts rather than posting new ones when I make progress, but there’s a timer preventing me from doing so. Sorry for 100 posts today. Under alot of pressure to get this running to demo for clients.


    i’m having the same problem….


    It really seems as if there has been MAJOR updates recently as multiple things are not working as they were before (The updater – The Config Files – DK1 Support has been removed all together – The Problem We’re Having with the display) and that anyone having any sort of issue is being given the same set of troubleshooting steps to solve their issue.

    I’ve made my videos public and have reached out to a few friends running forums, so hopefully an end-user will be able to point something out. I have both the CV1 and Vive ordered, and I’m just waiting for them to arrive.. Seems majority of users running the CV1 are doing just fine.


    @ DeltaChris: DK1 is not supported anymore by the latest Oculus runtime. Considering the “unsupported” note in Oculus Home I wouldn’t count on the DK2 being supported by it forever either. BTW: I can’t find you or your company in our commercial users database. Could you please contact support |at| vorpx com in this regard. Thanks.


    I am no longer seeking your support. Its been 4 days since a reply and I only received one because you were notified that other people will be seeing that software is not working as advertised. If you take to time to read or watch ANYTHING I have posted, you will know that I am using a DK2 and that I AM indeed following all of the steps provided to get the hardware to work with the software. I purchased this software for my own personal use and have been recommending it to clients as a solution to their own personal needs.
    You supply the same copy/paste replies and then stop responding if anyone continues to have a problem.


    Sorry for not being able to offer immediate responses over weekends.

    As you probably know from your own work, issues that cannot be replicated have to be investigated before any useful answers can be given. That’s where the recommended sending of trouble shoot data comes into play, which I would also recommend in your case. Maybe that helps to identify your issue or at least can give a hint in the right direction.

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!