Geometry 3D is not performing well on HP Reverb1

Homepage Forums Technical Support Geometry 3D is not performing well on HP Reverb1

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #201163

    Hi everyone,

    I’m racking my brain trying to get G3D performance from my Reverb1.

    For instance, I’m using Divinity Original Sin II profile with Divinity Original Sin I Enhanced Edition and it has perfect 3D effect with cinema screen. But when G3D is turned on, I get a DRAMATIC performance increase in the headset vs regular desktop mode (not generic headset).

    Desktop : 598 fps
    Reverb1 Z3D : 275 fps
    Reverb1 G3D : 40 – 45 fps fluctuating

    Should there be such a massive difference ?

    Regular VR games are fine

    I9 9900K – OCed to 5GHz all cores (watercooled) temp never goes above 65C
    RTX 3080
    32 GB ram

    I don’t think it’s CPU issue as the videocard is pegged at 99% when this happens


    The difference between desktop and Reverb/Z3D looks like vorpX’s hard FPS cap. It never goes above 300fps. Since vorpX circumvents VSync whenever possible this 300fps cap exists to avoid unnecessarily high CPU/GPU usage during menu screens etc.

    G3D should normally be about half the Z3D framerate, in worst case scenarios maybe a third, so that looks really odd. Not really sure what is going there. Try a few other games and check whether you get a similarly odd result when switching beween G3D and Z3D, probably just this particular game (or engine) that *really* dislikes something vorpX does.

    BTW: Are you sure you see 275fps with Z3D while using a headset? That shouldn’t really be possible actually, the game frame rate should never be higher than the headset refresh rate (half with FluidSync enabled). If you see a game frame rate higher than your headset refresh rate, that would be a fairly severe bug. If you used an external FPS counter, try the built in counter to double check (ALT-F). Maybe it’s just your FPS counter displaying garbage for some reason.


    Thanks for the quick reply Ralf

    The fps was taken with generic vr headset (desktop mode) and with a riva tuner.

    This was for test purposes.

    What I noticed was there is a tremendous difference in framerate between Z3D and G3D.

    Z3D seems to be closer to the performance of the desktop but G3D is literally performing 6 times worse. I know G3D renders double the geometry but almost 300 fps (Z3D) vs 40-45 fps (G3D) seems a little too extreme.

    Other games I’ve tested were with non-official profiles but I’ll try testing more with official games and see what I get.



    Can‘t really say much more to that than what I said above already. Apart from that try to disable FluidSync in the vorpX menu, 45 somehow sounds like FluidSync (caps at half the headset refresh rate). It’s on (or auto) for WMR headsets on purpose though. WMR headsets judder with uneven frame rate ratios, they either need fully stable 90/90 or 45/90. Something like 80/90 or so doesn’t work well on WMR.

    BTW: Don’t run any GPU tools alongside vorpX. Tools like that hook the same DirectX functions that vorpX hooks. May work, but also may cause all sorts of problems. That’s pretty much actively asking for trouble. If you want to measure performance, use vorpX’s built in FPS counter, which is way more useful anyway since it shows both the game and headset thread frame rate.


    The performance drop in G3D mode significantly depends on the game, or better said on the game engine used.

    In example Farming Simulator 2019 (Giants engine), G3D is a total performance killer. I can run it with Z3D on my rig maxed out graphics settings and 1680p resoultion stable with 60fps. In G3D lowest possible settings and 768p resolution it looks like a mess and barely exceeds 10fps.

    On some other games which run on unreal engine performance drops only about 30% in G3D without the need to reduce graphics or resolution absolutely ok.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!