Ghost Recon Wildlands + First Person mod

Homepage Forums Game Hints and Settings Ghost Recon Wildlands + First Person mod

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
  • #209317

    New First Person Mod for GRW just released this month on nexus, and combined with vorpX G3D fullVR, it is now much more the immersive experience I have been hoping for! (thank you intifofo). See video for gameplay and simple install guide:

    I have made some significant improvements to the old GRW profile (terrain textures and shadows are now correct in stereo, woohoo!!) and I’ve tuned it for best use with this first person mod. New profile now on the cloud for any to try:

    Ghost Recon Wildlands + FPS mod (G3D) [dellrifter22]

    G3D is very performance heavy in GRW, so expect modest settings and resolution with occasional frame dips. These are my recommended settings based on a 2080ti:

    Game FOV is affected by aspect ratio, so for best results, create a custom resolution from the following and apply it in game.

    1333 x 1200 – performance (~40 fps)
    1600 x 1440 – balanced (~35 fps)
    1920 x 1728 – quality (~25 fps)
    2400 x 2160 – ultra (Z3D only)
    3200 x 2880

    The Game also has internal render scaling in Video Settings that you can adjust up/down to find your own target performance.

    Game Settings:
    – Max Extended FOV to 100% in Video Settings and turn off VSync
    – AA = Temporal AA (adds blur to moving objects, but is the most stable image)
    – Texture Quality and Terrain Quality = High/Ultra
    – Shadow Quality = Medium, Long Range Shadows = On
    – AO = HBAO+, Godrays = On (both optional)
    – Draw Distance/Level of Detail/Vegetation = Low and everything else is OFF
    – Helicopter Controls = Classic in Gameplay settings (enables head rotation)
    – Increase vorpX Sharpen to max 2.00 in Delete Key menu

    *HUD visibility is very customizable in Options and can be toggled on/off with hotkey
    *AI teammates can be turned off in game settings if you want to run solo
    *Performance Z3D is also available if you want more frames/eye candy
    *tested on HP Reverb G1 with mouse/keyboard

    A few effects that remain unfixed for stereo (distant water reflections, stars, clouds, and rain) have for now been assigned to the vorpX Shadow Treatment menu so that you can toggle them on/off to your preference (Delete key menu, Image Settings page).

    One last suggestion to improve stealth gameplay: install the Remove Detection and Hit Sounds mod from nexus and turn the game HUD off. Now your awareness and infiltration skills will be tested.


    Ghost Recon Wildlands + FPS mod (G3D) cloud profile updated 2/5/2022

    -clouds, stars, water reflections, and light sources are now correct in stereo (nice!)
    -increased 3D strength for more accurate depth and scale
    -decreased image zoom a bit for improved image clarity and FOV (better with vehicles)
    -TAA motion blur effect now assigned to vorpX Shadow Treatment for toggle options:

    Auto = motion blur on static objects/furniture, but clear guns and moving vehicles/NPCs
    Turn Off = motion blur on guns and moving vehicles/NPCs, but clear static objects

    Or if the slight TAA blur bothers you altogether, you can try the other AA methods in Game Options to see which you prefer.

    I have been quite pleased with how the authoring tool (and a bit of patience) has been able to bring this profile together with near flawless G3D. It is very rare that a dx11 game has correct stereo shadows and lighting effects. Now all that remains to fix are decals for wall art and bullet holes (if those are even possible, I’ve always struggled with decals..Ralf?)

    Anyway, worth trying out with the mod if you own Wildlands. I prefer the stealthy approach, but as you can see here, it can now play like a Far Cry game if you want:

    p.s. oh, I get a crash sometimes when trying to access my loadout menu directly, but I’ve found if I indirectly access it by opening the skills menu first (press J), I can navigate to loadout from there okay.


    Oh, you’re the author of this cloud profile! Thank you so much! I’ve been trying desesperatly to get it to work but unfortunately my game crashes as soon as I launch the mission. The FPS mod works well without Vorpx however.

    One thing not clear to me: on other Vorpx profiles, it says you need to bypass EAC. I didn’t with and without but none work.

    Any idea?


    The FPS mod already includes the same bypass dlls needed for vorpX to work. So theoretically you should have things already correctly installed if the mod is working. Might not hurt to double check if you did the same as the video above.

    I get a crash sometimes when I try to open the loadout menu, or character customization screens from the main menu. Try to skip any of that before you load into the world.

    One thing you could try is temporarily switch the vorpX 3D render mode to Z-normal(delete key menu) when you first launch the game or use the customization menus, then switch back to Geometry 3D when you are in the world. This could reduce some system stress to hopefully avoid a crash. One downside though is that sometimes switching from Z3D and back to G3D will result into some G3D shader glitches that may require a reload or game restart to reset.

    As a last resort, you can try loading into the game without vorpX, make all desired loadout changes, and advance to a new mission. Then hopefully the next time you load with vorpX things won’t crash.

    Remember to keep settings and resolution low. The game is pretty heavy as keeps my 2080ti at 99%. 1600×1440 works best for me to keep rates at a playable 30+. You can however set frame limits in game to 30, which can help reduce the gpu load a bit and possibly reduce the potential to crash.

    Those are the best ideas I can offer right now. Good luck, I hope you can get it working. It is definitely my favorite way to play GRW.


    Great…!! Thank you for the tip and the guide…!! Dellrifter22 I’ll try it out tonight…I also have a 2080Ti with outdated i7 6700K, 32 GB Ram


    Did everything suggested above and crashes for me to the steam home evertime I try to start a campaign. Works great without Vorpx.


    Was able to start it up and hook using your Rift file. That one is in Z3D so I think the G3D is what is crashing it for me. I also used your first person mod profile as well and was able to start it when I changed it to Z3D in the vorpx menu and continue the campaign which let me in. Then I changed to G3D once I started. Has not crashed yet. Just FYI


    Good. Yeah, for some reason whenever the Character creation or loadout/customization menu tries to load in G3D, a crash is likely.

    Switching to Z3D before opening any of these menus seems to be the safest. vorpX has a hotkey that switches between G3D/Z3D that you can assign in the desktop config app – In-Game Key Bindings page.

    Glad to hear you got it working!


    The head track in the car is not correct and when you turn it stuck any way to fix it?


    Be sure to set Helicopter Controls to Classic mode in the game settings. That will unlock camera rotation in some vehicles.



    But is impossible to drive in car when headtrack is enable , or its just for me?
    Maybe do you have any mode or in game function that disable it?


    For cars, the camera rotation is not connected to the orientation of the car, so you will need to compensate by rotating the view with your mouse/gamepad when you make turns to change direction.

    Yes it is not completely natural, but those are the current restrictions of the mod. The modder claims he may be able to add a toggle for 1st to 3rd person view in an update coming soon.


    Hop will be a fix for camera rotation in car.
    It is very hard to drive this way


    just got the Tom Clancy’s Ghost Recon: Wildlands – Ultimate Edition so wil be giving this a go later this week )


    Thanks for your efforts on this, I hadn’t even seen the FPS mod even though I have been waiting for one since launch.
    For me with the above settings and resolutions the world is warping, not sure if I am missing something, I’m using a G2

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!