Morrowind (SteamVR with GOG version): won’t load in HMD

Homepage Forums Technical Support Morrowind (SteamVR with GOG version): won’t load in HMD

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #194987

    Hi all,

    I would be very grateful for assistance with this one as this is the one game I wanted to get working in VR with vorpx: Elder Scrolls 3: Morrowing.

    Right off the bat, I use an Index with SteamVR but the version I own is through GoG, downloaded through Gog Galaxy. I installed MG EXE for it which I believe is the version that it supports and the version that the cloud has profiles for.

    I run it and Steam VR and vorpx recognise it, it loads but then it only runs through my computer screen with the view in the HMD remaining black, with only the audio running. Any ideas what the issue is?


    MGE XE is what you need, but there are so many iterations of the app, that I wouldn’t rule out that some work and others don’t. The version I have installed here is MGE XE 0.9.10. That should work fine (just checked briefly).

    If vorpX can’t hook a game, it’s always worth a shot to try the ‘Alternative Hooking’ checkbox in the config app. Caveat: Don’t forgot to switch back even if that helps for particular game. Some games do not work with it.

    For games from GOG that don’t require a DRM client like Steam/Origin/Uplay etc. you can also create a vorpX desktop shortcut from the vorpX tray icon’s right click menu. Doesn’t help with Steam etc., but for games that don’t lauch through some client a vorpX shortcut ensures that hooks first before any potentially interfering overlay/other program.

    Also try to launch the game directly instead of using the Galaxy client. That way the GOG overlay can’t get in the way.

    Apart from that please check the trouble shooting guide in the help (or on top of this sub-forum) for general information regarding hooking problems.


    Thank you for your assistance.

    Unfortunately, I followed the steps and now have another headache…
    Vorpx is hooking in but the screen in my headset is empty black, displaying nothing.

    The output window on my laptop is clearly showing the cursor being controlled by the headtracking of my headset and the vorpx logo is showing. Steam VR shows that it’s about to run it before it starts.

    I reinstalled Morrowind to be sure, installed that version of MG XE instead but still not change. I also put a vorpx shortcut on my desktop.

    I tested Jedi Knight 2 just now and it is hooking it in fine with it so it seems to be a problem so far only with Morrowind in terms of not directing the video output to the headset.

    Just a question: vorpx desktop viewer: I tried to run it, it ran through steamvr then and then the same sort of thing. Is it a program that runs through the headset? If so, it’s blank on my end as well.



    Have an RTX 2070 and Geforce Experience. I decided to do my homework and look for previous posts on the subject.

    Elsewhere you wrote about possible interruptions:

    “-CPU/GPU utilities, e.g. fpsVR, MSI Afterburner, ASUS GPU Tweak, GeForce Experience”

    Another user reported something similar for his card which was on an Asus strix gaming laptop:

    I do not see anything when vorpx is open

    I changed the Geforce settings to run through the GPU and Morrowind booted up finally…..
    It worked.

    AND WOW. To finally be in Morrowind was amazing. More effort is needed to make playing it comfortable (still too zoomed in) but this can come with time. Absolutely amazing. Thank you.


    Just to also add for future reference for others:

    Newest version of MG EXE works fine.
    Vanilla Morrowind will not boot without it presumably because vorpx cannot detect it in its earliest form.


    vorpX should adjust the FOV (‘zoomed in’) automatically by adjusting MGE XE’s FOV setting under normal circumstances. Provided that didn’t fail for some reason, the FOV is calculated to match the FOV of your headset.

    vorpX expects the MGE .ini in [Morrowind folder]\mge3\. If that isn’t the case anymore with newer versions, let me know.


    No, I can confirm that the newest version, which is an install works fine. The issue I was facing was not related.

    I am reading and have been reading as much as I can from the documentation. However I am still trying to get my head around it all. This is the first week that I\ve had VR and I realize that vorpx is a bit tougher to get, particularly if one is playing with the settings.

    The default profile for Morrowind still is excessively zoomed for my eyes.

    Yes, I noticed that the profile pulls the FOV in the MG EXE settings to 111 horizontal in line with the settings.

    But with these settings, it still feels as though its too zoomed in and that anything close is unnaturally large. Something just doesnt fit.


    To put more simply, even on the default settings I need to zoom out to 53 or so get a perspective that feels more natural, but of course then the boxes are much larger.

    Theres no rush for this, but this is the game that I most want to have working with vorpx. But it seems that Im running into this issue of excessive zoom for all of my other games as well so far.


    The FOV is computed automatically to fit precisely the FOV of your headset. Provided the setting still does what it is supposed to do, the FOV is correct once vorpX has adjusted it. Please reset the profile to default in the config app if you made any changes to related settings.

    Just in case also make sure the game runs with a 4:3 resolution. Normally vorpX considers such things when it computes the FOv for games, but I’m not 100% certain at the moment whether the FOV would be right at other aspect ratios for Morrowind.


    Thanks a lot again for your help.

    I brought the settings back to default and although not perfect, it is more or less playable. Mapping the edgepeek to right grip was a really great idea and makes it a lot more playable. Nevertheless, in first person it still feels slightly zoomed in so that things up close seem bigger than they should be. My settings: 1400 x 1050 (4:3 aspect ratio); 101 horizontal FOV, 0.75 ui scaling.

    I think currently this may be as good as it gets for 20 year old game not made for VR and kept on stilts with MG EXE to run. And it still runs pretty well once you get used to it.

    Despite what others on the forum have written, I installed distant lands through the settings and it runs fine for me. This may be a since solved issue.

    So all in all, Morrowind does run I am happy to see. This was one of the games I got vorpx for, if not THE game I got it for and it works.
    Ideally I wanted it to work with Tamriel Rebuilt especially as it develops and that will be what I try out next but I don’t see why it wouldn’t work now.


    Do you get also 3D effect with distant lands?

    I mean with Morrowind and distant lands, vorpX hooks and wraps the image to my headset and it looks great but there is just no 3D effect.

    Without the distant lands, it still looks great and all AND there is 3D effect too.

    I think the whole discussion about distant land was about 3D.

    Anyhow, great to hear you made it run!


    I think the whole discussion about distant land was about 3D.

    Erm I don’t understand what is meant by a 3d effect on the distant lands.
    It looked fine on my end and I didn’t notice a difference from what I am used to seeing on the flatscreen. Or at least not yet.


    By the lack of 3D effect I mean that both eyes get the same picture – hence no stereoscopic effect.

    If the game appears in your HMD and all is looking fine, then do not worry :-)


    Never noticed anything wrong with the distant land feature either. The distant land is probably just, well, too distant to have any noticable stereo effect. The farther away something is the smaller the difference in perspective between both eyes gets, resulting in less stereo.

    The decreasing difference in perspective over distance is actually what mainly lets your brain derive depth from two images in the first place, be it in VR or in the real world. Since your eyes are only 6-7cm apart after a few dozen meters the difference in perspective between what you see in both eyes becomes so small that it isn’t really noticable anymore.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!