[Pimax] New user headtracking issues and more

Homepage Forums Technical Support [Pimax] New user headtracking issues and more

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
  • #172797

    Last week I sent a number of emails to the support address with attached vorpx logs and have not gotten any reply.

    I recently bought Vorpx and have spent the past week trying out a number of games. All of them are supported games (Jedi Knight 2, Kotor, Thief 2, Half-Life 2, The stanley parable). None of these games work.

    I have a reasonably clean rig with a 1080ti & pimax 4k running windows
    10. The headset works fine with steamvr games & unity. I can run the games perfectly fine without vorpx.
    Vorpx does hook into the games, but what it shows on the headset seems
    to be a high speed rotating texture that shows the game in probably
    16 colors. The Vorpx desktop viewer has the same problem.

    Half-Life 2 is an exception, it does not display on the headset at all.

    The Pimax is set to “Pimax mode” and Vorpx device selection is set to “Steamvr”. I also have the profile for the respective game loaded before I start it.
    Piplay & steamvr are running in the background before I start vorpx.
    I also upgraded to the latest version of Piplay and NVidia drivers which did not change anything. I tried reinstalling vorpx with no result. Both the headset and the monitor are plugged into the 1080 Ti. There are no additional monitors.

    When I turn off “Enable head tracking” it no longer spins but that also removes an important part of the Vorpx functionality.

    How do I get these supported games to work?


    I’ve been using the Pimax4k with vorpX on my 1080 for the past 6 months, never had the color issue you describe. I do suffer from slight drift side to side which i have to correct with the recenter hotkey every minute or so.

    Off the top of my head I’m not sure whats causing your problem. Are you using some kind of displayport/hdmi adapter? Have the usb plugged in as well (tried other hdmi/usb ports)? Have some specific Nvidia control panel global settings that force performance or color modes?

    Not running any system monitoring overlays like afterburner or EVGA percision, or video capture/streaming softwares?

    I haven’t heard of this issue before.


    To me that sounds like a positional headtracking issue. I heard of pimax not providing this properly. Try disabling positional headtracking instead of headtracking in main. You find this setting on the ingame headtracking page of VorpX.


    RJK_ that sounds promising. But due to the rotation problem I cannot access the ingame vorpx menu. I can disable head tracking from the vorpx configuration, before I start the game. Head tracking will be disabled but I can run the game and I can access the in-game vorpx menu. But when I look at the headtracking page, it just says headtracking on/off. There’s no option for positional headtracking. I have version 18.1.5 of vorpx installed, perhaps the option was removed?

    If I turn the headtracking on in the in-game menu everything starts spinning again as expected.

    Also on the in-game DirectVR page it says “Head Tracking Rotation: Unavailable” & “Head Tracking Position: Unavailable”

    Disabling head tracking roll from the vorpx configuration does not change anything.

    Ralf, I’m not sure what you meant, I read that post before I bought Vorpx, I tested piplay 1.1.92, 1.2.91, and I start piplay, then steamvr, then vorpx, load the profile, then start the game. I reinstalled piplay, steamvr, nvidia & vorpx multiple times, but vorpx never worked with headtracking.

    Dellrifter22, I’m not sure what’s causing the color issue, it’s not exactly 16 color, but it doesn’t bother me as much as the failing headtracking. The game displays fine on the main monitor though. I have only 1 monitor, connected to the zotac 1080 ti through displayport, the pimax is connected through hdmi and usb 3.0. I have tried using different usb ports (3.1, 2.0) but no change. I use no adapters. Onboard graphics are disabled in uefi. Nvidia settings are set to default. There is an asrock motherboard monitoring program but enabling or disabling it seems to have no influence. No video capturing/streaming. My monitor does have a lower resolution than my pimax in case that influences anything.


    Headtracking not beeing availiable/accessable ingame points strongly to an issue where your software doesnt provide the headtracking properly. With HTC Vive for example you only need to install steamvr, nothing else. The “driver” from HTC installes all kinds of crap on the pc. I am glad i found that out early enough. I would guess your glasses could work the same way. If anything else fails remove or disable the pimax software, make a fresh steamvr install and see what happens.I dont own the pimax so thats all i could guess.


    As per your suggestion I disabled vorpx and uninstalled piplay and steamvr, then reinstalled steamvr. The headset does not work without piplay so I reinstalled piplay afterwards. And then reenabled vorpx.
    Vorpx now needed admin rights in order to hook into jedi knight 2. The headtracking error still occurs.

    Also, when I run the stanley parable the in-game vorpx menu says Head Tracking Rotation: Success & Head Tracking Position: Success. But the same spinning problem occurs when I switch headtracking on. I still do no see an option to disable positional head tracking from the in-game menu.

    Headtracking works fine outside of vorpx. I can run plenty of steamvr games without any problems. It also works fine in Unity. So it seems to be a vorpx issue.

    I reinstalled vorpx again after this, the only thing that changed is that it no longer needs administrator rights to hook into jedi knight 2. So the headtracking issue still remains.

    Two footnotes:
    – When I close vorpx through right click on the icon, it warns the vorpx driver will be stopped. And one of the processes does, but in the task manager there’s still a vorpX VR Driver entry with vorpX Service running unter it.
    – After the vorpx setup is done it asks to start vorpx config, but that doesn’t start because it isn’t registered yet. The user needs to start vorpx normally in order to register vorpx. Only after that will vorpx config work.


    The service still running is perfectly normal, apart from that your overall configuration seems to be broken severely.

    One other thing you could try is to disconnect all USB devices (except the headset, of course) from your PC in case vorpX interprets one of them as tracking device or gamepad for some reason.

    If the Piplay application has a way to reset/calibrate/center tracking, pease also do that.

    Not sure what else to recommend, sorry. Your headset is on the market quite a while now and used by quite a few vorpX users, noone ever reported anything similar.


    I’ve read that some versions of Piplay have some sort of magnetic calibration setting for the gyros, but I still only use the old 1.1.92 and have never run said calibrations. You say other vr apps work fine though, so maybe it is some conflict with a gamepad or other connected USB device as Ralf mentions.

    Another way to test without positional tracking and directvr in games would be to checkbox “Never change any game settings” in the vorpX Congig.

    Side notes from my pimax experience…

    I still use 1.1.92 as it gives a satisfactory image quality without any super-sampling or performance hit. I haven’t personally needed any IPD adjustment (offered in later versions), and therefore have not felt the need to test more recent Piplays. There are a couple minor inconveniences to consider though:

    When I first installed 1.1.92 I got the “Pimax disconnected” loop, but was able to solve that somehow by right clicking piplay in the system tray and setting it to Pimax mode and/or uninstalling/reinstalling it’s drivers in device manager. Now I no longer get this problem.

    By default the display is very dark. There are two settings I must adjust in piplay everytime I plug the pimax:

    -First turn on “Cool colors”.
    -Then enter the max brightness code 10033036 into the debug tool.

    (I could skip these steps and jump directly into steamvr without piplay, but to get desired colors I must do this every session) Also note, piplay will prompt you to reconnect the USB after each step, but I’ve found that unnecessary.

    After each session I unplug the pimax USB to power off it’s display. Otherwise, when my PC is off, the screen stays on – full grey.

    Audio usually gets passed through with vorpX as intended, but if it ever fails, simply set Pimax as the default sound device in windows Playback Devices.

    Due to having only gyro sensors, Pimax4k struggles with drift. Not so severe as you describe, but a very slow panning to one side or the other. to combat this I have dedicated my Q key as recenter hotkey for vorpX. I now subconsciously spam Q every half minute or so as needed. This only applies when playing in immersive/cinema modes, as playing fullvr will center lock the display. For most games however I choose to play immersive cinema to relieve FOV constraints.

    If you want to increase the visual quality/clarity of games in vorpX, learn to use higher custom resolutions rather than antialiasing or supersampling via steamvr. vorpX can handle virtually any resolution you throw at it. In some games I go as high as 4224 x 2640 and still see subtle improvement in the pimax. Sure it’s still downsampling to 1440p input to then be upscaled to 4k by the pimax, but I still see improvement.

    I have created 20+ custom resolutions with Nvidia Control in incremental steps from 1080p to beyond 4k of various aspect ratios. Now I can use which ever works best performance-wise on a game by game basis.

    Also try changing the vorpX ingame setting “Crystal Image” to Aggressive and see how it looks. Sometimes Aggressive looks good, sometimes Normal is better. I also prefer to slide the Sharpness setting all the way up. This will drastically increase clarity from default. Increase the brightness and color saturation as well to improve the duller display of the pimax.

    Anyway, I’m starting to get carried away here. Just wanted to assure you that you can get a decent experience out of vorpX with a pimax4k, even if it can be a bit tricky. Hope you can get the tracking issue sorted. Perhaps the Pimax forums can further help.


    Ralf, how does my overall configuration seem to be broken severely? Everything works and has been working fine, except for vorpx.

    I don’t think the issue is related to USB interference. I did use to have a xbox360 gamepad hooked up, but I removed it sometime last week.
    I used the windows device manager and the steamvr tool usbdeview to disable/remove most usb ports/devices, I also updated the uefi/bios and used it to disable most usb ports. But the issue persists. The only usb ports I do use are 1 for the headset and 1 for the keyboard, sometimes I use 1 extra for the mouse. There are no other USB devices.
    But also, when I disable the headsets gyroscope the spinning is gone. Of course, headtracking also does not work, so the problem remains. But that makes it pretty clear that it’s the gyro signal that is not being processed properly.

    In the pimax software I have done all the calibrations (horizontal, magnetic, ipd, recentering), afterwards I re-ran the steamvr room setup.

    The fact that the headset (and its gyro) works fine with everything else points to vorpx being the culprit.

    One thing I noticed was when I do a Full Factory Reset in the Vorpx Config it says: “1 error(s) detected during factory reset. The reset may have failed or be incomplete.”
    There’s nothing in the troubleshoot log about it, any idea what the error could be?
    Reinstall does not fix this.

    Dellrifter22, I was using an old version of piplay as well as everything was working fine. But since the issue with Vorpx I have been trying out a lot of different versions of piplay hoping it would fix things.
    I barely noticed any drift issues and have been using the pimax a lot with unity and subnautica among others. The spinning seems to be something else, it’s very high speed, like you’re in a washing machine. That’s why I can’t read the vorpx in-game menu with headtracking enabled.

    Concerning resolutions, I usually have all nvidia settings set to default. My normal monitor runs at 1920 x 1080 and I have not set any custom resolutions in vorpx for the headset. The pimax does not show up in the nvidia control panel unless I set the pimax to extended/video mode. Is that different with you?

    (You can turn the pimax off by holding the power button for 10 seconds by the way)


    Even if you don’t believe that USB devices are the cause of the issue, please still double check it. A flight stick for example would be capable of creating such an issue or a badly calibrated gamepad that doesn’t re-center correctly.

    vorpX doesn’t read the gyro signal of your Pimax directly. It uses the SteamVR functions for reading the headset pose just like any other SteamVR app, which is why vorpX can work with any Steam VR headset. In fact there is not a single Pimax specific line of code in vorpX.

    The factory reset message most likely just means that some file wasn’t there. If you did a reinstall, you can be sure that everything has been reset.

    Do not use extended mode, vorpX only works in direct mode! Custom resolutions have to be added to your main monitor.


    I double checked the USB connections, I’ve been spending a lot of time trying to make this work in case that wasn’t clear.
    I do not use extended mode or custom resolutions.

    Ok sure that seems efficient, but then I don’t understand why all other SteamVR apps are working fine. Is there perhaps an exception for 3dof – 6dof headsets?

    The pimax only has the 3dof: pitch, yaw and roll. Is there perhaps a way I can turn these on and off seperately in VorpX? I saw “Enable head tracking roll” in the vorpx config general settings but can’t find the others.

    Positional tracking in vorpx seems to be on by default, perhaps that could cause issues? I was able to disable positional tracking from the vorpx in-game menu by disabling the gyro through piplay.

    Is there a vorpx config file I can edit manually?
    Are there more/other settings available in older versions of vorpx? I have 18.1.5.


    You can disable roll in the config app.

    One other thing you could check is trying to switch the gamepad emulation mode in the vorpX ingame menu. vorpX in some games per default emulates a mouse with a gamepad, which potentially could also cause a spinning the camera.

    Other than that I’m really out of ideas now.


    Yes, try to disable Positional tracking if you haven’t already (thought you had). In vorpX config checkbox “never change any game settings” and apply. Then in the ingame menu positional tracking should be off, but turn it off there if it isn’t.

    Any gamepad emulation drivers/processes like Xpadder running? Racing wheel drivers?
    what about Windows Sticky Keys? I’ve read having that enabled can cause control problems in normal games.
    Sorry, taking shots in the dark. You are testing several games, not just one, right?
    Correct, the Pimax should not show up as a display. All custom resolutions are made for your primary monitor (games render to the monitor and vorpX borrows that signal). Mine for example is native 1920 x 1200, but through method similar to DSR it can attempt to display much higher resolutions. They won’t look perfect on your monitor, but will look better in the headset.

    Each resolution you create is tested to see how your monitor can handle it. try 3840 x 2160 on you monitor, see if it passes etc. If its flashing or all black it didn’t pass.

    while gaming, you don’t set your desktop to these custom resolutions (keep native), you select the custom resolution inside each game’s video settings.

    These are things to try after the headtracking gets sorted of course :). good luck.


    Thanks for confirming my assumptions.

    I figured out I had to disable the pimax gyro to disable positional tracking from the vorpx in-game menu a couple of days ago. There seems to be no other way through the regular config or settings files.
    So usually the workflow is: I reinstall vorpx, disable the gyro through piplay, disable the positional tracking through vorpx ingame, quit the game, re-enable the gyroscope, and restart the game.
    I had really expected this to be the problem, but the spinning problem remained.

    There are no fancy gamepad/joystick/etc. programs running. It’s a reasonably clean rig. No sticky keys either. I just got a new logitech m90 mouse today, very simple, similair to the previous trust mouse, but it made no difference.

    I’m testing Jedi Knight 2, Kotor, The Stanley Parable and Thief 2. Halflife 2 I test only sporadically as I had other issues with it.

    What did you mean by “They won’t look perfect on your monitor, but will look better in the headset.” Any color artefacts by chance? Because the games tend to look fine on the monitor but have issues with color on the headset. There are some weird things going on the main monitor like the jedi knight 2 logo on the title screen spinning like crazy when head tracking is enabled, but that’s nothing compared to the entire world spinning in the headset. The title screen from Kotor is similar, darth malak looks like he had way too much coffee on the monitor.


    Is it correct that normally in a supported fps game, you can move the camera with the headtracking from the headset but also with the mouse/gamepad/keyboard?
    Is there any way to disable everything but the headtracking as camera control?

    I fiddled around with the gamepad emulation mode, didn’t help, but also didn’t stop the camera from being controllable with the mouse. This was all with the gyro off, change setting, quit game, gyro on, restart game process.

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!