Planet Explorers

Homepage Forums Game Hints and Settings Planet Explorers

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #110524

    I’m on a crusade to get Planet Explorers to work with VorpX :)

    The game uses Unity 5, so I’ve started out by copying the Firewatch profile.

    The problem is that it seems to do some odd shenanigans on launch.

    On a regular launch: First Steam launches the games executable (PE_client.exe) and VorpX hooks it just fine. Problem is, that all the client does is load the Planet Explorers launcher (PE_launcher.exe) which is then displayed in the headset. The launcher is loaded at a resolution of 965×400. If you then click “start game” in the launcher it actually goes back and relaunches PE_client.exe with some additional parameters from the launcher (“D:\Program Files (x86)\Steam\steamapps\common\Planet Explorers/PE_Client.exe” -from-launcher -rw 1920 -rh 1080 -ql 5 -ocl OpenCL|NVIDIA_CUDA_____|GeForce_GTX_1080 -language english). At this point Vorpx gives up and things go back to the normal monitor.

    If I run the actual command line handed by the launcher to the game directly, I can circumvent the launcher, but in that case VorpX doesn’t hook the game and it only appears on the monitor.

    Anyone tried to get this to work with success already, or any suggestions how to get VorpX to hook here?


    A small update: tried making a profile based on an OpenGL game (used the No Man’s Sky experimental one), and set planet Explorers to use the OpenGL renderer. No luck :-/


    Got it to work!

    Unfortunately it is one of those “close thing” experiences. Too many visual artifacts for the game to be a good experience (grass and flowers rotate to always face you when you turn your head, glare from sunlight only affecting one eye, etc.)

    It did give me Geo3D support though, and there is certainly much that is promising.

    For anyone who wants to try themselves, these are the steps I followed:

    • Create a profile for the game based on an existing OpenGL profile (I used the “No Man’s Sky” one from here:
    • Point the profile at the game executable (D:\Program Files (x86)\Steam\steamapps\common\Planet Explorers\PE_Client.exe on my machine)
    • Don’t start the game with VorpX just yet. Start it normally once. Make sure to set the renderer to OpenGL in options (and also get the camera FOV set to max).
    • Tricky bit: after the game is done starting up you need to figure out what command line was actually used to start it. Tab out and look in the Windows Task Manager for it (you may need to enable the “command line” column)
    • Enable VorpX, <windows key>+r to get a run box and paste the command line. You can tweak your resolution to what you’d like.
    • Have patience, while it loads

    For some odd reason the game would crash for me until I did a manual reinstall of vcredist_x64. You can find one in your Planet Explorers folder: D:\Program Files (x86)\Steam\steamapps\common\Planet Explorers\_CommonRedist\vcredist\2010. Take the x86 version if you have a 32 bit machine (who the hell does these days?).

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!